summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2012-03-19 09:08:49 +0000
committerNaohiro Aota <naota@gentoo.org>2012-03-19 09:08:49 +0000
commitc1866aebb3b9cb9624889a99a5958800cf232b99 (patch)
tree32b7de55905545365c364053c1c656c5ed17572c /media-gfx
parentApply relevant part of debian patch to fix building with gcc-4.6 wrt #366191 ... (diff)
downloadgentoo-2-c1866aebb3b9cb9624889a99a5958800cf232b99.tar.gz
gentoo-2-c1866aebb3b9cb9624889a99a5958800cf232b99.tar.bz2
gentoo-2-c1866aebb3b9cb9624889a99a5958800cf232b99.zip
Add patch to link against proper dlopen libraly. #395347
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/pstoedit/ChangeLog8
-rw-r--r--media-gfx/pstoedit/files/pstoedit-3.60-libdl.patch13
-rw-r--r--media-gfx/pstoedit/pstoedit-3.60.ebuild7
3 files changed, 23 insertions, 5 deletions
diff --git a/media-gfx/pstoedit/ChangeLog b/media-gfx/pstoedit/ChangeLog
index 24afbf5907cb..96397b4a1c88 100644
--- a/media-gfx/pstoedit/ChangeLog
+++ b/media-gfx/pstoedit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/pstoedit
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/ChangeLog,v 1.69 2011/09/21 05:02:57 radhermit Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/ChangeLog,v 1.70 2012/03/19 09:08:49 naota Exp $
+
+ 19 Mar 2012; Naohiro Aota <naota@gentoo.org> +files/pstoedit-3.60-libdl.patch,
+ pstoedit-3.60.ebuild:
+ Add patch to link against proper dlopen libraly. #395347
*pstoedit-3.60 (21 Sep 2011)
diff --git a/media-gfx/pstoedit/files/pstoedit-3.60-libdl.patch b/media-gfx/pstoedit/files/pstoedit-3.60-libdl.patch
new file mode 100644
index 000000000000..279ed715f53a
--- /dev/null
+++ b/media-gfx/pstoedit/files/pstoedit-3.60-libdl.patch
@@ -0,0 +1,13 @@
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 6b33220..30c9f2e 100755
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -139,7 +139,7 @@ libpstoedit_la_SOURCES = \
+ genericints.h \
+ version.h
+
+-libpstoedit_la_LIBADD = ${CXX_STD_LIB} ${CXX_RUNTIME_LIB} -ldl -lm
++libpstoedit_la_LIBADD = ${CXX_STD_LIB} ${CXX_RUNTIME_LIB} ${LIBLD_LDFLAGS} -lm
+ libpstoedit_la_LDFLAGS = -no-undefined
+
+ pstoedit_SOURCES = cmdmain.cpp
diff --git a/media-gfx/pstoedit/pstoedit-3.60.ebuild b/media-gfx/pstoedit/pstoedit-3.60.ebuild
index daae38f06ca9..ea3191a31600 100644
--- a/media-gfx/pstoedit/pstoedit-3.60.ebuild
+++ b/media-gfx/pstoedit/pstoedit-3.60.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/pstoedit-3.60.ebuild,v 1.1 2011/09/21 05:02:57 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/pstoedit-3.60.ebuild,v 1.2 2012/03/19 09:08:49 naota Exp $
EAPI=4
inherit autotools eutils
@@ -30,7 +30,8 @@ src_prepare() {
-e 's:-pedantic::' \
configure.ac || die
- epatch "${FILESDIR}"/${P}-parallel.patch
+ epatch "${FILESDIR}"/${P}-parallel.patch \
+ "${FILESDIR}"/${P}-libdl.patch
eautoreconf
}