summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-04-02 14:29:43 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-04-02 14:29:43 +0000
commitc6e256314465e02fee790c4916eaedf8492e4ae4 (patch)
tree358264f43bba0a84b8466bd4e938b50eadfa9b2c /media-gfx
parentalpha/arm/ia64/m68k/s390/sh/sparc/x86 stable wrt #360891 (diff)
downloadgentoo-2-c6e256314465e02fee790c4916eaedf8492e4ae4.tar.gz
gentoo-2-c6e256314465e02fee790c4916eaedf8492e4ae4.tar.bz2
gentoo-2-c6e256314465e02fee790c4916eaedf8492e4ae4.zip
Rename USE="static" to USE="static-libs" wrt #361659. Force spidermonkey as javascript engine until xulrunner-2 support is available wrt #361663.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/freewrl/ChangeLog9
-rw-r--r--media-gfx/freewrl/freewrl-1.22.10-r1.ebuild108
-rw-r--r--media-gfx/freewrl/freewrl-1.22.10.ebuild6
3 files changed, 119 insertions, 4 deletions
diff --git a/media-gfx/freewrl/ChangeLog b/media-gfx/freewrl/ChangeLog
index 27402e763ae7..78da8bc3b835 100644
--- a/media-gfx/freewrl/ChangeLog
+++ b/media-gfx/freewrl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/freewrl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/freewrl/ChangeLog,v 1.31 2011/04/01 14:23:54 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/freewrl/ChangeLog,v 1.32 2011/04/02 14:29:43 ssuominen Exp $
+
+*freewrl-1.22.10-r1 (02 Apr 2011)
+
+ 02 Apr 2011; Samuli Suominen <ssuominen@gentoo.org> freewrl-1.22.10.ebuild,
+ +freewrl-1.22.10-r1.ebuild:
+ Rename USE="static" to USE="static-libs" wrt #361659. Force spidermonkey as
+ javascript engine until xulrunner-2 support is available wrt #361663.
01 Apr 2011; Patrick Lauer <patrick@gentoo.org> freewrl-1.22.9.ebuild,
freewrl-1.22.10.ebuild:
diff --git a/media-gfx/freewrl/freewrl-1.22.10-r1.ebuild b/media-gfx/freewrl/freewrl-1.22.10-r1.ebuild
new file mode 100644
index 000000000000..0d2bd42246c0
--- /dev/null
+++ b/media-gfx/freewrl/freewrl-1.22.10-r1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/freewrl/freewrl-1.22.10-r1.ebuild,v 1.1 2011/04/02 14:29:43 ssuominen Exp $
+
+EAPI="2"
+
+inherit nsplugins eutils flag-o-matic java-pkg-opt-2
+
+DESCRIPTION="VRML2 and X3D compliant browser"
+SRC_URI="mirror://sourceforge/freewrl/${P}.tar.bz2"
+HOMEPAGE="http://freewrl.sourceforge.net/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="curl debug libeai +glew +java +motif +sox static-libs"
+
+COMMONDEPEND="x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libX11
+ motif? ( x11-libs/openmotif )
+ media-libs/mesa
+ glew? ( media-libs/glew )
+ virtual/opengl
+ media-libs/libpng
+ virtual/jpeg
+ media-libs/imlib2
+ >=media-libs/freetype-2
+ media-libs/fontconfig
+ curl? ( net-misc/curl )
+ dev-lang/spidermonkey"
+DEPEND="${COMMONDEPEND}
+ >=dev-util/pkgconfig-0.22
+ java? ( >=virtual/jdk-1.4 )"
+RDEPEND="${COMMONDEPEND}
+ media-fonts/dejavu
+ || ( media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick] )
+ app-arch/unzip
+ java? ( >=virtual/jre-1.4 )
+ sox? ( media-sound/sox )"
+
+src_prepare() {
+ # A hack to get around expat being grabbed from xulrunner
+ mkdir "${S}/src/lib/include";
+ cp /usr/include/expat.h "${S}/src/lib/include/";
+ cp /usr/include/expat_external.h "${S}/src/lib/include/";
+}
+
+src_configure() {
+ local myconf="--enable-fontconfig --disable-plugin
+ --with-imageconvert=/usr/bin/convert
+ --with-unzip=/usr/bin/unzip"
+ if use motif; then
+ myconf="${myconf} --with-x --with-target=motif"
+ else
+ myconf="${myconf} --with-x --with-target=x11"
+ fi
+ if use sox; then
+ myconf="${myconf} --with-soundconv=/usr/bin/sox"
+ fi
+ # disable the checks for other js libs, in case they are installed
+ myconf="${myconf} --disable-mozilla-js --disable-xulrunner-js --disable-firefox-js --disable-seamonkey-js"
+ # spidermonkey has no pkg-config, so override ./configure
+ JAVASCRIPT_ENGINE_CFLAGS="-I/usr/include/js -DXP_UNIX"
+ JAVASCRIPT_ENGINE_LIBS="-ljs"
+ if has_version dev-lang/spidermonkey[threadsafe] ; then
+ JAVASCRIPT_ENGINE_CFLAGS="${JAVASCRIPT_ENGINE_CFLAGS} -DJS_THREADSAFE $(pkg-config --cflags nspr)"
+ JAVASCRIPT_ENGINE_LIBS="$(pkg-config --libs nspr) ${JAVASCRIPT_ENGINE_LIBS}"
+ fi
+ export JAVASCRIPT_ENGINE_CFLAGS
+ export JAVASCRIPT_ENGINE_LIBS
+ econf ${myconf} \
+ $(use_enable curl libcurl) \
+ $(use_with glew) \
+ $(use_enable debug) $(use_enable debug thread_colorized) \
+ $(use_enable libeai) \
+ $(use_enable java) \
+ $(use_enable static-libs static) \
+ $(use_enable sox sound)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use java; then
+ java-pkg_dojar src/java/vrml.jar
+ insinto /usr/share/${PN}/lib
+ doins src/java/java.policy
+ elog "Because vrml.jar requires access to sockets, you will need to incorporate the"
+ elog "contents of /usr/share/${PN}/lib/java.policy into your system or user's default"
+ elog "java policy."
+ fi
+
+ # remove unneeded .la files (as per Flameeyes' rant)
+ cd "${D}"
+ rm "usr/$(get_libdir)"/*.la "usr/$(get_libdir)/${PLUGINS_DIR}"/*.la
+}
+
+pkg_postinst() {
+ elog "All versions of FreeWRL are incompatible with xulrunner-2.0 and above."
+ elog "This ebuild gets around it by removing support for browser plugins and forcing"
+ elog "the javascript engine to spidermonkey. If you are willing to downgrade to"
+ elog "xulrunner-1.9 (as well as downgrade/rebuild all packages depending on it), then"
+ elog "you can get this functionality back by adding =media-gfx/freewrl-1.22.10-r1 to your"
+ elog "package.mask"
+} \ No newline at end of file
diff --git a/media-gfx/freewrl/freewrl-1.22.10.ebuild b/media-gfx/freewrl/freewrl-1.22.10.ebuild
index 0ced8269ec91..342c564da681 100644
--- a/media-gfx/freewrl/freewrl-1.22.10.ebuild
+++ b/media-gfx/freewrl/freewrl-1.22.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/freewrl/freewrl-1.22.10.ebuild,v 1.3 2011/04/01 14:23:54 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/freewrl/freewrl-1.22.10.ebuild,v 1.4 2011/04/02 14:29:43 ssuominen Exp $
EAPI="2"
@@ -13,7 +13,7 @@ HOMEPAGE="http://freewrl.sourceforge.net/"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="curl debug libeai +glew +java +motif nsplugin +sox spidermonkey static"
+IUSE="curl debug libeai +glew +java +motif nsplugin +sox spidermonkey static-libs"
COMMONDEPEND="x11-libs/libXau
x11-libs/libXdmcp
@@ -91,7 +91,7 @@ src_configure() {
$(use_enable libeai) \
$(use_enable java) \
$(use_enable nsplugin plugin) \
- $(use_enable static) \
+ $(use_enable static-libs static) \
$(use_enable sox sound)
}