summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-06-05 21:27:06 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-06-05 21:27:06 +0000
commit966ca0b93d4ca2829e34623800d3bac0ad15465c (patch)
tree77b202371608d20296e6f74f5ae6fbaa7eed2f44 /media-libs/FusionSound
parentnetbeans-6.7_rc2: version bump (diff)
downloadgentoo-2-966ca0b93d4ca2829e34623800d3bac0ad15465c.tar.gz
gentoo-2-966ca0b93d4ca2829e34623800d3bac0ad15465c.tar.bz2
gentoo-2-966ca0b93d4ca2829e34623800d3bac0ad15465c.zip
Fix automagic deps like alsa, cddb, ffmpeg, mad, timidity and vorbis. Fix ffmpeg compability wrt #238718, thanks to Victor Ostorga. Fix building with GCC 4.3 wrt #238718, thanks to Tupone Alfredo.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/FusionSound')
-rw-r--r--media-libs/FusionSound/ChangeLog17
-rw-r--r--media-libs/FusionSound/FusionSound-1.1.1.ebuild54
-rw-r--r--media-libs/FusionSound/files/FusionSound-1.1.1-ffmpeg.patch43
-rw-r--r--media-libs/FusionSound/files/FusionSound-1.1.1-gcc43.patch40
-rw-r--r--media-libs/FusionSound/metadata.xml11
5 files changed, 146 insertions, 19 deletions
diff --git a/media-libs/FusionSound/ChangeLog b/media-libs/FusionSound/ChangeLog
index 49c0144923e2..e737eeda3415 100644
--- a/media-libs/FusionSound/ChangeLog
+++ b/media-libs/FusionSound/ChangeLog
@@ -1,20 +1,23 @@
# ChangeLog for media-libs/FusionSound
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/FusionSound/ChangeLog,v 1.3 2008/04/15 14:51:43 drac Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/FusionSound/ChangeLog,v 1.4 2009/06/05 21:27:06 ssuominen Exp $
- 15 Apr 2008; Samuli Suominen <drac@gentoo.org> -FusionSound-1.0.0.ebuild,
- FusionSound-1.1.1.ebuild:
- Remove old. QAbaddep fix for current.
+ 05 Jun 2009; Samuli Suominen <ssuominen@gentoo.org>
+ FusionSound-1.1.1.ebuild, +files/FusionSound-1.1.1-ffmpeg.patch,
+ +files/FusionSound-1.1.1-gcc43.patch:
+ Fix automagic deps like alsa, cddb, ffmpeg, mad, timidity and vorbis. Fix
+ ffmpeg compability wrt #238718, thanks to Victor Ostorga. Fix building
+ with GCC 4.3 wrt #238718, thanks to Tupone Alfredo.
*FusionSound-1.1.1 (19 Mar 2008)
19 Mar 2008; Joerg Bornkessel <hd_brummy@gentoo.org>
+FusionSound-1.1.1.ebuild:
- version bump; bug 205833
+ Version bump wrt #205833.
*FusionSound-1.0.0 (24 Aug 2007)
24 Aug 2007; Joerg Bornkessel <hd_brummy@gentoo.org> +metadata.xml,
+FusionSound-1.0.0.ebuild:
- initial ebuild
+ Initial ebuild.
diff --git a/media-libs/FusionSound/FusionSound-1.1.1.ebuild b/media-libs/FusionSound/FusionSound-1.1.1.ebuild
index e843c519432f..927563904fc7 100644
--- a/media-libs/FusionSound/FusionSound-1.1.1.ebuild
+++ b/media-libs/FusionSound/FusionSound-1.1.1.ebuild
@@ -1,6 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/FusionSound/FusionSound-1.1.1.ebuild,v 1.2 2008/04/15 14:51:43 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/FusionSound/FusionSound-1.1.1.ebuild,v 1.3 2009/06/05 21:27:06 ssuominen Exp $
+
+EAPI=2
+inherit autotools eutils
DESCRIPTION="Audio sub system for multiple applications"
HOMEPAGE="http://www.directfb.org/"
@@ -9,14 +12,53 @@ SRC_URI="http://www.directfb.org/downloads/Core/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="vorbis mp3"
+IUSE="alsa cddb ffmpeg mad oss timidity vorbis"
RDEPEND=">=dev-libs/DirectFB-${PV}
+ alsa? ( media-libs/alsa-lib )
+ timidity? ( media-libs/libtimidity
+ media-sound/timidity++ )
vorbis? ( media-libs/libvorbis )
- mp3? ( media-libs/libmad )"
+ mad? ( media-libs/libmad )
+ cddb? ( media-libs/libcddb )
+ ffmpeg? ( >=media-video/ffmpeg-0.5 )"
DEPEND="${RDEPEND}
- dev-util/pkgconfig"
+ dev-util/pkgconfig
+ sys-apps/sed"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-ffmpeg.patch
+ sed -i -e 's:-O3 -ffast-math -pipe::' configure.in \
+ || die "sed failed"
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ local myaudio="wave"
+
+ use alsa && myaudio="${myaudio} alsa"
+ use oss && myaudio="${myaudio} oss"
+
+ # Lite is used only for tests or examples.
+ # Tremor isn't there with latest libvorbis.
+ econf \
+ --disable-dependency-tracking \
+ --without-lite \
+ --with-drivers="${myaudio}" \
+ --without-examples \
+ $(use_with timidity) \
+ --with-wave \
+ $(use_with vorbis) \
+ --without-tremor \
+ $(use_with mad) \
+ $(use_with cddb cdda) \
+ $(use_with ffmpeg) \
+ --with-playlist
+}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
+ emake DESTDIR="${D}" htmldir=/usr/share/doc/${PF}/html \
+ install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
}
diff --git a/media-libs/FusionSound/files/FusionSound-1.1.1-ffmpeg.patch b/media-libs/FusionSound/files/FusionSound-1.1.1-ffmpeg.patch
new file mode 100644
index 000000000000..8135157b3f31
--- /dev/null
+++ b/media-libs/FusionSound/files/FusionSound-1.1.1-ffmpeg.patch
@@ -0,0 +1,43 @@
+diff -Naurp FusionSound-1.1.1-original/configure.in FusionSound-1.1.1/configure.in
+--- FusionSound-1.1.1-original/configure.in 2008-02-11 05:31:45.000000000 -0600
++++ FusionSound-1.1.1/configure.in 2009-04-10 15:18:02.000000000 -0600
+@@ -513,11 +513,11 @@ AC_ARG_WITH(ffmpeg,
+
+ if test "x$with_ffmpeg" = "xyes"; then
+ AC_MSG_CHECKING([for libavcodec/libavformat])
+- if $PKG_CONFIG libavcodec libavformat; then
++ if $PKG_CONFIG libavcodec libavformat libavutil; then
+ AC_MSG_RESULT(yes)
+ ffmpeg="yes"
+- FFMPEG_CFLAGS=`$PKG_CONFIG --cflags libavcodec libavformat`
+- FFMPEG_LIBS=`$PKG_CONFIG --libs libavcodec libavformat`
++ FFMPEG_CFLAGS=`$PKG_CONFIG --cflags libavcodec libavformat libavutil`
++ FFMPEG_LIBS=`$PKG_CONFIG --libs libavcodec libavformat libavutil`
+ else
+ AC_MSG_RESULT(no)
+ AC_MSG_WARN([
+diff -Naurp FusionSound-1.1.1-original/interfaces/IFusionSoundMusicProvider/ifusionsoundmusicprovider_ffmpeg.c FusionSound-1.1.1/interfaces/IFusionSoundMusicProvider/ifusionsoundmusicprovider_ffmpeg.c
+--- FusionSound-1.1.1-original/interfaces/IFusionSoundMusicProvider/ifusionsoundmusicprovider_ffmpeg.c 2008-02-11 05:31:45.000000000 -0600
++++ FusionSound-1.1.1/interfaces/IFusionSoundMusicProvider/ifusionsoundmusicprovider_ffmpeg.c 2009-04-10 15:18:21.000000000 -0600
+@@ -41,8 +41,8 @@
+
+ #include <misc/sound_util.h>
+
+-#include <avcodec.h>
+-#include <avformat.h>
++#include <libavcodec/avcodec.h>
++#include <libavformat/avformat.h>
+
+ static DFBResult
+ Probe( IFusionSoundMusicProvider_ProbeContext *ctx );
+@@ -123,8 +123,8 @@ av_read_callback( void *opaque, uint8_t
+ return len;
+ }
+
+-static offset_t
+-av_seek_callback( void *opaque, offset_t offset, int whence )
++static int64_t
++av_seek_callback( void *opaque, int64_t offset, int whence )
+ {
+ IFusionSoundMusicProvider_FFmpeg_data *data = opaque;
+ unsigned int pos = 0;
diff --git a/media-libs/FusionSound/files/FusionSound-1.1.1-gcc43.patch b/media-libs/FusionSound/files/FusionSound-1.1.1-gcc43.patch
new file mode 100644
index 000000000000..5ebdfbcf1eeb
--- /dev/null
+++ b/media-libs/FusionSound/files/FusionSound-1.1.1-gcc43.patch
@@ -0,0 +1,40 @@
+--- src/fusionsound.c.old 2009-01-16 14:28:27.000000000 +0100
++++ src/fusionsound.c 2009-01-16 14:33:34.000000000 +0100
+@@ -116,7 +116,7 @@
+ return fs_config_set( name, value );
+ }
+
+-DirectResult
++DFBResult
+ FusionSoundCreate( IFusionSound **ret_interface )
+ {
+ DFBResult ret;
+@@ -160,8 +160,8 @@
+ return ret;
+ }
+
+-DirectResult
+-FusionSoundError( const char *msg, DirectResult error )
++DFBResult
++FusionSoundError( const char *msg, DFBResult error )
+ {
+ if (msg)
+ fprintf( stderr, "(#) FusionSound Error [%s]: %s\n", msg, DirectResultString( error ) );
+@@ -172,7 +172,7 @@
+ }
+
+ DFBResult
+-FusionSoundErrorFatal( const char *msg, DirectResult error )
++FusionSoundErrorFatal( const char *msg, DFBResult error )
+ {
+ FusionSoundError( msg, error );
+
+@@ -180,7 +180,7 @@
+ }
+
+ const char *
+-FusionSoundErrorString( DirectResult error )
++FusionSoundErrorString( DFBResult error )
+ {
+ return DirectResultString( error );
+ }
diff --git a/media-libs/FusionSound/metadata.xml b/media-libs/FusionSound/metadata.xml
index a402e786e9b6..5e71b4c24efb 100644
--- a/media-libs/FusionSound/metadata.xml
+++ b/media-libs/FusionSound/metadata.xml
@@ -1,10 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>video</herd>
-<maintainer>
-<email>hd_brummy@gentoo.org</email>
-<name>Joerg Bornkessel</name>
-</maintainer>
+ <herd>sound</herd>
+ <maintainer>
+ <email>hd_brummy@gentoo.org</email>
+ <name>Joerg Bornkessel</name>
+ </maintainer>
</pkgmetadata>
-