summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-06-23 21:24:11 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-06-23 21:24:11 +0000
commit5e656057cfaaeebca30be5770765fa5cb1dcc248 (patch)
tree01877d673eac456ec1a8c627e5b8233347d72a73 /media-libs/alsa-lib
parentVersion bump. (diff)
downloadgentoo-2-5e656057cfaaeebca30be5770765fa5cb1dcc248.tar.gz
gentoo-2-5e656057cfaaeebca30be5770765fa5cb1dcc248.tar.bz2
gentoo-2-5e656057cfaaeebca30be5770765fa5cb1dcc248.zip
Version bump wrt #513670 by "PG". Use PYTHON_REQUIRED_USE wrt #509308 by Maciej Piechotka.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-libs/alsa-lib')
-rw-r--r--media-libs/alsa-lib/ChangeLog9
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.27.2.ebuild4
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.28.ebuild85
3 files changed, 96 insertions, 2 deletions
diff --git a/media-libs/alsa-lib/ChangeLog b/media-libs/alsa-lib/ChangeLog
index c3016778219a..91c2cb636ddd 100644
--- a/media-libs/alsa-lib/ChangeLog
+++ b/media-libs/alsa-lib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/alsa-lib
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.391 2014/04/28 17:46:53 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.392 2014/06/23 21:24:11 ssuominen Exp $
+
+*alsa-lib-1.0.28 (23 Jun 2014)
+
+ 23 Jun 2014; Samuli Suominen <ssuominen@gentoo.org> +alsa-lib-1.0.28.ebuild,
+ alsa-lib-1.0.27.2.ebuild:
+ Version bump wrt #513670 by "PG". Use PYTHON_REQUIRED_USE wrt #509308 by
+ Maciej Piechotka.
28 Apr 2014; Michał Górny <mgorny@gentoo.org> alsa-lib-1.0.27.2.ebuild:
Replace multilib_build_binaries with multilib_is_native_abi. The two are
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.27.2.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.27.2.ebuild
index 2eb804dec472..237daeab32fe 100644
--- a/media-libs/alsa-lib/alsa-lib-1.0.27.2.ebuild
+++ b/media-libs/alsa-lib/alsa-lib-1.0.27.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.27.2.ebuild,v 1.13 2014/04/28 17:46:53 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.27.2.ebuild,v 1.14 2014/06/23 21:24:11 ssuominen Exp $
EAPI=5
@@ -26,6 +26,8 @@ RDEPEND="python? ( ${PYTHON_DEPS} )
DEPEND="${RDEPEND}
doc? ( >=app-doc/doxygen-1.2.6 )"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
pkg_setup() {
use python && python-single-r1_pkg_setup
}
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.28.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.28.ebuild
new file mode 100644
index 000000000000..2f2c1c84bf5b
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.0.28.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.28.ebuild,v 1.1 2014/06/23 21:24:11 ssuominen Exp $
+
+EAPI=5
+
+# no support for python3_2 or above yet wrt #471326
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils multilib multilib-minimal python-single-r1
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/lib/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc debug alisp python"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-soundlibs-20130224-r1
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ find . -name Makefile.am -exec sed -i -e '/CFLAGS/s:-g -O2::' {} + || die
+ epatch_user
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myconf
+ # enable Python only on final ABI
+ if multilib_is_native_abi; then
+ myconf="$(use_enable python)"
+ else
+ myconf="--disable-python"
+ fi
+ use elibc_uclibc && myconf+=" --without-versioned"
+
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-maintainer-mode \
+ --enable-shared \
+ --disable-resmgr \
+ --enable-rawmidi \
+ --enable-seq \
+ --enable-aload \
+ $(use_with debug) \
+ $(use_enable alisp) \
+ ${myconf}
+}
+
+multilib_src_compile() {
+ emake
+
+ if multilib_is_native_abi && use doc; then
+ emake doc
+ fgrep -Zrl "${S}" doc/doxygen/html | \
+ xargs -0 sed -i -e "s:${S}::"
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ if multilib_is_native_abi && use doc; then
+ dohtml -r doc/doxygen/html/.
+ fi
+}
+
+multilib_src_install_all() {
+ prune_libtool_files --all
+ find "${ED}"/usr/$(get_libdir)/alsa-lib -name '*.a' -exec rm -f {} +
+ dodoc ChangeLog doc/asoundrc.txt NOTES TODO
+}