summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2015-03-25 11:35:17 +0000
committerTony Vroon <chainsaw@gentoo.org>2015-03-25 11:35:17 +0000
commitb4409521d1ed76ad10d43e7e9e5aa769eaac332e (patch)
tree09546f2703fb0cefbbfcaa2e5dc715c92c7427bf /media-libs/alsa-lib
parentEnforce sys-auth/polkit-qt USE dependency wrt bug #544412. (diff)
downloadgentoo-2-b4409521d1ed76ad10d43e7e9e5aa769eaac332e.tar.gz
gentoo-2-b4409521d1ed76ad10d43e7e9e5aa769eaac332e.tar.bz2
gentoo-2-b4409521d1ed76ad10d43e7e9e5aa769eaac332e.zip
Version bump, as requested by Manuel Rüger in bug #541798.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
Diffstat (limited to 'media-libs/alsa-lib')
-rw-r--r--media-libs/alsa-lib/ChangeLog7
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.29.ebuild87
2 files changed, 93 insertions, 1 deletions
diff --git a/media-libs/alsa-lib/ChangeLog b/media-libs/alsa-lib/ChangeLog
index a5167839600e..bc3da6db22ef 100644
--- a/media-libs/alsa-lib/ChangeLog
+++ b/media-libs/alsa-lib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/alsa-lib
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.402 2015/03/03 08:20:32 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.403 2015/03/25 11:35:17 chainsaw Exp $
+
+*alsa-lib-1.0.29 (25 Mar 2015)
+
+ 25 Mar 2015; Tony Vroon <chainsaw@gentoo.org> +alsa-lib-1.0.29.ebuild:
+ Version bump, as requested by Manuel Rüger in bug #541798.
03 Mar 2015; Yixun Lan <dlan@gentoo.org> alsa-lib-1.0.28.ebuild:
add arm64 support, tested on A53 board
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.29.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.29.ebuild
new file mode 100644
index 000000000000..55ec1237a146
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.0.29.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.29.ebuild,v 1.1 2015/03/25 11:35:17 chainsaw Exp $
+
+EAPI=5
+
+# no support for python3_2 or above yet wrt #471326
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils multilib multilib-minimal python-single-r1
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/lib/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="alisp debug doc elibc_uclibc python"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-soundlibs-20130224-r1
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ find . -name Makefile.am -exec sed -i -e '/CFLAGS/s:-g -O2::' {} + || die
+ # http://bugs.gentoo.org/509886
+ use elibc_uclibc && { sed -i -e 's:oldapi queue_timer:queue_timer:' test/Makefile.am || die; }
+ epatch_user
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myconf
+ # enable Python only on final ABI
+ if multilib_is_native_abi; then
+ myconf="$(use_enable python)"
+ else
+ myconf="--disable-python"
+ fi
+ use elibc_uclibc && myconf+=" --without-versioned"
+
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-maintainer-mode \
+ --enable-shared \
+ --disable-resmgr \
+ --enable-rawmidi \
+ --enable-seq \
+ --enable-aload \
+ $(use_with debug) \
+ $(use_enable alisp) \
+ ${myconf}
+}
+
+multilib_src_compile() {
+ emake
+
+ if multilib_is_native_abi && use doc; then
+ emake doc
+ fgrep -Zrl "${S}" doc/doxygen/html | \
+ xargs -0 sed -i -e "s:${S}::"
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ if multilib_is_native_abi && use doc; then
+ dohtml -r doc/doxygen/html/.
+ fi
+}
+
+multilib_src_install_all() {
+ prune_libtool_files --all
+ find "${ED}"/usr/$(get_libdir)/alsa-lib -name '*.a' -exec rm -f {} +
+ dodoc ChangeLog doc/asoundrc.txt NOTES TODO
+}