summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-01-26 21:00:27 +0000
committerDan Armak <danarmak@gentoo.org>2002-01-26 21:00:27 +0000
commit07e11f56f33a352c8eceb139bd0f4f7020e23b9c (patch)
tree540cd3f489bd61e8008d53b2743f83031447e444 /media-libs/gltt
parentNew version, removed old one (diff)
downloadgentoo-2-07e11f56f33a352c8eceb139bd0f4f7020e23b9c.tar.gz
gentoo-2-07e11f56f33a352c8eceb139bd0f4f7020e23b9c.tar.bz2
gentoo-2-07e11f56f33a352c8eceb139bd0f4f7020e23b9c.zip
new: gltt library - use truetype fonts in opengl apps, needed for upcoming k3studio ebuild
Diffstat (limited to 'media-libs/gltt')
-rw-r--r--media-libs/gltt/files/digest-gltt-2.5.21
-rw-r--r--media-libs/gltt/gltt-2.5.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/gltt/files/digest-gltt-2.5.2 b/media-libs/gltt/files/digest-gltt-2.5.2
new file mode 100644
index 000000000000..0fd16c0b7f61
--- /dev/null
+++ b/media-libs/gltt/files/digest-gltt-2.5.2
@@ -0,0 +1 @@
+MD5 1098121fc2b2e66ba0cbc979c1e7d21c gltt-2.5.2.tar.gz 221184
diff --git a/media-libs/gltt/gltt-2.5.2.ebuild b/media-libs/gltt/gltt-2.5.2.ebuild
new file mode 100644
index 000000000000..3077fcd74567
--- /dev/null
+++ b/media-libs/gltt/gltt-2.5.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gltt/gltt-2.5.2.ebuild,v 1.1 2002/01/26 21:00:27 danarmak Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GL truetype library"
+SRC_URI="http://gltt.sourceforge.net/download/${P}.tar.gz"
+HOMEPAGE="http://gltt.sourceforge.net/"
+
+DEPEND="virtual/glibc
+ virtual/opengl
+ virtual/glut
+ virtual/x11
+ >=media-libs/freetype-1.3.1"
+RDEPEND="$DEPEND"
+
+src_compile() {
+
+ ./configure --with-x \
+ --prefix=/usr \
+ --with-ttf-dir=/usr || die
+
+ make || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D}/usr install || die
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+
+}
+
+