summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2011-03-20 08:20:45 +0000
committerMart Raudsepp <leio@gentoo.org>2011-03-20 08:20:45 +0000
commita288c702741c22bd789b49699335334e4cb90b9d (patch)
treec1ae1869b050f8fa1a133d43f267006f959ba95b /media-libs/gst-plugins-good
parentRemoved virtual/PodParser from dep again and correct perl to be only a build dep (diff)
downloadgentoo-2-a288c702741c22bd789b49699335334e4cb90b9d.tar.gz
gentoo-2-a288c702741c22bd789b49699335334e4cb90b9d.tar.bz2
gentoo-2-a288c702741c22bd789b49699335334e4cb90b9d.zip
Version bump. Uses orc instead of liboil for CPU detection and new optimizations (in deinterlace, videobox and videomixer). Disable examples building (we do not install them anyway) to avoid bug #348623. Huge amount of new upstream features, bug fixes and improvements that are too numerous to summarize here - check upstream release notes from 0.10.24 through 0.10.28 if interested.
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/gst-plugins-good')
-rw-r--r--media-libs/gst-plugins-good/ChangeLog13
-rw-r--r--media-libs/gst-plugins-good/gst-plugins-good-0.10.28.ebuild69
-rw-r--r--media-libs/gst-plugins-good/metadata.xml5
3 files changed, 85 insertions, 2 deletions
diff --git a/media-libs/gst-plugins-good/ChangeLog b/media-libs/gst-plugins-good/ChangeLog
index f8d0ae272917..5226cf50149f 100644
--- a/media-libs/gst-plugins-good/ChangeLog
+++ b/media-libs/gst-plugins-good/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for media-libs/gst-plugins-good
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/ChangeLog,v 1.111 2011/03/11 18:31:56 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/ChangeLog,v 1.112 2011/03/20 08:20:45 leio Exp $
+
+*gst-plugins-good-0.10.28 (20 Mar 2011)
+
+ 20 Mar 2011; Mart Raudsepp <leio@gentoo.org> metadata.xml,
+ +gst-plugins-good-0.10.28.ebuild:
+ Version bump. Uses orc instead of liboil for CPU detection and new
+ optimizations (in deinterlace, videobox and videomixer). Disable examples
+ building (we do not install them anyway) to avoid bug #348623. Huge amount
+ of new upstream features, bug fixes and improvements that are too numerous
+ to summarize here - check upstream release notes from 0.10.24 through
+ 0.10.28 if interested.
11 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org>
gst-plugins-good-0.10.23.ebuild:
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-0.10.28.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-0.10.28.ebuild
new file mode 100644
index 000000000000..e9d23da38964
--- /dev/null
+++ b/media-libs/gst-plugins-good/gst-plugins-good-0.10.28.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/gst-plugins-good-0.10.28.ebuild,v 1.1 2011/03/20 08:20:45 leio Exp $
+
+EAPI=1
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins-good gst-plugins10 gnome2 eutils flag-o-matic libtool
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.net/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="+orc"
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.32
+ >=media-libs/gstreamer-0.10.32
+ orc? ( >=dev-lang/orc-0.4.11 )
+ sys-libs/zlib
+ app-arch/bzip2"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.11.5
+ dev-util/pkgconfig
+ !<media-libs/gst-plugins-bad-0.10.19"
+
+# Always enable optional bz2 support for matroska
+# Always enable optional zlib support for qtdemux, id3demux and matroska
+# Many media files require these to work, as some container headers are often compressed, bug 291154
+GST_PLUGINS_BUILD="bz2 zlib"
+
+src_compile() {
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+
+ gst-plugins-good_src_configure \
+ $(use_enable orc) \
+ --disable-examples \
+ --with-default-audiosink=autoaudiosink \
+ --with-default-visualizer=goom
+
+ emake || die "emake failed."
+}
+
+# override eclass
+src_install() {
+ gnome2_src_install
+}
+
+DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+
+pkg_postinst () {
+ gnome2_pkg_postinst
+
+ echo
+ elog "The Gstreamer plugins setup has changed quite a bit on Gentoo,"
+ elog "applications now should provide the basic plugins needed."
+ echo
+ elog "The new seperate plugins are all named 'gst-plugins-<plugin>'."
+ elog "To get a listing of currently available plugins execute 'emerge -s gst-plugins-'."
+ elog "In most cases it shouldn't be needed though to emerge extra plugins."
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+}
diff --git a/media-libs/gst-plugins-good/metadata.xml b/media-libs/gst-plugins-good/metadata.xml
index 6cb5dfb547c2..1e851910a311 100644
--- a/media-libs/gst-plugins-good/metadata.xml
+++ b/media-libs/gst-plugins-good/metadata.xml
@@ -2,5 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>gstreamer</herd>
- <herd>gnome</herd>
+ <use>
+ <flag name="orc">Use <pkg>dev-lang/orc</pkg> for runtime
+ optimisations</flag>
+ </use>
</pkgmetadata>