summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-06-05 11:29:57 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-06-05 11:29:57 +0000
commitc9d2a45e8a373510d3b0465832dbaff1716a0304 (patch)
treeaef462d87729981987f8130f7ffe7dd41ddbc3d7 /media-libs/harfbuzz
parentrevbump, migrate -> distutils-r1, remove old, add test phase (diff)
downloadgentoo-2-c9d2a45e8a373510d3b0465832dbaff1716a0304.tar.gz
gentoo-2-c9d2a45e8a373510d3b0465832dbaff1716a0304.tar.bz2
gentoo-2-c9d2a45e8a373510d3b0465832dbaff1716a0304.zip
Version bump to 0.9.18 fixing bug#472346.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'media-libs/harfbuzz')
-rw-r--r--media-libs/harfbuzz/ChangeLog9
-rw-r--r--media-libs/harfbuzz/files/harfbuzz-0.9.18-ldadd.patch27
-rw-r--r--media-libs/harfbuzz/harfbuzz-0.9.18.ebuild70
-rw-r--r--media-libs/harfbuzz/harfbuzz-9999.ebuild25
-rw-r--r--media-libs/harfbuzz/metadata.xml4
5 files changed, 126 insertions, 9 deletions
diff --git a/media-libs/harfbuzz/ChangeLog b/media-libs/harfbuzz/ChangeLog
index 3ed2e0f368ae..f793f1d059f0 100644
--- a/media-libs/harfbuzz/ChangeLog
+++ b/media-libs/harfbuzz/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/harfbuzz
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/harfbuzz/ChangeLog,v 1.33 2013/05/21 10:31:14 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/harfbuzz/ChangeLog,v 1.34 2013/06/05 11:29:56 scarabeus Exp $
+
+*harfbuzz-0.9.18 (05 Jun 2013)
+
+ 05 Jun 2013; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/harfbuzz-0.9.18-ldadd.patch, +harfbuzz-0.9.18.ebuild,
+ harfbuzz-9999.ebuild, metadata.xml:
+ Version bump to 0.9.18 fixing bug#472346.
*harfbuzz-0.9.17 (21 May 2013)
diff --git a/media-libs/harfbuzz/files/harfbuzz-0.9.18-ldadd.patch b/media-libs/harfbuzz/files/harfbuzz-0.9.18-ldadd.patch
new file mode 100644
index 000000000000..6b76e350288b
--- /dev/null
+++ b/media-libs/harfbuzz/files/harfbuzz-0.9.18-ldadd.patch
@@ -0,0 +1,27 @@
+From 2966d3603259430800cb5880491d28a1c5ea2314 Mon Sep 17 00:00:00 2001
+From: Behdad Esfahbod <behdad@behdad.org>
+Date: Tue, 28 May 2013 21:34:37 +0000
+Subject: Fix test build
+
+---
+diff --git a/test/api/Makefile.am b/test/api/Makefile.am
+index bef7716..4ff14fa 100644
+--- a/test/api/Makefile.am
++++ b/test/api/Makefile.am
+@@ -28,12 +28,13 @@ TEST_PROGS = \
+ $(NULL)
+
+ test_unicode_CPPFLAGS = $(AM_CPPFLAGS)
++test_unicode_LDADD = $(LDADD)
+ if HAVE_GLIB
+ test_unicode_CPPFLAGS += $(GLIB_CFLAGS)
+ endif
+ if HAVE_ICU
+ test_unicode_CPPFLAGS += $(ICU_CFLAGS)
+-test_unicode_LDADD = $(LDADD) $(top_builddir)/src/libharfbuzz-icu.la
++test_unicode_LDADD += $(top_builddir)/src/libharfbuzz-icu.la
+ endif
+
+
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/media-libs/harfbuzz/harfbuzz-0.9.18.ebuild b/media-libs/harfbuzz/harfbuzz-0.9.18.ebuild
new file mode 100644
index 000000000000..0ac05c67e61b
--- /dev/null
+++ b/media-libs/harfbuzz/harfbuzz-0.9.18.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/harfbuzz/harfbuzz-0.9.18.ebuild,v 1.1 2013/06/05 11:29:56 scarabeus Exp $
+
+EAPI=5
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/harfbuzz"
+[[ ${PV} == 9999 ]] && inherit git-2 autotools
+
+inherit eutils libtool autotools
+
+DESCRIPTION="An OpenType text shaping engine"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/HarfBuzz"
+[[ ${PV} == 9999 ]] || SRC_URI="http://www.freedesktop.org/software/${PN}/release/${P}.tar.bz2"
+
+LICENSE="Old-MIT ISC icu"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x86-macos ~x64-macos ~x64-solaris"
+IUSE="+cairo +glib +graphite icu static-libs +truetype"
+
+RDEPEND="
+ cairo? ( x11-libs/cairo:= )
+ glib? ( dev-libs/glib:2 )
+ graphite? ( media-gfx/graphite2:= )
+ icu? ( dev-libs/icu:= )
+ truetype? ( media-libs/freetype:2= )
+"
+DEPEND="${RDEPEND}
+ dev-util/ragel
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # on Darwin we need to link with g++, like automake defaults to,
+ # but overridden by upstream because on Linux this is not
+ # necessary, bug #449126
+ sed -i \
+ -e 's/\<LINK\>/CXXLINK/' \
+ src/Makefile.am || die
+ sed -i \
+ -e '/libharfbuzz_la_LINK = /s/\<LINK\>/CXXLINK/' \
+ src/Makefile.in || die
+ fi
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+ elibtoolize # for building a shared library on x64-solaris
+
+ epatch "${FILESDIR}/${P}-ldadd.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --without-coretext \
+ --without-uniscribe \
+ $(use_enable static-libs static) \
+ $(use_with cairo) \
+ $(use_with glib) \
+ $(use_with graphite graphite2) \
+ $(use_with icu) \
+ $(use_with truetype freetype)
+
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}
diff --git a/media-libs/harfbuzz/harfbuzz-9999.ebuild b/media-libs/harfbuzz/harfbuzz-9999.ebuild
index e12aebcc6138..c7a2f3eddef1 100644
--- a/media-libs/harfbuzz/harfbuzz-9999.ebuild
+++ b/media-libs/harfbuzz/harfbuzz-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/harfbuzz/harfbuzz-9999.ebuild,v 1.13 2013/02/27 23:34:03 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/harfbuzz/harfbuzz-9999.ebuild,v 1.14 2013/06/05 11:29:56 scarabeus Exp $
EAPI=5
@@ -17,16 +17,17 @@ LICENSE="Old-MIT ISC icu"
SLOT="0"
[[ ${PV} == 9999 ]] || \
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x86-macos ~x64-macos ~x64-solaris"
-IUSE="static-libs"
+IUSE="+cairo +glib +graphite icu static-libs +truetype"
RDEPEND="
- dev-libs/glib:2
- dev-libs/icu:=
- media-gfx/graphite2:=
- media-libs/freetype:2=
- x11-libs/cairo:=
+ cairo? ( x11-libs/cairo:= )
+ glib? ( dev-libs/glib:2 )
+ graphite? ( media-gfx/graphite2:= )
+ icu? ( dev-libs/icu:= )
+ truetype? ( media-libs/freetype:2= )
"
DEPEND="${RDEPEND}
+ dev-util/ragel
virtual/pkgconfig
"
@@ -48,7 +49,15 @@ src_prepare() {
src_configure() {
econf \
- $(use_enable static-libs static)
+ --without-coretext \
+ --without-uniscribe \
+ $(use_enable static-libs static) \
+ $(use_with cairo) \
+ $(use_with glib) \
+ $(use_with graphite graphite2) \
+ $(use_with icu) \
+ $(use_with truetype freetype)
+
}
src_install() {
diff --git a/media-libs/harfbuzz/metadata.xml b/media-libs/harfbuzz/metadata.xml
index 8c6a9ff92ec5..76b20737ffdf 100644
--- a/media-libs/harfbuzz/metadata.xml
+++ b/media-libs/harfbuzz/metadata.xml
@@ -3,4 +3,8 @@
<pkgmetadata>
<herd>openoffice</herd>
<herd>gnome</herd>
+ <use>
+ <flag name="glib">Compile with GLib Unicode support</flag>
+ <flag name="graphite">Use graphite to render complex non-Roman writing systems</flag>
+ </use>
</pkgmetadata>