summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-08 01:53:50 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-08 01:53:50 +0000
commit5c83f1a4b06ac8779b6c7184f4d2e75e6041e589 (patch)
treeea020da7194f78232a385b548a1f36edb30c4420 /media-libs/hermes
parentppc (diff)
downloadgentoo-2-5c83f1a4b06ac8779b6c7184f4d2e75e6041e589.tar.gz
gentoo-2-5c83f1a4b06ac8779b6c7184f4d2e75e6041e589.tar.bz2
gentoo-2-5c83f1a4b06ac8779b6c7184f4d2e75e6041e589.zip
fix autotools bs #40739
Diffstat (limited to 'media-libs/hermes')
-rw-r--r--media-libs/hermes/hermes-1.3.2-r2.ebuild26
1 files changed, 10 insertions, 16 deletions
diff --git a/media-libs/hermes/hermes-1.3.2-r2.ebuild b/media-libs/hermes/hermes-1.3.2-r2.ebuild
index 0c670caa8070..6f44b02e5f2f 100644
--- a/media-libs/hermes/hermes-1.3.2-r2.ebuild
+++ b/media-libs/hermes/hermes-1.3.2-r2.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/hermes/hermes-1.3.2-r2.ebuild,v 1.13 2003/09/29 17:27:55 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/hermes/hermes-1.3.2-r2.ebuild,v 1.14 2004/02/08 01:53:50 vapier Exp $
inherit gnuconfig
MY_P=${P/h/H}
S=${WORKDIR}/${MY_P}
DESCRIPTION="Library for fast colorspace conversion and other graphics routines"
+HOMEPAGE="http://hermes.terminal.at/"
SRC_URI="http://dark.x.dtu.dk/~mbn/clanlib/download/download-sphair/${MY_P}.tar.gz"
-HOMEPAGE="http://hermes.terminal.at"
-SLOT="0"
LICENSE="LGPL-2"
+SLOT="0"
KEYWORDS="x86 ppc sparc alpha ~mips amd64"
DEPEND="sys-devel/libtool
@@ -23,24 +23,18 @@ src_unpack() {
cd ${S} || die
use alpha && gnuconfig_update
use amd64 && gnuconfig_update
+ aclocal || die "aclocal failed"
+ env WANT_AUTOMAKE=1.4 automake -a || die "automake failed"
+ autoconf || die "autoconf failed"
}
src_compile() {
-
- aclocal || die
- automake -a
- autoconf || die
-
- ./configure \
- --prefix=/usr || die
-
- sh ltconfig ltmain.sh || die
- emake || die
-
+ econf || die
+ sh ltconfig ltmain.sh || die "ltconfig failed"
+ emake || die "make failed"
}
-src_install () {
-
+src_install() {
make \
prefix=${D}/usr \
install || die