summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-15 03:30:23 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-15 03:30:23 +0000
commit9ae77eb75c3dd9725eca4c6fbd808d22b5844f8c (patch)
tree2d6f4a9142c7ce40e0b4714f996af61425e47f6f /media-libs/libao
parentarm/sh love (diff)
downloadgentoo-2-9ae77eb75c3dd9725eca4c6fbd808d22b5844f8c.tar.gz
gentoo-2-9ae77eb75c3dd9725eca4c6fbd808d22b5844f8c.tar.bz2
gentoo-2-9ae77eb75c3dd9725eca4c6fbd808d22b5844f8c.zip
arm/sh love, misc touchups, and punt USE=static garbage
(Portage version: 2.1.1_pre2-r4)
Diffstat (limited to 'media-libs/libao')
-rw-r--r--media-libs/libao/files/digest-libao-0.8.52
-rw-r--r--media-libs/libao/files/digest-libao-0.8.6-r12
-rw-r--r--media-libs/libao/libao-0.8.5.ebuild19
-rw-r--r--media-libs/libao/libao-0.8.6-r1.ebuild19
-rw-r--r--media-libs/libao/libao-0.8.6-r2.ebuild19
5 files changed, 34 insertions, 27 deletions
diff --git a/media-libs/libao/files/digest-libao-0.8.5 b/media-libs/libao/files/digest-libao-0.8.5
index c7f25da7ed3a..1dbe5c506211 100644
--- a/media-libs/libao/files/digest-libao-0.8.5
+++ b/media-libs/libao/files/digest-libao-0.8.5
@@ -1 +1,3 @@
MD5 dd72b66f5f29361411bda465470b65e2 libao-0.8.5.tar.gz 267283
+RMD160 5e4593915ec3c5affd110f345dbfe9ae2f808e86 libao-0.8.5.tar.gz 267283
+SHA256 fd9d8447f81a86d3d991dc137609b087560e0affea94e7430a59bc0ca62e0d82 libao-0.8.5.tar.gz 267283
diff --git a/media-libs/libao/files/digest-libao-0.8.6-r1 b/media-libs/libao/files/digest-libao-0.8.6-r1
index bb1e0d16cc39..683f564f94dc 100644
--- a/media-libs/libao/files/digest-libao-0.8.6-r1
+++ b/media-libs/libao/files/digest-libao-0.8.6-r1
@@ -2,3 +2,5 @@ MD5 12e136a4c0995068ff134997c84421ed libao-0.8.6.tar.gz 387583
RMD160 650258240295f221e95d39cf2380ada73f3cb4e1 libao-0.8.6.tar.gz 387583
SHA256 99565c6f8a560abc24bf6c07726737d54db64daae08c8708fc9e8f3aeb723985 libao-0.8.6.tar.gz 387583
MD5 5ed655e04ed0f827b88d390dc3528896 libao-patches-2.tar.bz2 2208
+RMD160 5686800c595f6f3d6a8d96278e4089705bcf765a libao-patches-2.tar.bz2 2208
+SHA256 0ced633f4e7c7d498aadda370e5e677b7847500db37d07127933625c245d25e7 libao-patches-2.tar.bz2 2208
diff --git a/media-libs/libao/libao-0.8.5.ebuild b/media-libs/libao/libao-0.8.5.ebuild
index 502fa80b8f02..1fa9dc9dbede 100644
--- a/media-libs/libao/libao-0.8.5.ebuild
+++ b/media-libs/libao/libao-0.8.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libao/libao-0.8.5.ebuild,v 1.19 2006/03/06 14:28:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libao/libao-0.8.5.ebuild,v 1.20 2006/07/15 03:30:23 vapier Exp $
inherit libtool eutils
@@ -10,8 +10,8 @@ SRC_URI="http://www.xiph.org/ao/src/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ~ppc-macos ppc64 sparc x86"
-IUSE="alsa arts esd nas mmap static"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ~ppc-macos ppc64 sh sparc x86"
+IUSE="alsa arts esd nas mmap"
DEPEND="alsa? ( media-libs/alsa-lib )
arts? ( kde-base/arts )
@@ -28,13 +28,14 @@ src_unpack() {
src_compile() {
# this is called alsa09 even if it is alsa 1.0
econf \
- `use_enable alsa alsa09` \
- `use_enable mmap alsa09-mmap` \
- `use_enable arts` \
- `use_enable esd` \
- `use_enable nas` \
+ $(use_enable alsa alsa09) \
+ $(use_enable mmap alsa09-mmap) \
+ $(use_enable arts) \
+ $(use_enable esd) \
+ $(use_enable nas) \
--enable-shared \
- `use_enable static` || die
+ --enable-static \
+ || die
# See bug #37218. Build problems with parallel make.
emake -j1 || die
diff --git a/media-libs/libao/libao-0.8.6-r1.ebuild b/media-libs/libao/libao-0.8.6-r1.ebuild
index 1e7fd1affa93..cb9f5b2da687 100644
--- a/media-libs/libao/libao-0.8.6-r1.ebuild
+++ b/media-libs/libao/libao-0.8.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libao/libao-0.8.6-r1.ebuild,v 1.6 2006/03/06 14:28:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libao/libao-0.8.6-r1.ebuild,v 1.7 2006/07/15 03:30:23 vapier Exp $
inherit libtool eutils autotools
@@ -13,8 +13,8 @@ SRC_URI="http://downloads.xiph.org/releases/ao/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
-IUSE="alsa arts esd nas mmap static"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sh ~sparc ~x86"
+IUSE="alsa arts esd nas mmap"
RDEPEND="alsa? ( media-libs/alsa-lib )
arts? ( kde-base/arts )
@@ -38,13 +38,14 @@ src_unpack() {
src_compile() {
# this is called alsa09 even if it is alsa 1.0
econf \
- `use_enable alsa alsa09` \
- `use_enable mmap alsa09-mmap` \
- `use_enable arts` \
- `use_enable esd` \
- `use_enable nas` \
+ $(use_enable alsa alsa09) \
+ $(use_enable mmap alsa09-mmap) \
+ $(use_enable arts) \
+ $(use_enable esd) \
+ $(use_enable nas) \
--enable-shared \
- `use_enable static` || die
+ --enable-static \
+ || die
# See bug #37218. Build problems with parallel make.
emake -j1 || die
diff --git a/media-libs/libao/libao-0.8.6-r2.ebuild b/media-libs/libao/libao-0.8.6-r2.ebuild
index 42fb975c049e..ac2d4df3a4b4 100644
--- a/media-libs/libao/libao-0.8.6-r2.ebuild
+++ b/media-libs/libao/libao-0.8.6-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libao/libao-0.8.6-r2.ebuild,v 1.4 2006/05/26 17:35:43 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libao/libao-0.8.6-r2.ebuild,v 1.5 2006/07/15 03:30:23 vapier Exp $
inherit libtool eutils autotools
@@ -13,8 +13,8 @@ SRC_URI="http://downloads.xiph.org/releases/ao/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="alsa arts esd nas mmap static"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa arts esd nas mmap"
RDEPEND="alsa? ( media-libs/alsa-lib )
arts? ( kde-base/arts )
@@ -34,13 +34,14 @@ src_unpack() {
src_compile() {
# this is called alsa09 even if it is alsa 1.0
econf \
- `use_enable alsa alsa09` \
- `use_enable mmap alsa09-mmap` \
- `use_enable arts` \
- `use_enable esd` \
- `use_enable nas` \
+ $(use_enable alsa alsa09) \
+ $(use_enable mmap alsa09-mmap) \
+ $(use_enable arts) \
+ $(use_enable esd) \
+ $(use_enable nas) \
--enable-shared \
- --enable-static || die
+ --enable-static \
+ || die
emake || die
}