summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Shepherd <masterdriverz@gentoo.org>2007-03-09 23:41:04 +0000
committerCharlie Shepherd <masterdriverz@gentoo.org>2007-03-09 23:41:04 +0000
commit9c7e3ede22bec1e09e97ffd16b643e8781d0e2cb (patch)
tree3fb84b815be713aafcdde1e95374ab28c7ebf7a0 /media-libs/libkarma/libkarma-0.0.6-r1.ebuild
parentAdd mono flag for libkarma (diff)
downloadgentoo-2-9c7e3ede22bec1e09e97ffd16b643e8781d0e2cb.tar.gz
gentoo-2-9c7e3ede22bec1e09e97ffd16b643e8781d0e2cb.tar.bz2
gentoo-2-9c7e3ede22bec1e09e97ffd16b643e8781d0e2cb.zip
Add mono useflag and give shared library a SONAME
(Portage version: 2.1.2-r13)
Diffstat (limited to 'media-libs/libkarma/libkarma-0.0.6-r1.ebuild')
-rw-r--r--media-libs/libkarma/libkarma-0.0.6-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-libs/libkarma/libkarma-0.0.6-r1.ebuild b/media-libs/libkarma/libkarma-0.0.6-r1.ebuild
new file mode 100644
index 000000000000..37ea3efcce14
--- /dev/null
+++ b/media-libs/libkarma/libkarma-0.0.6-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libkarma/libkarma-0.0.6-r1.ebuild,v 1.1 2007/03/09 23:41:04 masterdriverz Exp $
+
+inherit eutils mono
+
+DESCRIPTION="Support library for using Rio devices with mtp"
+HOMEPAGE="http://www.freakysoft.de/html/libkarma/"
+SRC_URI="http://www.freakysoft.de/html/libkarma/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="mono"
+
+DEPEND="virtual/libiconv
+ media-libs/taglib
+ mono? ( dev-lang/mono )
+ dev-libs/libusb"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ use !mono && epatch "${FILESDIR}/${P}-mono.patch"
+ epatch "${FILESDIR}/${P}-soname.patch"
+}
+
+src_compile() {
+ # need "all" target to build both static and shared libs
+ emake -j1 all || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install PREFIX="${D}/usr" || die "emake install failed"
+}