summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2010-06-05 16:10:03 +0000
committerSteve Dibb <beandog@gentoo.org>2010-06-05 16:10:03 +0000
commit7795456c72e219aa85c228cec43c43dd6d1b8c9c (patch)
treea68cd19d36b87c52a6d016a94b2879bf9f50197d /media-libs/libmatroska
parentVersion bump, bug 321021 (diff)
downloadgentoo-2-7795456c72e219aa85c228cec43c43dd6d1b8c9c.tar.gz
gentoo-2-7795456c72e219aa85c228cec43c43dd6d1b8c9c.tar.bz2
gentoo-2-7795456c72e219aa85c228cec43c43dd6d1b8c9c.zip
Version bump, bug 321021
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libmatroska')
-rw-r--r--media-libs/libmatroska/ChangeLog10
-rw-r--r--media-libs/libmatroska/files/libmatroska-0.9.0-respectflags.patch11
-rw-r--r--media-libs/libmatroska/libmatroska-0.9.0.ebuild41
3 files changed, 60 insertions, 2 deletions
diff --git a/media-libs/libmatroska/ChangeLog b/media-libs/libmatroska/ChangeLog
index 083997dacd81..cdafda45d7cf 100644
--- a/media-libs/libmatroska/ChangeLog
+++ b/media-libs/libmatroska/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libmatroska
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmatroska/ChangeLog,v 1.82 2008/01/06 22:51:58 aballier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmatroska/ChangeLog,v 1.83 2010/06/05 16:10:03 beandog Exp $
+
+*libmatroska-0.9.0 (05 Jun 2010)
+
+ 05 Jun 2010; Steve Dibb <beandog@gentoo.org> +libmatroska-0.9.0.ebuild,
+ +files/libmatroska-0.9.0-respectflags.patch:
+ Version bump, bug 321021
06 Jan 2008; Alexis Ballier <aballier@gentoo.org>
-files/libmatroska-0.8.0-respectflags.patch,
diff --git a/media-libs/libmatroska/files/libmatroska-0.9.0-respectflags.patch b/media-libs/libmatroska/files/libmatroska-0.9.0-respectflags.patch
new file mode 100644
index 000000000000..2a7f7e29a983
--- /dev/null
+++ b/media-libs/libmatroska/files/libmatroska-0.9.0-respectflags.patch
@@ -0,0 +1,11 @@
+--- make/linux/Makefile.orig 2010-06-05 10:05:18.000000000 -0600
++++ make/linux/Makefile 2010-06-05 10:05:50.000000000 -0600
+@@ -99,7 +99,7 @@
+ $(RANLIB) $@
+
+ $(LIBRARY_SO): $(objects_so)
+- $(CXX) -shared -Wl,-soname,$(LIBRARY_SO_VER) -o $(LIBRARY_SO_VER) $(objects_so) -lebml
++ $(CXX) $(LINKFLAGS) -shared -Wl,-soname,$(LIBRARY_SO_VER) -o $(LIBRARY_SO_VER) $(objects_so) -lebml
+ rm -f $(LIBRARY_SO)
+ ln -s $(LIBRARY_SO_VER) $(LIBRARY_SO)
+
diff --git a/media-libs/libmatroska/libmatroska-0.9.0.ebuild b/media-libs/libmatroska/libmatroska-0.9.0.ebuild
new file mode 100644
index 000000000000..bb7503506794
--- /dev/null
+++ b/media-libs/libmatroska/libmatroska-0.9.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmatroska/libmatroska-0.9.0.ebuild,v 1.1 2010/06/05 16:10:03 beandog Exp $
+
+EAPI="2"
+
+inherit flag-o-matic eutils toolchain-funcs
+
+DESCRIPTION="Extensible multimedia container format based on EBML"
+HOMEPAGE="http://www.matroska.org/"
+SRC_URI="http://www.bunkus.org/videotools/mkvtoolnix/sources/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-libs/libebml-0.7.6"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-respectflags.patch"
+}
+
+src_compile() {
+ cd "${S}/make/linux"
+
+ #fixes locale for gcc3.4.0 to close bug 52385
+ append-flags $(test-flags -finput-charset=ISO8859-15)
+
+ emake PREFIX=/usr \
+ LIBEBML_INCLUDE_DIR=/usr/include/ebml \
+ LIBEBML_LIB_DIR=/usr/$(get_libdir) \
+ CXX="$(tc-getCXX)" || die "make failed"
+}
+
+src_install() {
+ cd "${S}/make/linux"
+
+ emake prefix="${D}/usr" libdir="${D}/usr/$(get_libdir)" install || die "make install failed"
+ dodoc "${S}/ChangeLog"
+}