summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-10-05 20:01:17 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-10-05 20:01:17 +0000
commitcda5239eb81802f3a23c8385b7d54092f0cb8dae (patch)
tree560840eca570ec4997bceebf172ea6b1376c7ea6 /media-libs/libopendaap
parentFixed mistake in pkg_config of coda. First ask where, then check for problems... (diff)
downloadgentoo-2-cda5239eb81802f3a23c8385b7d54092f0cb8dae.tar.gz
gentoo-2-cda5239eb81802f3a23c8385b7d54092f0cb8dae.tar.bz2
gentoo-2-cda5239eb81802f3a23c8385b7d54092f0cb8dae.zip
Added to ~amd64. Fixed typedefs to work crossplatform.
Diffstat (limited to 'media-libs/libopendaap')
-rw-r--r--media-libs/libopendaap/ChangeLog6
-rw-r--r--media-libs/libopendaap/files/libopendaap-0.2.3-types.h14
-rw-r--r--media-libs/libopendaap/libopendaap-0.2.3.ebuild26
3 files changed, 36 insertions, 10 deletions
diff --git a/media-libs/libopendaap/ChangeLog b/media-libs/libopendaap/ChangeLog
index f42f40753a64..1f50f83209cb 100644
--- a/media-libs/libopendaap/ChangeLog
+++ b/media-libs/libopendaap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libopendaap
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libopendaap/ChangeLog,v 1.4 2004/09/11 16:06:22 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libopendaap/ChangeLog,v 1.5 2004/10/05 20:01:17 eradicator Exp $
+
+ 05 Oct 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ libopendaap-0.2.3.ebuild, +files/libopendaap-0.2.3-types.h:
+ Added to ~amd64. Fixed typedefs to work crossplatform.
11 Sep 2004; Jon Hood <squinky86@gentoo.org> libopendaap-0.2.3.ebuild:
Stable on x86.
diff --git a/media-libs/libopendaap/files/libopendaap-0.2.3-types.h b/media-libs/libopendaap/files/libopendaap-0.2.3-types.h
new file mode 100644
index 000000000000..25c25957fd5b
--- /dev/null
+++ b/media-libs/libopendaap/files/libopendaap-0.2.3-types.h
@@ -0,0 +1,14 @@
+diff -Naur libopendaap-0.2.3.orig/mDNS/mDNSClientAPI.h libopendaap-0.2.3/mDNS/mDNSClientAPI.h
+--- libopendaap-0.2.3.orig/mDNS/mDNSClientAPI.h 2004-04-13 00:05:11.000000000 -0700
++++ libopendaap-0.2.3/mDNS/mDNSClientAPI.h 2004-10-05 12:58:19.996946514 -0700
+@@ -483,8 +483,8 @@
+ typedef unsigned char mDNSu8;
+ typedef signed short mDNSs16;
+ typedef unsigned short mDNSu16;
+-typedef signed long mDNSs32;
+-typedef unsigned long mDNSu32;
++typedef signed int mDNSs32;
++typedef unsigned int mDNSu32;
+
+ // To enforce useful type checking, we make mDNSInterfaceID be a pointer to a dummy struct
+ // This way, mDNSInterfaceIDs can be assigned, and compared with each other, but not with other types
diff --git a/media-libs/libopendaap/libopendaap-0.2.3.ebuild b/media-libs/libopendaap/libopendaap-0.2.3.ebuild
index c98bcca05870..b2cf3aacddd8 100644
--- a/media-libs/libopendaap/libopendaap-0.2.3.ebuild
+++ b/media-libs/libopendaap/libopendaap-0.2.3.ebuild
@@ -1,21 +1,29 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libopendaap/libopendaap-0.2.3.ebuild,v 1.5 2004/09/27 23:09:13 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libopendaap/libopendaap-0.2.3.ebuild,v 1.6 2004/10/05 20:01:17 eradicator Exp $
+
+IUSE=""
+
+inherit eutils
-SLOT="0"
-LICENSE="crazney APSL-2"
-KEYWORDS="x86 ppc"
DESCRIPTION="libopendaap is a library which enables applications to discover and connect to iTunes(R) music shares"
SRC_URI="http://crazney.net/programs/itunes/files/${P}.tar.bz2"
HOMEPAGE="http://crazney.net/programs/itunes/libopendaap.html"
-IUSE=""
-src_compile() {
- econf || die
- emake || die
+SLOT="0"
+LICENSE="crazney APSL-2"
+
+KEYWORDS="x86 ppc ~amd64"
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-types.h
}
src_install() {
+ make DESTDIR="${D}" install || die
dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
- einstall || die
}