summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-02-21 10:13:40 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-02-21 10:13:40 +0000
commit167a0664820ce3b80acd9eae9c1a51d6f9b68a72 (patch)
tree3820c076ad714727d662df946b78b84b4c8de44d /media-libs/lilv
parentversion bump (diff)
downloadgentoo-2-167a0664820ce3b80acd9eae9c1a51d6f9b68a72.tar.gz
gentoo-2-167a0664820ce3b80acd9eae9c1a51d6f9b68a72.tar.bz2
gentoo-2-167a0664820ce3b80acd9eae9c1a51d6f9b68a72.zip
version bump
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/lilv')
-rw-r--r--media-libs/lilv/ChangeLog9
-rw-r--r--media-libs/lilv/lilv-0.16.0.ebuild49
2 files changed, 56 insertions, 2 deletions
diff --git a/media-libs/lilv/ChangeLog b/media-libs/lilv/ChangeLog
index 101393659ec3..dde74d224811 100644
--- a/media-libs/lilv/ChangeLog
+++ b/media-libs/lilv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/lilv
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lilv/ChangeLog,v 1.10 2012/12/11 19:12:49 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lilv/ChangeLog,v 1.11 2013/02/21 10:13:40 aballier Exp $
+
+*lilv-0.16.0 (21 Feb 2013)
+
+ 21 Feb 2013; Alexis Ballier <aballier@gentoo.org> +lilv-0.16.0.ebuild:
+ version bump
11 Dec 2012; Agostino Sarubbo <ago@gentoo.org> lilv-0.14.4.ebuild:
Add ~ppc, wrt bug #421061
diff --git a/media-libs/lilv/lilv-0.16.0.ebuild b/media-libs/lilv/lilv-0.16.0.ebuild
new file mode 100644
index 000000000000..09cbf5733372
--- /dev/null
+++ b/media-libs/lilv/lilv-0.16.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lilv/lilv-0.16.0.ebuild,v 1.1 2013/02/21 10:13:40 aballier Exp $
+
+EAPI=4
+
+inherit base waf-utils bash-completion-r1
+
+DESCRIPTION="Library to make the use of LV2 plugins as simple as possible for applications"
+HOMEPAGE="http://drobilla.net/software/lilv/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc +dyn-manifest static-libs test"
+
+RDEPEND="media-libs/lv2
+ >=media-libs/sratom-0.4.0
+ >=dev-libs/serd-0.14.0
+ >=dev-libs/sord-0.12.0"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+DOCS=( "AUTHORS" "NEWS" "README" )
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --no-bash-completion \
+ $(use test && echo "--test") \
+ $(use doc && echo "--docs") \
+ $(use static-libs && echo "--static") \
+ $(use dyn-manifest && echo "--dyn-manifest")
+}
+
+src_test() {
+ ./waf test || die
+}
+
+src_install() {
+ waf-utils_src_install
+ newbashcomp utils/lilv.bash_completion ${PN}
+}