summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-02-20 21:06:42 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-02-20 21:06:42 +0000
commitf32b4b4825311bdb4dfdf381d3429b515e1bf3a3 (patch)
treee52532a70b3ec2966ae7aa4a84c45aaaa4798353 /media-libs/opencore-amr
parentrevert last commit, worked around differently (diff)
downloadgentoo-2-f32b4b4825311bdb4dfdf381d3429b515e1bf3a3.tar.gz
gentoo-2-f32b4b4825311bdb4dfdf381d3429b515e1bf3a3.tar.bz2
gentoo-2-f32b4b4825311bdb4dfdf381d3429b515e1bf3a3.zip
version bump. build static libs with use=static-libs
(Portage version: 2.2.0_alpha88/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/opencore-amr')
-rw-r--r--media-libs/opencore-amr/ChangeLog9
-rw-r--r--media-libs/opencore-amr/opencore-amr-0.1.3.ebuild27
2 files changed, 34 insertions, 2 deletions
diff --git a/media-libs/opencore-amr/ChangeLog b/media-libs/opencore-amr/ChangeLog
index c9cc6d85bf0f..4871ad37c67b 100644
--- a/media-libs/opencore-amr/ChangeLog
+++ b/media-libs/opencore-amr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/opencore-amr
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/opencore-amr/ChangeLog,v 1.18 2011/08/29 17:42:13 grobian Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opencore-amr/ChangeLog,v 1.19 2012/02/20 21:06:42 aballier Exp $
+
+*opencore-amr-0.1.3 (20 Feb 2012)
+
+ 20 Feb 2012; Alexis Ballier <aballier@gentoo.org> +opencore-amr-0.1.3.ebuild:
+ version bump. build static libs with use=static-libs
29 Aug 2011; Fabian Groffen <grobian@gentoo.org> opencore-amr-0.1.2.ebuild:
Marked *-macos, bug #362691
diff --git a/media-libs/opencore-amr/opencore-amr-0.1.3.ebuild b/media-libs/opencore-amr/opencore-amr-0.1.3.ebuild
new file mode 100644
index 000000000000..f9cbe498d740
--- /dev/null
+++ b/media-libs/opencore-amr/opencore-amr-0.1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opencore-amr/opencore-amr-0.1.3.ebuild,v 1.1 2012/02/20 21:06:42 aballier Exp $
+
+EAPI=2
+inherit multilib
+
+DESCRIPTION="Implementation of Adaptive Multi Rate Narrowband and Wideband speech codec"
+HOMEPAGE="http://opencore-amr.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="static-libs"
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README
+ find "${D}"usr/$(get_libdir) -name '*.la' -delete
+}