summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-06-06 13:15:54 +0000
committerMichael Weber <xmw@gentoo.org>2013-06-06 13:15:54 +0000
commit9d08ae6beb52bccc488aa754631a2a120cfc4f1c (patch)
treeb641d354a294972ae6250909df14038b65c63362 /media-libs/openjpeg/openjpeg-2.0.0.ebuild
parentamd64 stable wrt bug #472486 (diff)
downloadgentoo-2-9d08ae6beb52bccc488aa754631a2a120cfc4f1c.tar.gz
gentoo-2-9d08ae6beb52bccc488aa754631a2a120cfc4f1c.tar.bz2
gentoo-2-9d08ae6beb52bccc488aa754631a2a120cfc4f1c.zip
Version bump, set SLOT to 2, backport pkg-config patch as pointed out by Rafał Mużyło (bug 440086), non-maint commit.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'media-libs/openjpeg/openjpeg-2.0.0.ebuild')
-rw-r--r--media-libs/openjpeg/openjpeg-2.0.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-libs/openjpeg/openjpeg-2.0.0.ebuild b/media-libs/openjpeg/openjpeg-2.0.0.ebuild
new file mode 100644
index 000000000000..ccb42c405d36
--- /dev/null
+++ b/media-libs/openjpeg/openjpeg-2.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openjpeg/openjpeg-2.0.0.ebuild,v 1.1 2013/06/06 13:15:54 xmw Exp $
+
+EAPI=5
+inherit cmake-utils multilib
+
+DESCRIPTION="An open-source JPEG 2000 library"
+HOMEPAGE="http://code.google.com/p/openjpeg/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+RDEPEND="media-libs/lcms:2=
+ media-libs/libpng:0=
+ media-libs/tiff:0=
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+DOCS=( AUTHORS CHANGES NEWS README THANKS )
+
+PATCHES=( "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-pkgconfig.patch )
+
+RESTRICT="test" #409263
+
+src_configure() {
+ local mycmakeargs=(
+ -DOPENJPEG_INSTALL_LIB_DIR="$(get_libdir)"
+ $(cmake-utils_use_build doc)
+ $(cmake-utils_use_build test TESTING)
+ )
+
+ cmake-utils_src_configure
+}