summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-01-22 22:02:07 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-01-22 22:02:07 +0000
commitb4148b391a48a13fe0af4b96afd6c65cc0f3ce2a (patch)
tree5c82605687ab3c1d85c9d9679f46f4e03f30fb72 /media-libs/pdflib
parentKDE support only requires kdelibs, not kdebase. (Manifest recommit) (diff)
downloadgentoo-2-b4148b391a48a13fe0af4b96afd6c65cc0f3ce2a.tar.gz
gentoo-2-b4148b391a48a13fe0af4b96afd6c65cc0f3ce2a.tar.bz2
gentoo-2-b4148b391a48a13fe0af4b96afd6c65cc0f3ce2a.zip
Fix sandbox violations. Thanks to: Thomas Seifert <ts77@gmx.de> for reporting it in bug #38500
Diffstat (limited to 'media-libs/pdflib')
-rw-r--r--media-libs/pdflib/ChangeLog6
-rw-r--r--media-libs/pdflib/pdflib-5.0.2.ebuild15
2 files changed, 12 insertions, 9 deletions
diff --git a/media-libs/pdflib/ChangeLog b/media-libs/pdflib/ChangeLog
index c821b78b995f..8a9cd8bf0c3c 100644
--- a/media-libs/pdflib/ChangeLog
+++ b/media-libs/pdflib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/pdflib
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/ChangeLog,v 1.23 2004/01/14 04:42:26 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/ChangeLog,v 1.24 2004/01/22 22:02:07 seemant Exp $
+
+ 22 Jan 2004; Seemant Kulleen <seemant@gentoo.org> pdflib-5.0.2.ebuild:
+ Fix sandbox violations. Thanks to: Thomas Seifert <ts77@gmx.de> for reporting
+ it in bug #38500
*pdflib-5.0.2 (13 Jan 2004)
diff --git a/media-libs/pdflib/pdflib-5.0.2.ebuild b/media-libs/pdflib/pdflib-5.0.2.ebuild
index e84964b98f5d..6c8d404824bb 100644
--- a/media-libs/pdflib/pdflib-5.0.2.ebuild
+++ b/media-libs/pdflib/pdflib-5.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/pdflib-5.0.2.ebuild,v 1.1 2004/01/14 04:42:26 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/pdflib-5.0.2.ebuild,v 1.2 2004/01/22 22:02:07 seemant Exp $
IUSE="tcltk perl python java"
MY_PN=${PN/pdf/PDF}-Lite
@@ -60,17 +60,17 @@ src_install() {
# fix sandbox violations
# NB: do this *after* build, otherwise we will get linker problems.
# all we basically do here is modify the install path for Makefiles that
- # needs it.
- sed -i -e "s:LANG_LIBDIR \t\= :LANG_LIBDIR\t\= ${D}:" \
+ # need it.
+ sed -i -e "s:^\(LANG_LIBDIR\).*= \(.*\):\1\t = ${D}/\2:" \
${S}/bind/java/Makefile
- sed -i -e "s:LANG_LIBDIR \t\= :LANG_LIBDIR\t\= ${D}:" \
+ sed -i -e "s:^\(LANG_LIBDIR\).*= \(.*\):\1\t = ${D}/\2:" \
${S}/bind/perl/Makefile
- sed -i -e "s:LANG_LIBDIR \t\= :LANG_LIBDIR\t\= ${D}:" \
+ sed -i -e "s:^\(LANG_LIBDIR\).*= \(.*\):\1\t = ${D}/\2:" \
${S}/bind/python/Makefile
- sed -e "s:LANG_LIBDIR \t\= :LANG_LIBDIR\t\= ${D}:" \
+ sed -i -e "s:^\(LANG_LIBDIR\).*= \(.*\):\1\t = ${D}/\2:" \
${S}/bind/tcl/Makefile
# ok, this should create the correct lib dirs for perl and python.
@@ -90,8 +90,7 @@ src_install() {
fi
#next line required for proper install
dodir /usr/bin
- make prefix=${D}/usr \
- install || die
+ einstall || die
dodoc readme.txt doc/*