summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-22 09:43:00 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-22 09:43:00 +0000
commit818e52ebfd18c39d323506d793d77a16cd5daa8e (patch)
tree79b6efc32878b6d045e28719b73e89d0cd05de33 /media-libs/qhull
parentAdd a patch to compile on alpha wrt #318975 (diff)
downloadgentoo-2-818e52ebfd18c39d323506d793d77a16cd5daa8e.tar.gz
gentoo-2-818e52ebfd18c39d323506d793d77a16cd5daa8e.tar.bz2
gentoo-2-818e52ebfd18c39d323506d793d77a16cd5daa8e.zip
Version bump, #307217
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/qhull')
-rw-r--r--media-libs/qhull/ChangeLog7
-rw-r--r--media-libs/qhull/qhull-2010.1.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/media-libs/qhull/ChangeLog b/media-libs/qhull/ChangeLog
index 4f4e272b0a93..9f77951440a1 100644
--- a/media-libs/qhull/ChangeLog
+++ b/media-libs/qhull/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/qhull
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/ChangeLog,v 1.34 2010/04/12 13:50:16 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/ChangeLog,v 1.35 2010/05/22 09:43:00 jlec Exp $
+
+*qhull-2010.1 (22 May 2010)
+
+ 22 May 2010; Justin Lecher <jlec@gentoo.org> +qhull-2010.1.ebuild:
+ Version bump, #307217
12 Apr 2010; Alexis Ballier <aballier@gentoo.org> qhull-2003.1-r1.ebuild:
keyword ~x86-fbsd thanks to Henning Schild <henning@wh9.tu-dresden.de>,
diff --git a/media-libs/qhull/qhull-2010.1.ebuild b/media-libs/qhull/qhull-2010.1.ebuild
new file mode 100644
index 000000000000..68d46c57ff1c
--- /dev/null
+++ b/media-libs/qhull/qhull-2010.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/qhull-2010.1.ebuild,v 1.1 2010/05/22 09:43:00 jlec Exp $
+
+EAPI=2
+
+inherit cmake-utils eutils flag-o-matic
+
+MY_P="${PN}${PV}"
+DESCRIPTION="Geometry library"
+HOMEPAGE="http://www.qhull.org"
+SRC_URI="${HOMEPAGE}/download/${P}-src.tgz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+pkg_setup() {
+ append-flags -fno-strict-aliasing
+}
+
+src_install() {
+ dobin "${S}"_build/src/{q*,rbox} || die
+
+ dodoc Announce.txt File_id.diz README.txt REGISTER.txt || die
+
+ if use doc; then
+ dohtml -r index.htm html || die
+ fi
+}