summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2010-08-17 02:44:29 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2010-08-17 02:44:29 +0000
commitad72a4aa081086fde29b42f34739892e3b4d3e47 (patch)
treef824c3a1f4693288a5920c0aa1f3bba31f23761a /media-libs/qimageblitz
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-ad72a4aa081086fde29b42f34739892e3b4d3e47.tar.gz
gentoo-2-ad72a4aa081086fde29b42f34739892e3b4d3e47.tar.bz2
gentoo-2-ad72a4aa081086fde29b42f34739892e3b4d3e47.zip
Version bump 0.0.6
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/qimageblitz')
-rw-r--r--media-libs/qimageblitz/ChangeLog8
-rw-r--r--media-libs/qimageblitz/qimageblitz-0.0.6.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/media-libs/qimageblitz/ChangeLog b/media-libs/qimageblitz/ChangeLog
index 40b83d3ab14e..be6e012af36d 100644
--- a/media-libs/qimageblitz/ChangeLog
+++ b/media-libs/qimageblitz/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/qimageblitz
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/qimageblitz/ChangeLog,v 1.1 2010/05/15 16:44:48 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/qimageblitz/ChangeLog,v 1.2 2010/08/17 02:44:29 reavertm Exp $
+
+*qimageblitz-0.0.6 (17 Aug 2010)
+
+ 17 Aug 2010; Maciej Mrozowski <reavertm@gentoo.org>
+ +qimageblitz-0.0.6.ebuild:
+ Version bump 0.0.6
15 May 2010; Maciej Mrozowski <reavertm@gentoo.org>
+qimageblitz-0.0.4.ebuild, +files/qimageblitz-9999-exec-stack.patch,
diff --git a/media-libs/qimageblitz/qimageblitz-0.0.6.ebuild b/media-libs/qimageblitz/qimageblitz-0.0.6.ebuild
new file mode 100644
index 000000000000..2484404ca70d
--- /dev/null
+++ b/media-libs/qimageblitz/qimageblitz-0.0.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/qimageblitz/qimageblitz-0.0.6.ebuild,v 1.1 2010/08/17 02:44:29 reavertm Exp $
+
+EAPI="2"
+
+inherit cmake-utils eutils
+
+DESCRIPTION="A graphical effect and filter library for KDE4"
+HOMEPAGE="http://websvn.kde.org/trunk/kdesupport/qimageblitz/"
+SRC_URI="mirror://kde/stable/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+SLOT="0"
+IUSE="3dnow altivec debug mmx sse sse2"
+
+DEPEND="
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/qimageblitz-9999-exec-stack.patch
+}
+
+src_compile() {
+ mycmakeargs=(
+ $(cmake-utils_use_has 3dnow 3DNOW)
+ $(cmake-utils_use_has altivec ALTIVEC)
+ $(cmake-utils_use_has mmx MMX)
+ $(cmake-utils_use_has sse SSE)
+ $(cmake-utils_use_has sse2 SSE2)
+ )
+ cmake-utils_src_compile
+}