summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-07-01 03:31:27 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-07-01 03:31:27 +0000
commite36717ab53671b8669cb5bf4748161852681c9ff (patch)
treeb1504723f594af36af4b38cb07b57e12b0cbf557 /media-libs/sdl-ttf
parentstable on ppc64, bug #55597 (Manifest recommit) (diff)
downloadgentoo-2-e36717ab53671b8669cb5bf4748161852681c9ff.tar.gz
gentoo-2-e36717ab53671b8669cb5bf4748161852681c9ff.tar.bz2
gentoo-2-e36717ab53671b8669cb5bf4748161852681c9ff.zip
Add patch from Ming Zhao via bug #55746 to support latest freetype
Diffstat (limited to 'media-libs/sdl-ttf')
-rw-r--r--media-libs/sdl-ttf/ChangeLog6
-rw-r--r--media-libs/sdl-ttf/files/ft2build.patch12
-rw-r--r--media-libs/sdl-ttf/sdl-ttf-2.0.6.ebuild10
3 files changed, 26 insertions, 2 deletions
diff --git a/media-libs/sdl-ttf/ChangeLog b/media-libs/sdl-ttf/ChangeLog
index 83bf72b18d03..fd28b5acd9f6 100644
--- a/media-libs/sdl-ttf/ChangeLog
+++ b/media-libs/sdl-ttf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/sdl-ttf
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-ttf/ChangeLog,v 1.13 2004/06/24 23:22:24 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-ttf/ChangeLog,v 1.14 2004/07/01 03:31:27 mr_bones_ Exp $
+
+ 30 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> +files/ft2build.patch,
+ sdl-ttf-2.0.6.ebuild:
+ Add patch from Ming Zhao via bug #55746 to support latest freetype
29 Nov 2003; Brad House <brad_mssw@gentoo.org> sdl-ttf-2.0.6.ebuild:
mark stable on amd64
diff --git a/media-libs/sdl-ttf/files/ft2build.patch b/media-libs/sdl-ttf/files/ft2build.patch
new file mode 100644
index 000000000000..56868fdf871b
--- /dev/null
+++ b/media-libs/sdl-ttf/files/ft2build.patch
@@ -0,0 +1,12 @@
+--- SDL_ttf.c.orig 2003-02-22 01:38:15.000000000 +0800
++++ SDL_ttf.c 2004-07-01 10:36:07.439887480 +0800
+@@ -39,7 +39,8 @@
+ #define FREEA(p) free(p)
+ #endif
+
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+ #include <freetype/ftoutln.h>
+ #include <freetype/ttnameid.h>
+ #include <freetype/internal/ftobjs.h>
diff --git a/media-libs/sdl-ttf/sdl-ttf-2.0.6.ebuild b/media-libs/sdl-ttf/sdl-ttf-2.0.6.ebuild
index cd530ef36afe..32ff9f0c37fa 100644
--- a/media-libs/sdl-ttf/sdl-ttf-2.0.6.ebuild
+++ b/media-libs/sdl-ttf/sdl-ttf-2.0.6.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-ttf/sdl-ttf-2.0.6.ebuild,v 1.11 2004/07/01 03:21:31 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-ttf/sdl-ttf-2.0.6.ebuild,v 1.12 2004/07/01 03:31:27 mr_bones_ Exp $
+
+inherit eutils
MY_P="${P/sdl-/SDL_}"
DESCRIPTION="library that allows you to use TrueType fonts in SDL applications"
@@ -17,6 +19,12 @@ DEPEND=">=media-libs/libsdl-1.2.4
S="${WORKDIR}/${MY_P}"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}/ft2build.patch"
+}
+
src_install() {
make DESTDIR="${D}" install || die "make install failed"
dodoc CHANGES README