summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-04-29 04:54:07 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-04-29 04:54:07 +0000
commit20800f9a1617c79f969fc721cca3832eeb3ac9a9 (patch)
tree70360c8306ecfc21571f72af89a687198f9c8a41 /media-libs/sdlmm
parentAdded app-text/scrollkeeper to DEPEND. resolves bug #2138 (diff)
downloadgentoo-2-20800f9a1617c79f969fc721cca3832eeb3ac9a9.tar.gz
gentoo-2-20800f9a1617c79f969fc721cca3832eeb3ac9a9.tar.bz2
gentoo-2-20800f9a1617c79f969fc721cca3832eeb3ac9a9.zip
New package
Diffstat (limited to 'media-libs/sdlmm')
-rw-r--r--media-libs/sdlmm/ChangeLog14
-rw-r--r--media-libs/sdlmm/files/digest-sdlmm-0.1.81
-rw-r--r--media-libs/sdlmm/sdlmm-0.1.8.ebuild26
3 files changed, 41 insertions, 0 deletions
diff --git a/media-libs/sdlmm/ChangeLog b/media-libs/sdlmm/ChangeLog
new file mode 100644
index 000000000000..44bd1cecc2f2
--- /dev/null
+++ b/media-libs/sdlmm/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for media-libs/sdlmm
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdlmm/ChangeLog,v 1.1 2002/04/29 04:54:07 rphillips Exp $
+
+*sdlmm-0.1.8 (28 Apr 2002)
+
+ 28 Apr 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
+
diff --git a/media-libs/sdlmm/files/digest-sdlmm-0.1.8 b/media-libs/sdlmm/files/digest-sdlmm-0.1.8
new file mode 100644
index 000000000000..f5ff11d471f5
--- /dev/null
+++ b/media-libs/sdlmm/files/digest-sdlmm-0.1.8
@@ -0,0 +1 @@
+MD5 0a05d27d1aed72af3c7a37b6378f50e5 SDLmm-0.1.8.tar.bz2 399529
diff --git a/media-libs/sdlmm/sdlmm-0.1.8.ebuild b/media-libs/sdlmm/sdlmm-0.1.8.ebuild
new file mode 100644
index 000000000000..bac76a433093
--- /dev/null
+++ b/media-libs/sdlmm/sdlmm-0.1.8.ebuild
@@ -0,0 +1,26 @@
+# Copyriht 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author phoen][x <eqc_phoenix@gmx.de>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdlmm/sdlmm-0.1.8.ebuild,v 1.1 2002/04/29 04:54:07 rphillips Exp $
+
+MY_P="${P/sdl/SDL}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A C++ Wrapper for the Simple DirectMedia Layer"
+SRC_URI="http://prdownloads.sourceforge.net/sdlmm/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.libsdl.org/projects/SDL_mixer/index.html"
+DEPEND=">=media-libs/libsdl-1.2.4"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING README THANKS
+}
+