summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-02 10:52:25 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-02 10:52:25 +0000
commitaf5e7367539fed0231db5952e5e4594ede2dbdde (patch)
tree4a609064a6272053436ccf7d53c24af169159c73 /media-libs/slv2
parentAdd live ebuild for testing (diff)
downloadgentoo-2-af5e7367539fed0231db5952e5e4594ede2dbdde.tar.gz
gentoo-2-af5e7367539fed0231db5952e5e4594ede2dbdde.tar.bz2
gentoo-2-af5e7367539fed0231db5952e5e4594ede2dbdde.zip
version bump
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'media-libs/slv2')
-rw-r--r--media-libs/slv2/ChangeLog9
-rw-r--r--media-libs/slv2/files/digest-slv2-0.4.03
-rw-r--r--media-libs/slv2/slv2-0.4.0.ebuild37
3 files changed, 47 insertions, 2 deletions
diff --git a/media-libs/slv2/ChangeLog b/media-libs/slv2/ChangeLog
index dbb7d629f13f..b12413e07a64 100644
--- a/media-libs/slv2/ChangeLog
+++ b/media-libs/slv2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/slv2
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/slv2/ChangeLog,v 1.2 2007/12/12 07:29:26 aballier Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/slv2/ChangeLog,v 1.3 2008/01/02 10:52:24 aballier Exp $
+
+*slv2-0.4.0 (02 Jan 2008)
+
+ 02 Jan 2008; Alexis Ballier <aballier@gentoo.org> +slv2-0.4.0.ebuild:
+ version bump
12 Dec 2007; Alexis Ballier <aballier@gentoo.org> slv2-0.3.2.ebuild:
keyword ~x86 too, working fine
diff --git a/media-libs/slv2/files/digest-slv2-0.4.0 b/media-libs/slv2/files/digest-slv2-0.4.0
new file mode 100644
index 000000000000..f4f688582b75
--- /dev/null
+++ b/media-libs/slv2/files/digest-slv2-0.4.0
@@ -0,0 +1,3 @@
+MD5 616acffff9d2924d92adf5995216d106 slv2-0.4.0.tar.gz 529211
+RMD160 70cc1b514388adc7f0c951da688207abe56c5c04 slv2-0.4.0.tar.gz 529211
+SHA256 d5fb9d8a2892f4df41434bc971e81fc9819fb2d29dd8be7b2e110967961c7194 slv2-0.4.0.tar.gz 529211
diff --git a/media-libs/slv2/slv2-0.4.0.ebuild b/media-libs/slv2/slv2-0.4.0.ebuild
new file mode 100644
index 000000000000..827ba8173b7d
--- /dev/null
+++ b/media-libs/slv2/slv2-0.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/slv2/slv2-0.4.0.ebuild,v 1.1 2008/01/02 10:52:24 aballier Exp $
+
+DESCRIPTION="A library to make the use of LV2 plugins as simple as possible for applications"
+HOMEPAGE="http://wiki.drobilla.net/SLV2"
+SRC_URI="http://download.drobilla.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc jack"
+
+RDEPEND="dev-libs/redland
+ media-libs/raptor
+ jack? ( media-sound/jack-audio-connection-kit )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf $(use_enable debug) \
+ $(use_enable jack) \
+ $(use_enable doc documentation)
+
+ emake || die "make failed"
+ if use doc; then
+ emake docs || die "creating documentation failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README
+ doman doc/man/man3/*
+ use doc && dohtml doc/html/*
+}