summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-10-07 15:36:13 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-10-07 15:36:13 +0000
commit0f8a0050b115d460e5fab6cf5123d0afdb03391d (patch)
treeab280dfbd1511c9cfa1029ad1a4d5905d20fad8a /media-libs/smpeg2
parentVersion bump. (diff)
downloadgentoo-2-0f8a0050b115d460e5fab6cf5123d0afdb03391d.tar.gz
gentoo-2-0f8a0050b115d460e5fab6cf5123d0afdb03391d.tar.bz2
gentoo-2-0f8a0050b115d460e5fab6cf5123d0afdb03391d.zip
fix smpeg2-config
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'media-libs/smpeg2')
-rw-r--r--media-libs/smpeg2/ChangeLog8
-rw-r--r--media-libs/smpeg2/files/smpeg2-2.0.0-smpeg2-config.patch27
-rw-r--r--media-libs/smpeg2/smpeg2-2.0.0-r1.ebuild (renamed from media-libs/smpeg2/smpeg2-2.0.0.ebuild)4
3 files changed, 37 insertions, 2 deletions
diff --git a/media-libs/smpeg2/ChangeLog b/media-libs/smpeg2/ChangeLog
index 21a368e85b77..98d340030dd8 100644
--- a/media-libs/smpeg2/ChangeLog
+++ b/media-libs/smpeg2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/smpeg2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/smpeg2/ChangeLog,v 1.1 2013/08/28 21:42:16 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/smpeg2/ChangeLog,v 1.2 2013/10/07 15:36:12 hasufell Exp $
+
+*smpeg2-2.0.0-r1 (07 Oct 2013)
+
+ 07 Oct 2013; Julian Ospald <hasufell@gentoo.org> -smpeg2-2.0.0.ebuild,
+ +smpeg2-2.0.0-r1.ebuild, +files/smpeg2-2.0.0-smpeg2-config.patch:
+ fix smpeg2-config
*smpeg2-2.0.0 (28 Aug 2013)
diff --git a/media-libs/smpeg2/files/smpeg2-2.0.0-smpeg2-config.patch b/media-libs/smpeg2/files/smpeg2-2.0.0-smpeg2-config.patch
new file mode 100644
index 000000000000..2018968e195e
--- /dev/null
+++ b/media-libs/smpeg2/files/smpeg2-2.0.0-smpeg2-config.patch
@@ -0,0 +1,27 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Mon Oct 7 15:10:46 UTC 2013
+Subject: fix smpeg2-config.in
+
+SDL_CONFIG is now SDL2_CONFIG in the new sdl2.m4
+
+--- smpeg-2.0.0/smpeg2-config.in
++++ smpeg-2.0.0/smpeg2-config.in
+@@ -42,7 +42,7 @@
+ if test @includedir@ != /usr/include ; then
+ includes=-I@includedir@
+ fi
+- echo $includes -I@includedir@/smpeg2 `@SDL_CONFIG@ --cflags`
++ echo $includes -I@includedir@/smpeg2 `@SDL2_CONFIG@ --cflags`
+ ;;
+ --libs)
+ if [ "`uname`" = "SunOS" ]; then
+@@ -50,7 +50,7 @@
+ else
+ libdirs="-L@libdir@ @SMPEG_RLD_FLAGS@"
+ fi
+- echo $libdirs -lsmpeg2 `@SDL_CONFIG@ --libs`
++ echo $libdirs -lsmpeg2 `@SDL2_CONFIG@ --libs`
+ ;;
+ *)
+ echo "${usage}" 1>&2
+
diff --git a/media-libs/smpeg2/smpeg2-2.0.0.ebuild b/media-libs/smpeg2/smpeg2-2.0.0-r1.ebuild
index 436145ea089b..b12a1349abf7 100644
--- a/media-libs/smpeg2/smpeg2-2.0.0.ebuild
+++ b/media-libs/smpeg2/smpeg2-2.0.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/smpeg2/smpeg2-2.0.0.ebuild,v 1.1 2013/08/28 21:42:16 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/smpeg2/smpeg2-2.0.0-r1.ebuild,v 1.1 2013/10/07 15:36:12 hasufell Exp $
EAPI=5
inherit eutils toolchain-funcs autotools
@@ -23,6 +23,8 @@ DOCS=( CHANGES README README.SDL_mixer TODO )
S=${WORKDIR}/${MY_P}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-smpeg2-config.patch
+
# avoid file collision with media-libs/smpeg
sed -i \
-e '/plaympeg/d' \