summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-08-30 21:55:06 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-08-30 21:55:06 +0000
commit93b7b0a3a2f4dc309cabf42d77b3396b46c879a5 (patch)
tree3e48e27f8f02cb13f5a4e1c6baf58c53c4325f19 /media-libs/sratom
parentVersion bump RC's (diff)
downloadgentoo-2-93b7b0a3a2f4dc309cabf42d77b3396b46c879a5.tar.gz
gentoo-2-93b7b0a3a2f4dc309cabf42d77b3396b46c879a5.tar.bz2
gentoo-2-93b7b0a3a2f4dc309cabf42d77b3396b46c879a5.zip
version bump
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/sratom')
-rw-r--r--media-libs/sratom/ChangeLog7
-rw-r--r--media-libs/sratom/sratom-0.4.0.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/media-libs/sratom/ChangeLog b/media-libs/sratom/ChangeLog
index 2e38eff21939..181605169082 100644
--- a/media-libs/sratom/ChangeLog
+++ b/media-libs/sratom/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/sratom
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sratom/ChangeLog,v 1.4 2012/05/22 16:04:12 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sratom/ChangeLog,v 1.5 2012/08/30 21:55:06 aballier Exp $
+
+*sratom-0.4.0 (30 Aug 2012)
+
+ 30 Aug 2012; Alexis Ballier <aballier@gentoo.org> +sratom-0.4.0.ebuild:
+ version bump
22 May 2012; Johannes Huber <johu@gentoo.org> sratom-0.2.0.ebuild:
Add ~x86 wrt bug #413037
diff --git a/media-libs/sratom/sratom-0.4.0.ebuild b/media-libs/sratom/sratom-0.4.0.ebuild
new file mode 100644
index 000000000000..fa13c3b1a446
--- /dev/null
+++ b/media-libs/sratom/sratom-0.4.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sratom/sratom-0.4.0.ebuild,v 1.1 2012/08/30 21:55:06 aballier Exp $
+
+EAPI=4
+
+inherit waf-utils
+
+DESCRIPTION="Library for serialising LV2 atoms to/from RDF, particularly the Turtle syntax"
+HOMEPAGE="http://drobilla.net/software/sratom/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs test"
+
+RDEPEND="media-libs/lv2
+ >=dev-libs/serd-0.14.0
+ >=dev-libs/sord-0.8.0"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+DOCS=( "NEWS" "README" )
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ --docdir=/usr/share/doc/${PF} \
+ $(use test && echo "--test") \
+ $(use doc && echo "--docs") \
+ $(use static-libs && echo "--static")
+}
+
+src_test() {
+ ./waf test || die
+}