summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-04-22 02:37:19 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-04-22 02:37:19 +0000
commit9ac11d96a3c9f305a8a2d400a2aa001390ccab2a (patch)
tree673697df5a3932a12a1e8ddc6d5d53416325333d /media-libs/sratom
parentversion bump (diff)
downloadgentoo-2-9ac11d96a3c9f305a8a2d400a2aa001390ccab2a.tar.gz
gentoo-2-9ac11d96a3c9f305a8a2d400a2aa001390ccab2a.tar.bz2
gentoo-2-9ac11d96a3c9f305a8a2d400a2aa001390ccab2a.zip
initial import, ebuild by me
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/sratom')
-rw-r--r--media-libs/sratom/ChangeLog10
-rw-r--r--media-libs/sratom/files/ldconfig.patch12
-rw-r--r--media-libs/sratom/metadata.xml8
-rw-r--r--media-libs/sratom/sratom-0.2.0.ebuild38
4 files changed, 68 insertions, 0 deletions
diff --git a/media-libs/sratom/ChangeLog b/media-libs/sratom/ChangeLog
new file mode 100644
index 000000000000..4e4a3950f246
--- /dev/null
+++ b/media-libs/sratom/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-libs/sratom
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sratom/ChangeLog,v 1.1 2012/04/22 02:37:19 aballier Exp $
+
+*sratom-0.2.0 (22 Apr 2012)
+
+ 22 Apr 2012; Alexis Ballier <aballier@gentoo.org> +sratom-0.2.0.ebuild,
+ +files/ldconfig.patch, +metadata.xml:
+ initial import, ebuild by me
+
diff --git a/media-libs/sratom/files/ldconfig.patch b/media-libs/sratom/files/ldconfig.patch
new file mode 100644
index 000000000000..80567b1dc77e
--- /dev/null
+++ b/media-libs/sratom/files/ldconfig.patch
@@ -0,0 +1,12 @@
+Index: serd-0.4.2/wscript
+===================================================================
+--- serd-0.4.2.orig/wscript
++++ serd-0.4.2/wscript
+@@ -125,7 +125,6 @@ def build(bld):
+ # Man page
+ bld.install_files('${MANDIR}/man1', 'doc/serdi.1')
+
+- bld.add_post_fun(autowaf.run_ldconfig)
+ if bld.env['DOCS']:
+ bld.add_post_fun(fix_docs)
+
diff --git a/media-libs/sratom/metadata.xml b/media-libs/sratom/metadata.xml
new file mode 100644
index 000000000000..640383e7be81
--- /dev/null
+++ b/media-libs/sratom/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proaudio</herd>
+<longdescription lang="en">
+ Lilv is a library to make the use of LV2 plugins as simple as possible for applications. Lilv is the successor to SLV2, rewritten to be significantly faster and have minimal dependencies.
+</longdescription>
+</pkgmetadata>
diff --git a/media-libs/sratom/sratom-0.2.0.ebuild b/media-libs/sratom/sratom-0.2.0.ebuild
new file mode 100644
index 000000000000..984b5cafd387
--- /dev/null
+++ b/media-libs/sratom/sratom-0.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sratom/sratom-0.2.0.ebuild,v 1.1 2012/04/22 02:37:19 aballier Exp $
+
+EAPI=4
+
+inherit waf-utils
+
+DESCRIPTION="Library for serialising LV2 atoms to/from RDF, particularly the Turtle syntax"
+HOMEPAGE="http://drobilla.net/software/sratom/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc static-libs test"
+
+RDEPEND="media-libs/lv2
+ >=dev-libs/serd-0.14.0
+ >=dev-libs/sord-0.8.0"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-util/pkgconfig"
+
+PATCHES=( "${FILESDIR}/ldconfig.patch" )
+DOCS=( "NEWS" "README" )
+
+src_configure() {
+ waf-utils_src_configure \
+ --docdir=/usr/share/doc/${PF} \
+ $(use test && echo "--test") \
+ $(use doc && echo "--docs") \
+ $(use static-libs && echo "--static")
+}
+
+src_test() {
+ ./waf test || die
+}