summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Huebel <jhuebel@gentoo.org>2004-05-25 15:42:59 +0000
committerJason Huebel <jhuebel@gentoo.org>2004-05-25 15:42:59 +0000
commitd18765011f3e57e2c90e53a1b4ce5ae4c4d2583b (patch)
treeea586dc3161028742409afa8826deff98cc78033 /media-libs/tse3
parentAdded to ~ppc (Manifest recommit) (diff)
downloadgentoo-2-d18765011f3e57e2c90e53a1b4ce5ae4c4d2583b.tar.gz
gentoo-2-d18765011f3e57e2c90e53a1b4ce5ae4c4d2583b.tar.bz2
gentoo-2-d18765011f3e57e2c90e53a1b4ce5ae4c4d2583b.zip
patch for 64bit systems where size_t != unsigned int, ~amd64
Diffstat (limited to 'media-libs/tse3')
-rw-r--r--media-libs/tse3/ChangeLog9
-rw-r--r--media-libs/tse3/files/tse3-0.2.7-size_t-64bit.patch25
-rw-r--r--media-libs/tse3/tse3-0.2.7.ebuild7
3 files changed, 37 insertions, 4 deletions
diff --git a/media-libs/tse3/ChangeLog b/media-libs/tse3/ChangeLog
index 62f2d710a491..bdf2ff6aa5cf 100644
--- a/media-libs/tse3/ChangeLog
+++ b/media-libs/tse3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/tse3
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/tse3/ChangeLog,v 1.3 2003/07/12 18:06:10 aliz Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tse3/ChangeLog,v 1.4 2004/05/25 15:42:59 jhuebel Exp $
+
+ 25 May 2004; Jason Eric Huebel <jhuebel@gentoo.org>
+ +files/tse3-0.2.7-size_t-64bit.patch, tse3-0.2.7.ebuild:
+ patch for 64bit systems where size_t != unsigned int. provided by Evgeny
+ Stambulchik <fnevgeny@plasma-gate.weizmann.ac.il>
*tse3-0.2.7 (15 Mar 2003)
diff --git a/media-libs/tse3/files/tse3-0.2.7-size_t-64bit.patch b/media-libs/tse3/files/tse3-0.2.7-size_t-64bit.patch
new file mode 100644
index 000000000000..fc30625efcfd
--- /dev/null
+++ b/media-libs/tse3/files/tse3-0.2.7-size_t-64bit.patch
@@ -0,0 +1,25 @@
+--- src/tse3/file/XML.h.orig 2002-07-28 18:17:11.000000000 +0300
++++ src/tse3/file/XML.h 2004-04-25 14:51:56.000000000 +0300
+@@ -154,6 +154,7 @@
+ void element(const std::string &name, const char *value);
+ void element(const std::string &name, int value);
+ void element(const std::string &name, unsigned int value);
++ void element(const std::string &name, size_t value);
+ void element(const std::string &name, bool value);
+
+ void comment(const std::string &comment);
+--- src/tse3/file/XML.cpp.orig 2002-07-28 18:17:11.000000000 +0300
++++ src/tse3/file/XML.cpp 2004-04-25 14:54:01.000000000 +0300
+@@ -116,6 +116,12 @@
+ out << "<" << name << " value=\"" << value << "\"/>\n";
+ }
+
++void TSE3::File::XmlFileWriter::element(const std::string &name, size_t value)
++{
++ indent(out);
++ out << "<" << name << " value=\"" << value << "\"/>\n";
++}
++
+
+ void TSE3::File::XmlFileWriter::element(const std::string &name, bool value)
+ {
diff --git a/media-libs/tse3/tse3-0.2.7.ebuild b/media-libs/tse3/tse3-0.2.7.ebuild
index a33206e552f6..cc8d6a44d2d9 100644
--- a/media-libs/tse3/tse3-0.2.7.ebuild
+++ b/media-libs/tse3/tse3-0.2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/tse3/tse3-0.2.7.ebuild,v 1.5 2004/03/19 07:56:05 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tse3/tse3-0.2.7.ebuild,v 1.6 2004/05/25 15:42:59 jhuebel Exp $
DESCRIPTION="TSE3 Sequencer library"
HOMEPAGE="http://TSE3.sourceforge.net/"
@@ -8,13 +8,16 @@ SRC_URI="mirror://sourceforge/tse3/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~ppc"
+KEYWORDS="x86 ~ppc ~amd64"
IUSE="alsa oss arts"
DEPEND="alsa? ( media-libs/alsa-lib )
arts? ( kde-base/arts )"
src_compile() {
+ # size_t patch for amd64
+ use amd64 && epatch ${FILESDIR}/${P}-size_t-64bit.patch
+
local myconf=""
use arts || myconf="$myconf --without-arts"