summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2011-09-07 02:24:28 +0000
committerPatrick McLean <chutzpah@gentoo.org>2011-09-07 02:24:28 +0000
commit262261ad37dc80ba995bbdea245feb0c2d24a345 (patch)
tree3bff013467fdd20e44fbf01e3ed224c3b568579d /media-libs/x264
parentGenerate relative symlinks to certs when using --root so c_rehash works prope... (diff)
downloadgentoo-2-262261ad37dc80ba995bbdea245feb0c2d24a345.tar.gz
gentoo-2-262261ad37dc80ba995bbdea245feb0c2d24a345.tar.bz2
gentoo-2-262261ad37dc80ba995bbdea245feb0c2d24a345.zip
Version bump, pull a lot of fixes by Nikoli <nikoli@lavabit.com> from the live ebuild. Add custom-cflags USE flag with workaround for bug #376925. Also contains fix for bug #378303.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/x264')
-rw-r--r--media-libs/x264/ChangeLog9
-rw-r--r--media-libs/x264/x264-0.0.20110825.ebuild68
2 files changed, 76 insertions, 1 deletions
diff --git a/media-libs/x264/ChangeLog b/media-libs/x264/ChangeLog
index 8a308af09a7b..1f4ceb09ea82 100644
--- a/media-libs/x264/ChangeLog
+++ b/media-libs/x264/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/x264
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.57 2011/09/03 18:39:24 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.58 2011/09/07 02:24:28 chutzpah Exp $
+
+*x264-0.0.20110825 (07 Sep 2011)
+
+ 07 Sep 2011; Patrick McLean <chutzpah@gentoo.org> +x264-0.0.20110825.ebuild:
+ Version bump, pull a lot of fixes by Nikoli <nikoli@lavabit.com> from the
+ live ebuild. Add custom-cflags USE flag with workaround for bug #376925. Also
+ contains fix for bug #378303.
03 Sep 2011; Maxim Koltsov <maksbotan@gentoo.org> x264-9999.ebuild:
Fix SRC_URI & some cosmetic change. Thanks to Nikoli <nikoli@lavabit.com>
diff --git a/media-libs/x264/x264-0.0.20110825.ebuild b/media-libs/x264/x264-0.0.20110825.ebuild
new file mode 100644
index 000000000000..6e46dbd47e32
--- /dev/null
+++ b/media-libs/x264/x264-0.0.20110825.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20110825.ebuild,v 1.1 2011/09/07 02:24:28 chutzpah Exp $
+
+EAPI=4
+inherit eutils flag-o-matic multilib toolchain-funcs versionator
+
+MY_P=x264-snapshot-$(get_version_component_range 3)-2245
+
+DESCRIPTION="A free library for encoding X264/AVC streams"
+HOMEPAGE="http://www.videolan.org/developers/x264.html"
+SRC_URI="ftp://ftp.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="custom-cflags debug +threads pic static-libs"
+
+RDEPEND=""
+DEPEND="amd64? ( >=dev-lang/yasm-0.6.2 )
+ x86? ( >=dev-lang/yasm-0.6.2 )
+ x86-fbsd? ( >=dev-lang/yasm-0.6.2 )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS doc/*.txt"
+
+src_configure() {
+ tc-export CC
+
+ local myconf=""
+ use debug && myconf+=" --enable-debug"
+ use static-libs && myconf+=" --enable-static"
+ use threads || myconf+=" --disable-thread"
+
+ # let upstream pick the optimization level by default
+ use custom-cflags || filter-flags -O?
+
+ if use x86 && use pic; then
+ myconf+=" --disable-asm"
+ fi
+
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --disable-cli \
+ --disable-avs \
+ --disable-lavf \
+ --disable-swscale \
+ --disable-ffms \
+ --disable-gpac \
+ --enable-pic \
+ --enable-shared \
+ --host="${CHOST}" \
+ ${myconf} \
+ || die
+
+ # this is a nasty workaround for bug #376925 as upstream doesn't like us
+ # fiddling with their CFLAGS
+ if use custom-cflags; then
+ local cflags
+ cflags="$(grep "^CFLAGS=" config.mak | sed 's/CFLAGS=//')"
+ cflags="${cflags//$(get-flag O)/}"
+ cflags="${cflags//-O?/$(get-flag O)}"
+ cflags="${cflags//-g/}"
+ sed -i "s:^CFLAGS=.*:CFLAGS=${cflags//:/\\:}:" config.mak
+ fi
+}