summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-06-06 10:37:33 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-06-06 10:37:33 +0000
commit3bc681acd5b06e853e469b6195a2c04c0fe43964 (patch)
tree6ada424a8741215e78d4c06c2d3cb46f47ae5922 /media-libs/x264
parentForce Python 2.x wrt #317009. (diff)
downloadgentoo-2-3bc681acd5b06e853e469b6195a2c04c0fe43964.tar.gz
gentoo-2-3bc681acd5b06e853e469b6195a2c04c0fe43964.tar.bz2
gentoo-2-3bc681acd5b06e853e469b6195a2c04c0fe43964.zip
bump a new snapshot
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/x264')
-rw-r--r--media-libs/x264/ChangeLog8
-rw-r--r--media-libs/x264/files/x264-onlylib-20100605.patch30
-rw-r--r--media-libs/x264/x264-0.0.20100605.ebuild61
3 files changed, 98 insertions, 1 deletions
diff --git a/media-libs/x264/ChangeLog b/media-libs/x264/ChangeLog
index 31c9f58e27e6..2f144d6f1d85 100644
--- a/media-libs/x264/ChangeLog
+++ b/media-libs/x264/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/x264
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.34 2010/04/24 15:46:48 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.35 2010/06/06 10:37:33 aballier Exp $
+
+*x264-0.0.20100605 (06 Jun 2010)
+
+ 06 Jun 2010; Alexis Ballier <aballier@gentoo.org>
+ +x264-0.0.20100605.ebuild, +files/x264-onlylib-20100605.patch:
+ bump a new snapshot
*x264-0.0.20100423 (24 Apr 2010)
diff --git a/media-libs/x264/files/x264-onlylib-20100605.patch b/media-libs/x264/files/x264-onlylib-20100605.patch
new file mode 100644
index 000000000000..3f400ce9b2f8
--- /dev/null
+++ b/media-libs/x264/files/x264-onlylib-20100605.patch
@@ -0,0 +1,30 @@
+Index: x264-snapshot-20100605-2245/Makefile
+===================================================================
+--- x264-snapshot-20100605-2245.orig/Makefile
++++ x264-snapshot-20100605-2245/Makefile
+@@ -118,7 +118,7 @@ DEP = depend
+
+ .PHONY: all default fprofiled clean distclean install uninstall dox test testclean
+
+-default: $(DEP) x264$(EXE)
++default: $(DEP)
+
+ libx264.a: .depend $(OBJS) $(OBJASM)
+ $(AR) rc libx264.a $(OBJS) $(OBJASM)
+@@ -193,7 +193,7 @@ distclean: clean
+ rm -f config.mak config.h config.log x264.pc
+ rm -rf test/
+
+-install: x264$(EXE) $(SONAME)
++install: libx264.a $(SONAME)
+ install -d $(DESTDIR)$(bindir)
+ install -d $(DESTDIR)$(includedir)
+ install -d $(DESTDIR)$(libdir)
+@@ -201,7 +201,6 @@ install: x264$(EXE) $(SONAME)
+ install -m 644 x264.h $(DESTDIR)$(includedir)
+ install -m 644 libx264.a $(DESTDIR)$(libdir)
+ install -m 644 x264.pc $(DESTDIR)$(libdir)/pkgconfig
+- install x264$(EXE) $(DESTDIR)$(bindir)
+ $(RANLIB) $(DESTDIR)$(libdir)/libx264.a
+ ifeq ($(SYS),MINGW)
+ $(if $(SONAME), install -m 755 $(SONAME) $(DESTDIR)$(bindir))
diff --git a/media-libs/x264/x264-0.0.20100605.ebuild b/media-libs/x264/x264-0.0.20100605.ebuild
new file mode 100644
index 000000000000..08145ca6f902
--- /dev/null
+++ b/media-libs/x264/x264-0.0.20100605.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20100605.ebuild,v 1.1 2010/06/06 10:37:33 aballier Exp $
+
+EAPI=2
+inherit eutils multilib toolchain-funcs versionator
+
+MY_P=x264-snapshot-$(get_version_component_range 3)-2245
+
+DESCRIPTION="A free library for encoding X264/AVC streams"
+HOMEPAGE="http://www.videolan.org/developers/x264.html"
+SRC_URI="ftp://ftp.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +threads pic"
+
+RDEPEND=""
+DEPEND="amd64? ( >=dev-lang/yasm-0.6.2 )
+ x86? ( >=dev-lang/yasm-0.6.2 )
+ x86-fbsd? ( >=dev-lang/yasm-0.6.2 )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-nostrip.patch \
+ "${FILESDIR}"/${PN}-onlylib-20100605.patch
+}
+
+src_configure() {
+ tc-export CC
+
+ local myconf=""
+ use debug && myconf="${myconf} --enable-debug"
+
+ if use x86 && use pic; then
+ myconf="${myconf} --disable-asm"
+ fi
+
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --disable-avs-input \
+ --disable-lavf-input \
+ --disable-mp4-output \
+ $(use_enable threads pthread) \
+ --enable-pic \
+ --enable-shared \
+ --extra-asflags="${ASFLAGS}" \
+ --extra-cflags="${CFLAGS}" \
+ --extra-ldflags="${LDFLAGS}" \
+ --host="${CHOST}" \
+ ${myconf} \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS doc/*.txt
+}