summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2011-09-07 17:56:15 +0000
committerPatrick McLean <chutzpah@gentoo.org>2011-09-07 17:56:15 +0000
commit8e236f94bfc199cecbce64330f5acee51219bacc (patch)
tree4dfa2dc28ee92b5a8fc346253073479b18d58160 /media-libs/x264
parentrevision bump to fix bug 252280 by Ian Stakenvicius (diff)
downloadgentoo-2-8e236f94bfc199cecbce64330f5acee51219bacc.tar.gz
gentoo-2-8e236f94bfc199cecbce64330f5acee51219bacc.tar.bz2
gentoo-2-8e236f94bfc199cecbce64330f5acee51219bacc.zip
Add enabled-by-default "interlaced" USE flag to allow disabling of interlacing support. This can speed up encoding by up to 2%.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/x264')
-rw-r--r--media-libs/x264/ChangeLog7
-rw-r--r--media-libs/x264/metadata.xml1
-rw-r--r--media-libs/x264/x264-0.0.20110825.ebuild5
3 files changed, 10 insertions, 3 deletions
diff --git a/media-libs/x264/ChangeLog b/media-libs/x264/ChangeLog
index e919158d0247..c1cc68f2c3ee 100644
--- a/media-libs/x264/ChangeLog
+++ b/media-libs/x264/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/x264
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.59 2011/09/07 09:04:25 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.60 2011/09/07 17:56:15 chutzpah Exp $
+
+ 07 Sep 2011; Patrick McLean <chutzpah@gentoo.org> x264-0.0.20110825.ebuild,
+ metadata.xml:
+ Add enabled-by-default "interlaced" USE flag to allow disabling of
+ interlacing support. This can speed up encoding by up to 2%.
07 Sep 2011; Diego E. Pettenò <flameeyes@gentoo.org>
x264-0.0.20110825.ebuild:
diff --git a/media-libs/x264/metadata.xml b/media-libs/x264/metadata.xml
index dc77ccda7e4a..321f7b28784f 100644
--- a/media-libs/x264/metadata.xml
+++ b/media-libs/x264/metadata.xml
@@ -7,5 +7,6 @@
</maintainer>
<use>
<flag name="pic">disable optimized assembly code that is not PIC friendly</flag>
+ <flag name="interlaced">enable interlaced encoding support, this can decrease encoding speed by up to 2%</flag>
</use>
</pkgmetadata>
diff --git a/media-libs/x264/x264-0.0.20110825.ebuild b/media-libs/x264/x264-0.0.20110825.ebuild
index 388fc0ab3b10..01612d74cd4d 100644
--- a/media-libs/x264/x264-0.0.20110825.ebuild
+++ b/media-libs/x264/x264-0.0.20110825.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20110825.ebuild,v 1.2 2011/09/07 09:04:25 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20110825.ebuild,v 1.3 2011/09/07 17:56:15 chutzpah Exp $
EAPI=4
inherit eutils flag-o-matic multilib toolchain-funcs versionator
@@ -14,7 +14,7 @@ SRC_URI="ftp://ftp.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="custom-cflags debug +threads pic static-libs"
+IUSE="custom-cflags debug +interlaced pic static-libs +threads"
RDEPEND=""
DEPEND="amd64? ( >=dev-lang/yasm-0.6.2 )
@@ -32,6 +32,7 @@ src_configure() {
use debug && myconf+=" --enable-debug"
use static-libs && myconf+=" --enable-static"
use threads || myconf+=" --disable-thread"
+ use interlaced || myconf+=" --disable-interlaced"
# let upstream pick the optimization level by default
use custom-cflags || filter-flags -O?