summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-07-10 13:23:48 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-07-10 13:23:48 +0000
commit400f304ead3efbf6cfa7aed3dfc8605d5a8466fb (patch)
treea7a5030f19ca6c69c84fc77ec75d169c31a9d1b2 /media-libs/xine-lib
parentCleanup old versions (diff)
downloadgentoo-2-400f304ead3efbf6cfa7aed3dfc8605d5a8466fb.tar.gz
gentoo-2-400f304ead3efbf6cfa7aed3dfc8605d5a8466fb.tar.bz2
gentoo-2-400f304ead3efbf6cfa7aed3dfc8605d5a8466fb.zip
Version bump; based on 1.2.9999 wrt #514474
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-libs/xine-lib')
-rw-r--r--media-libs/xine-lib/ChangeLog8
-rw-r--r--media-libs/xine-lib/xine-lib-1.2.6.ebuild223
-rw-r--r--media-libs/xine-lib/xine-lib-1.2.9999.ebuild16
3 files changed, 241 insertions, 6 deletions
diff --git a/media-libs/xine-lib/ChangeLog b/media-libs/xine-lib/ChangeLog
index c1885880c089..31914fd639a9 100644
--- a/media-libs/xine-lib/ChangeLog
+++ b/media-libs/xine-lib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/xine-lib
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.708 2014/07/10 13:04:15 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.709 2014/07/10 13:23:48 ssuominen Exp $
+
+*xine-lib-1.2.6 (10 Jul 2014)
+
+ 10 Jul 2014; Samuli Suominen <ssuominen@gentoo.org> +xine-lib-1.2.6.ebuild,
+ xine-lib-1.2.9999.ebuild:
+ Version bump; based on 1.2.9999 wrt #514474
10 Jul 2014; Samuli Suominen <ssuominen@gentoo.org> xine-lib-1.2.5.ebuild,
xine-lib-1.2.9999.ebuild:
diff --git a/media-libs/xine-lib/xine-lib-1.2.6.ebuild b/media-libs/xine-lib/xine-lib-1.2.6.ebuild
new file mode 100644
index 000000000000..4f275c3bf5c7
--- /dev/null
+++ b/media-libs/xine-lib/xine-lib-1.2.6.ebuild
@@ -0,0 +1,223 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1.2.6.ebuild,v 1.1 2014/07/10 13:23:48 ssuominen Exp $
+
+EAPI=5
+
+inherit flag-o-matic libtool multilib
+
+if [[ ${PV} == *9999* ]]; then
+ EHG_REPO_URI="http://hg.debian.org/hg/xine-lib/xine-lib-1.2"
+ inherit autotools mercurial eutils
+ unset NLS_IUSE
+ NLS_DEPEND="sys-devel/gettext"
+ NLS_RDEPEND="virtual/libintl"
+else
+ KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd"
+ SRC_URI="mirror://sourceforge/xine/${P}.tar.xz"
+ NLS_IUSE="nls"
+ NLS_DEPEND="nls? ( sys-devel/gettext )"
+ NLS_RDEPEND="nls? ( virtual/libintl )"
+fi
+
+DESCRIPTION="Core libraries for Xine movie player"
+HOMEPAGE="http://xine.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="1"
+IUSE="a52 aac aalib +alsa altivec bluray +css directfb dts dvb dxr3 fbcon flac fusion gtk imagemagick ipv6 jack jpeg libcaca mad +mmap mng modplug musepack opengl oss pulseaudio samba sdl speex theora truetype v4l vaapi vcd vdpau vdr vidix +vis vorbis vpx wavpack +X +xcb xinerama +xv xvmc ${NLS_IUSE}"
+
+RDEPEND="${NLS_RDEPEND}
+ dev-libs/libxdg-basedir
+ media-libs/libdvdnav
+ sys-libs/zlib
+ || ( media-video/ffmpeg:0 media-libs/libpostproc <media-video/libav-0.8.2-r1 )
+ virtual/ffmpeg
+ virtual/libiconv
+ a52? ( media-libs/a52dec )
+ aac? ( media-libs/faad2 )
+ aalib? ( media-libs/aalib )
+ alsa? ( media-libs/alsa-lib )
+ bluray? ( >=media-libs/libbluray-0.2.1 )
+ css? ( >=media-libs/libdvdcss-1.2.10 )
+ directfb? ( dev-libs/DirectFB )
+ dts? ( media-libs/libdca )
+ dxr3? ( media-libs/libfame )
+ flac? ( media-libs/flac )
+ fusion? ( media-libs/FusionSound )
+ gtk? ( x11-libs/gdk-pixbuf:2 )
+ imagemagick? ( || ( media-gfx/imagemagick media-gfx/graphicsmagick ) )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.100 )
+ jpeg? ( virtual/jpeg:0 )
+ libcaca? ( media-libs/libcaca )
+ mad? ( media-libs/libmad )
+ mng? ( media-libs/libmng )
+ modplug? ( >=media-libs/libmodplug-0.8.8.1 )
+ musepack? ( >=media-sound/musepack-tools-444 )
+ opengl? (
+ virtual/glu
+ virtual/opengl
+ )
+ pulseaudio? ( media-sound/pulseaudio )
+ samba? ( net-fs/samba )
+ sdl? ( media-libs/libsdl )
+ speex? (
+ media-libs/libogg
+ media-libs/speex
+ )
+ theora? (
+ media-libs/libogg
+ media-libs/libtheora
+ )
+ truetype? (
+ media-libs/fontconfig
+ media-libs/freetype:2
+ )
+ v4l? ( media-libs/libv4l )
+ vaapi? ( x11-libs/libva )
+ vcd? (
+ >=media-video/vcdimager-0.7.23
+ dev-libs/libcdio[-minimal]
+ )
+ vdpau? ( x11-libs/libvdpau )
+ vorbis? (
+ media-libs/libogg
+ media-libs/libvorbis
+ )
+ vpx? ( media-libs/libvpx )
+ wavpack? ( media-sound/wavpack )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ )
+ xcb? ( x11-libs/libxcb )
+ xinerama? ( x11-libs/libXinerama )
+ xv? ( x11-libs/libXv )
+ xvmc? ( x11-libs/libXvMC )"
+DEPEND="${RDEPEND}
+ ${NLS_DEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+ >=sys-devel/libtool-2.2.6b
+ oss? ( virtual/os-headers )
+ v4l? ( virtual/os-headers )
+ X? (
+ x11-libs/libXt
+ x11-proto/xf86vidmodeproto
+ x11-proto/xproto
+ )
+ xv? ( x11-proto/videoproto )
+ xvmc? ( x11-proto/videoproto )
+ xinerama? ( x11-proto/xineramaproto )"
+REQUIRED_USE="vidix? ( || ( X fbcon ) )
+ xv? ( X )
+ xinerama? ( X )"
+
+src_prepare() {
+ sed -i -e '/define VDR_ABS_FIFO_DIR/s|".*"|"/var/vdr/xine"|' src/vdr/input_vdr.c || die
+
+ if [[ ${PV} == *9999* ]]; then
+ epatch_user
+ eautoreconf
+ else
+ elibtoolize
+ fi
+
+ local x
+ for x in 0 1 2 3; do
+ sed -i -e "/^O${x}_CFLAGS=\"-O${x}\"/d" configure || die
+ done
+}
+
+src_configure() {
+ [[ ${CHOST} == i?86-* ]] && append-flags -fomit-frame-pointer #422519
+
+ local win32dir #197236
+ if has_multilib_profile; then
+ win32dir=/usr/$(ABI="x86" get_libdir)/win32
+ else
+ win32dir=/usr/$(get_libdir)/win32
+ fi
+
+ local myconf=()
+ [[ ${PV} == *9999* ]] || myconf=( $(use_enable nls) )
+
+ if has_version '>=media-video/ffmpeg-2.2:0'; then
+ myconf+=( --enable-avformat ) #507474
+ fi
+
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable altivec) \
+ $(use_enable vis) \
+ --disable-optimizations \
+ $(use_enable mmap) \
+ $(use_enable oss) \
+ $(use_enable aalib) \
+ $(use_enable directfb) \
+ $(use_enable dxr3) \
+ $(use_enable fbcon fb) \
+ $(use_enable opengl) $(use_enable opengl glu) \
+ $(use_enable vidix) \
+ $(use_enable xinerama) \
+ $(use_enable xvmc) \
+ $(use_enable vdpau) \
+ $(use_enable vaapi) \
+ $(use_enable dvb) \
+ --disable-gnomevfs \
+ $(use_enable samba) \
+ --disable-v4l $(use_enable v4l v4l2) $(use_enable v4l libv4l) \
+ $(use_enable vcd) \
+ $(use_enable vdr) \
+ $(use_enable bluray) \
+ $(use_enable a52 a52dec) \
+ $(use_enable aac faad) \
+ $(use_enable gtk gdkpixbuf) \
+ $(use_enable jpeg libjpeg) \
+ $(use_enable dts) \
+ $(use_enable mad) \
+ $(use_enable modplug) \
+ $(use_enable musepack) \
+ $(use_enable mng) \
+ --disable-real-codecs \
+ --disable-w32dll \
+ $(use_enable vpx) \
+ $(use_with truetype freetype) $(use_with truetype fontconfig) \
+ $(use_with X x) \
+ $(use_with alsa) \
+ --without-esound \
+ $(use_with fusion fusionsound) \
+ $(use_with jack) \
+ $(use_with pulseaudio) \
+ $(use_with libcaca caca) \
+ $(use_with sdl) \
+ $(use_with xcb) \
+ --with-xv-path=/usr/$(get_libdir) \
+ $(use_with imagemagick) \
+ --with-external-dvdnav \
+ $(use_with flac libflac) \
+ $(use_with speex) \
+ $(use_with theora) \
+ $(use_with vorbis) \
+ --with-real-codecs-path=/usr/$(get_libdir)/codecs \
+ --with-w32-path=${win32dir} \
+ $(use_with wavpack) \
+ ${myconf[@]}
+}
+
+src_compile() {
+ # enable verbose building, bug #448140
+ emake V=1
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ docdir="/usr/share/doc/${PF}" \
+ htmldir="/usr/share/doc/${PF}/html" \
+ install
+
+ rm -f \
+ "${ED}"usr/lib*/libxine*.la \
+ "${ED}"usr/share/doc/${PF}/COPYING
+}
diff --git a/media-libs/xine-lib/xine-lib-1.2.9999.ebuild b/media-libs/xine-lib/xine-lib-1.2.9999.ebuild
index 5177b43e6cec..ce293a9ccf75 100644
--- a/media-libs/xine-lib/xine-lib-1.2.9999.ebuild
+++ b/media-libs/xine-lib/xine-lib-1.2.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1.2.9999.ebuild,v 1.26 2014/07/10 13:04:15 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1.2.9999.ebuild,v 1.27 2014/07/10 13:23:48 ssuominen Exp $
EAPI=5
@@ -25,7 +25,7 @@ HOMEPAGE="http://xine.sourceforge.net/"
LICENSE="GPL-2"
SLOT="1"
-IUSE="a52 aac aalib +alsa altivec bluray +css directfb dts dvb dxr3 fbcon flac fusion gtk imagemagick ipv6 jack jpeg libcaca mad +mmap mng modplug musepack opengl oss pulseaudio samba sdl speex theora truetype v4l vaapi vcd vdpau vdr vidix +vis vorbis wavpack +X +xcb xinerama +xv xvmc ${NLS_IUSE}"
+IUSE="a52 aac aalib +alsa altivec bluray +css directfb dts dvb dxr3 fbcon flac fusion gtk imagemagick ipv6 jack jpeg libcaca mad +mmap mng modplug musepack opengl oss pulseaudio samba sdl speex theora truetype v4l vaapi vcd vdpau vdr vidix +vis vorbis vpx wavpack +X +xcb xinerama +xv xvmc ${NLS_IUSE}"
RDEPEND="${NLS_RDEPEND}
dev-libs/libxdg-basedir
@@ -84,6 +84,7 @@ RDEPEND="${NLS_RDEPEND}
media-libs/libogg
media-libs/libvorbis
)
+ vpx? ( media-libs/libvpx )
wavpack? ( media-sound/wavpack )
X? (
x11-libs/libX11
@@ -138,8 +139,12 @@ src_configure() {
win32dir=/usr/$(get_libdir)/win32
fi
- local myconf
- [[ ${PV} == *9999* ]] || myconf="$(use_enable nls)"
+ local myconf=()
+ [[ ${PV} == *9999* ]] || myconf=( $(use_enable nls) )
+
+ if has_version '>=media-video/ffmpeg-2.2:0'; then
+ myconf+=( --enable-avformat ) #507474
+ fi
econf \
$(use_enable ipv6) \
@@ -176,6 +181,7 @@ src_configure() {
$(use_enable mng) \
--disable-real-codecs \
--disable-w32dll \
+ $(use_enable vpx) \
$(use_with truetype freetype) $(use_with truetype fontconfig) \
$(use_with X x) \
$(use_with alsa) \
@@ -196,7 +202,7 @@ src_configure() {
--with-real-codecs-path=/usr/$(get_libdir)/codecs \
--with-w32-path=${win32dir} \
$(use_with wavpack) \
- ${myconf}
+ ${myconf[@]}
}
src_compile() {