summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-07-31 19:15:32 +0000
committerMike Frysinger <vapier@gentoo.org>2003-07-31 19:15:32 +0000
commit172884cd28de5f6cd20a4296ddf9b90a3360c11f (patch)
tree138a97ac4e4dda4fa02d3396d7f82e73c748bf16 /media-libs/yiff
parentadded updated patch (diff)
downloadgentoo-2-172884cd28de5f6cd20a4296ddf9b90a3360c11f.tar.gz
gentoo-2-172884cd28de5f6cd20a4296ddf9b90a3360c11f.tar.bz2
gentoo-2-172884cd28de5f6cd20a4296ddf9b90a3360c11f.zip
initial ebuild
Diffstat (limited to 'media-libs/yiff')
-rw-r--r--media-libs/yiff/ChangeLog8
-rw-r--r--media-libs/yiff/files/2.14.2-gcc3.patch77
-rw-r--r--media-libs/yiff/files/digest-yiff-2.14.21
-rw-r--r--media-libs/yiff/yiff-2.14.2.ebuild39
4 files changed, 125 insertions, 0 deletions
diff --git a/media-libs/yiff/ChangeLog b/media-libs/yiff/ChangeLog
new file mode 100644
index 000000000000..167a22558765
--- /dev/null
+++ b/media-libs/yiff/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for media-libs/yiff
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/yiff/ChangeLog,v 1.1 2003/07/31 19:15:32 vapier Exp $
+
+*yiff-2.14.2 (31 Jul 2003)
+
+ 31 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/media-libs/yiff/files/2.14.2-gcc3.patch b/media-libs/yiff/files/2.14.2-gcc3.patch
new file mode 100644
index 000000000000..e80db2186cbc
--- /dev/null
+++ b/media-libs/yiff/files/2.14.2-gcc3.patch
@@ -0,0 +1,77 @@
+--- yiffutils/ymixer.c.orig 2003-07-31 14:52:34.000000000 -0400
++++ yiffutils/ymixer.c 2003-07-31 14:53:28.000000000 -0400
+@@ -23,26 +23,26 @@
+ */
+ static void print_help(void)
+ {
+- printf("\
+-Usage: ymixer [mixer] [value1] [value2] [value3] [value4] [options]\n\
+-\n\
+- [mixer] specifies the mixer channel device name, running without\n\
+- any arguments prints a list of available mixer names.
+-\n\
+- [value#] specify the percent values (from 0.0%%, 100.0%%) to be set.\n\
+- If no [value#] is specified then the current value is printed.\n\
+-\n\
+- [options] can be any of the following:\n\
+-\n\
+- --recorder <address:port> Specify which Y server to connect to.\n\
+-\n\
+- Return values:\n\
+-\n\
+- 0 Success.\n\
+- 1 General error.\n\
+- 2 Cannot connect to Y server error.\n\
+- 3 Systems error.\n\
+-\n"
++ printf("\n"\
++"Usage: ymixer [mixer] [value1] [value2] [value3] [value4] [options]\n"\
++"\n"\
++" [mixer] specifies the mixer channel device name, running without\n"\
++" any arguments prints a list of available mixer names."\
++"\n"\
++" [value#] specify the percent values (from 0.0%%, 100.0%%) to be set.\n"\
++" If no [value#] is specified then the current value is printed.\n"\
++"\n"\
++" [options] can be any of the following:\n"\
++"\n"\
++" --recorder <address:port> Specify which Y server to connect to.\n"\
++"\n"\
++" Return values:\n"\
++"\n"\
++" 0 Success.\n"\
++" 1 General error.\n"\
++" 2 Cannot connect to Y server error.\n"\
++" 3 Systems error.\n"\
++"\n"
+ );
+ }
+
+--- yiffconfig/yccb.c.orig 2003-07-31 14:51:20.000000000 -0400
++++ yiffconfig/yccb.c 2003-07-31 14:52:19.000000000 -0400
+@@ -1302,10 +1302,10 @@
+ {
+ CDialogGetResponse(
+ "No Y Audio Mode selected!",
+-"There is no Y Audio Mode currently selected to apply\n\
+-values for.",
+-"You must select a Y Audio Mode from the list and then
+-apply its values to the Y server.",
++"There is no Y Audio Mode currently selected to apply\n"\
++"values for.",
++"You must select a Y Audio Mode from the list and then"\
++"apply its values to the Y server.",
+ CDIALOG_ICON_ERROR,
+ CDIALOG_RESPONSE_OK | CDIALOG_RESPONSE_HELP,
+ CDIALOG_RESPONSE_OK
+--- yiff/Makefile.Linux 2003-07-31 14:50:45.000000000 -0400
++++ yiff/Makefile.Linux 2003-07-31 14:50:53.000000000 -0400
+@@ -111,7 +111,7 @@
+ # farther above.
+ #
+ #LIB = -lm -lkmid
+-LIB = -lm
++LIB = -lm -lstdc++
+
+ # Library Directories:
+ #
diff --git a/media-libs/yiff/files/digest-yiff-2.14.2 b/media-libs/yiff/files/digest-yiff-2.14.2
new file mode 100644
index 000000000000..3335e9b8c8ae
--- /dev/null
+++ b/media-libs/yiff/files/digest-yiff-2.14.2
@@ -0,0 +1 @@
+MD5 00c446190892989a167769fb9ea2c037 yiff-2.14.2.tar.bz2 519464
diff --git a/media-libs/yiff/yiff-2.14.2.ebuild b/media-libs/yiff/yiff-2.14.2.ebuild
new file mode 100644
index 000000000000..8d113216d6a6
--- /dev/null
+++ b/media-libs/yiff/yiff-2.14.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/yiff/yiff-2.14.2.ebuild,v 1.1 2003/07/31 19:15:32 vapier Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="high performance and stable sound server for UNIX games and apps"
+HOMEPAGE="http://wolfpack.twu.net/YIFF/"
+SRC_URI="ftp://wolfpack.twu.net/users/wolfpack/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="gtk mikmod"
+
+DEPEND="gtk? ( =x11-libs/gtk+-1.2* )
+ mikmod? ( media-libs/libmikmod )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gcc3.patch
+}
+
+src_compile() {
+ local pkgs="libY2 yiff yiffutils"
+ [ `use gtk` ] && pkgs="${pkgs} yiffconfig" && append-flags `gtk-config --cflags`
+ [ `use mikmod` ] && append-flags -DHAVE_LIBKMID
+ append-flags -DALSA_RUN_CONFORM -DOSS -DOSS_BUFFRAG -DYSHM_SUPPORT -D__USE_BSD
+ make linux \
+ CFLAGS="${CFLAGS}" \
+ LINUX_DIRS="${pkgs}" \
+ || die
+}
+
+src_install() {
+ make install PREFIX=${D}/usr || die
+ dodoc AUTHORS README
+}