summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2014-09-07 14:46:22 +0000
committerFabian Groffen <grobian@gentoo.org>2014-09-07 14:46:22 +0000
commit3b0f2397255cc1ba06c2a20025bee8bdcf3be4f5 (patch)
treeea20dda77986955e4f8f6691322b2c76c2eb8fdd /media-libs
parentVersion bump, drop old, collides with old colohug-client versions (#520936 by... (diff)
downloadgentoo-2-3b0f2397255cc1ba06c2a20025bee8bdcf3be4f5.tar.gz
gentoo-2-3b0f2397255cc1ba06c2a20025bee8bdcf3be4f5.tar.bz2
gentoo-2-3b0f2397255cc1ba06c2a20025bee8bdcf3be4f5.zip
Add back font paths for as long as we don't understand why fontconfig doesn't work, bug #518970
(Portage version: 2.2.10.1-prefix/cvs/SunOS i386, signed Manifest commit with key 0x5F75F607C5C74E89)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gd/ChangeLog6
-rw-r--r--media-libs/gd/gd-2.0.35-r4.ebuild29
2 files changed, 32 insertions, 3 deletions
diff --git a/media-libs/gd/ChangeLog b/media-libs/gd/ChangeLog
index 60a95c8fefce..70e18e293838 100644
--- a/media-libs/gd/ChangeLog
+++ b/media-libs/gd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/gd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gd/ChangeLog,v 1.100 2014/08/25 10:59:22 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gd/ChangeLog,v 1.101 2014/09/07 14:46:22 grobian Exp $
+
+ 07 Sep 2014; Fabian Groffen <grobian@gentoo.org> gd-2.0.35-r4.ebuild:
+ Add back font paths for as long as we don't understand why fontconfig doesn't
+ work, bug #518970
25 Aug 2014; Agostino Sarubbo <ago@gentoo.org> gd-2.0.35-r4.ebuild:
Stable for alpha, wrt bug #512012
diff --git a/media-libs/gd/gd-2.0.35-r4.ebuild b/media-libs/gd/gd-2.0.35-r4.ebuild
index bad8057d9e8d..7622949d0d7f 100644
--- a/media-libs/gd/gd-2.0.35-r4.ebuild
+++ b/media-libs/gd/gd-2.0.35-r4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gd/gd-2.0.35-r4.ebuild,v 1.12 2014/08/25 10:59:22 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gd/gd-2.0.35-r4.ebuild,v 1.13 2014/09/07 14:46:22 grobian Exp $
EAPI="5"
-inherit autotools eutils multilib-minimal
+inherit autotools eutils flag-o-matic multilib-minimal
DESCRIPTION="A graphics library for fast image creation"
HOMEPAGE="http://libgd.org/ http://www.boutell.com/gd/"
@@ -54,6 +54,31 @@ src_prepare() {
}
multilib_src_configure() {
+ # setup a default FONT path that has a chance of existing using corefonts,
+ # as to make it more useful with e.g. gnuplot
+ local fontpath="${EPREFIX}/usr/share/fonts/corefonts"
+ # like with fontconfig, try to use fonts from the host OS, because that's
+ # beneficial for the user
+ use prefix && case ${CHOST} in
+ *-darwin*)
+ fontpath+=":/Library/Fonts:/System/Library/Fonts"
+ ;;
+ *-solaris*)
+ [[ -d /usr/X/lib/X11/fonts/TrueType ]] && \
+ fontpath+=":/usr/X/lib/X11/fonts/TrueType"
+ [[ -d /usr/X/lib/X11/fonts/Type1 ]] && \
+ fontpath+=":/usr/X/lib/X11/fonts/Type1"
+ # OpenIndiana
+ [[ -d /usr/share/fonts/X11/Type1 ]] && \
+ fontpath+=":/usr/share/fonts/X11/Type1"
+ ;;
+ *-linux-gnu)
+ [[ -d /usr/share/fonts/truetype ]] && \
+ fontpath+=":/usr/share/fonts/truetype"
+ ;;
+ esac
+ append-cppflags "-DDEFAULT_FONTPATH=\\\"${fontpath}\\\""
+
export ac_cv_lib_z_deflate=$(usex zlib)
# we aren't actually {en,dis}abling X here ... the configure
# script uses it just to add explicit -I/-L paths which we