summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-04-27 17:20:07 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-04-27 17:20:07 +0000
commit96885b9e30c8c3c900d871587c431f71bd55ec24 (patch)
tree337090e8b089e66247384d749deb478a6060d291 /media-libs
parentStable for HPPA (bug #362025). (diff)
downloadgentoo-2-96885b9e30c8c3c900d871587c431f71bd55ec24.tar.gz
gentoo-2-96885b9e30c8c3c900d871587c431f71bd55ec24.tar.bz2
gentoo-2-96885b9e30c8c3c900d871587c431f71bd55ec24.zip
new snapshot
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/x264/ChangeLog8
-rw-r--r--media-libs/x264/files/x264-onlylib-20110425.patch30
-rw-r--r--media-libs/x264/x264-0.0.20110426.ebuild62
3 files changed, 99 insertions, 1 deletions
diff --git a/media-libs/x264/ChangeLog b/media-libs/x264/ChangeLog
index 1a0cac3450f8..367048a08718 100644
--- a/media-libs/x264/ChangeLog
+++ b/media-libs/x264/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/x264
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.48 2011/02/24 13:25:45 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.49 2011/04/27 17:20:07 aballier Exp $
+
+*x264-0.0.20110426 (27 Apr 2011)
+
+ 27 Apr 2011; Alexis Ballier <aballier@gentoo.org> +x264-0.0.20110426.ebuild,
+ +files/x264-onlylib-20110425.patch:
+ new snapshot
*x264-0.0.20110223 (24 Feb 2011)
diff --git a/media-libs/x264/files/x264-onlylib-20110425.patch b/media-libs/x264/files/x264-onlylib-20110425.patch
new file mode 100644
index 000000000000..6f216b92fa8e
--- /dev/null
+++ b/media-libs/x264/files/x264-onlylib-20110425.patch
@@ -0,0 +1,30 @@
+Index: x264-snapshot-20110425-2245/Makefile
+===================================================================
+--- x264-snapshot-20110425-2245.orig/Makefile
++++ x264-snapshot-20110425-2245/Makefile
+@@ -137,7 +137,7 @@ DEP = depend
+
+ .PHONY: all default fprofiled clean distclean install uninstall dox test testclean
+
+-default: $(DEP) x264$(EXE)
++default: $(DEP)
+
+ $(LIBX264): .depend $(OBJS) $(OBJASM)
+ $(AR)$@ $(OBJS) $(OBJASM)
+@@ -207,7 +207,7 @@ distclean: clean
+ rm -f config.mak x264_config.h config.h config.log x264.pc x264.def
+ rm -rf test/
+
+-install: x264$(EXE) $(SONAME)
++install: $(LIBX264) $(SONAME)
+ install -d $(DESTDIR)$(bindir)
+ install -d $(DESTDIR)$(includedir)
+ install -d $(DESTDIR)$(libdir)
+@@ -216,7 +216,6 @@ install: x264$(EXE) $(SONAME)
+ install -m 644 x264_config.h $(DESTDIR)$(includedir)
+ install -m 644 $(LIBX264) $(DESTDIR)$(libdir)
+ install -m 644 x264.pc $(DESTDIR)$(libdir)/pkgconfig
+- install x264$(EXE) $(DESTDIR)$(bindir)
+ $(if $(RANLIB), $(RANLIB) $(DESTDIR)$(libdir)/$(LIBX264))
+ ifeq ($(SYS),WINDOWS)
+ $(if $(SONAME), install -m 755 $(SONAME) $(DESTDIR)$(bindir))
diff --git a/media-libs/x264/x264-0.0.20110426.ebuild b/media-libs/x264/x264-0.0.20110426.ebuild
new file mode 100644
index 000000000000..bf92c374adc7
--- /dev/null
+++ b/media-libs/x264/x264-0.0.20110426.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20110426.ebuild,v 1.1 2011/04/27 17:20:07 aballier Exp $
+
+EAPI=2
+inherit eutils multilib toolchain-funcs versionator
+
+MY_P=x264-snapshot-$(get_version_component_range 3)-2245
+
+DESCRIPTION="A free library for encoding X264/AVC streams"
+HOMEPAGE="http://www.videolan.org/developers/x264.html"
+SRC_URI="http://ftp.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +threads pic"
+
+RDEPEND=""
+DEPEND="amd64? ( >=dev-lang/yasm-0.6.2 )
+ x86? ( >=dev-lang/yasm-0.6.2 )
+ x86-fbsd? ( >=dev-lang/yasm-0.6.2 )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-nostrip.patch \
+ "${FILESDIR}"/${PN}-onlylib-20110425.patch
+}
+
+src_configure() {
+ tc-export CC
+
+ local myconf=""
+ use debug && myconf="${myconf} --enable-debug"
+
+ if use x86 && use pic; then
+ myconf="${myconf} --disable-asm"
+ fi
+
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --disable-avs \
+ --disable-lavf \
+ --disable-swscale \
+ --disable-gpac \
+ $(use threads || echo "--disable-thread") \
+ --enable-pic \
+ --enable-shared \
+ --extra-asflags="${ASFLAGS}" \
+ --extra-cflags="${CFLAGS}" \
+ --extra-ldflags="${LDFLAGS}" \
+ --host="${CHOST}" \
+ ${myconf} \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS doc/*.txt
+}