summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2013-04-30 20:37:44 +0000
committerSebastian Pipping <sping@gentoo.org>2013-04-30 20:37:44 +0000
commit97175df717ee29d93055115664ef6b05d0425f68 (patch)
treee55daf056c223849739681e84acb381ab2b34003 /media-libs
parentadd patch for automake-1.13 compatibility, bug 467626 (diff)
downloadgentoo-2-97175df717ee29d93055115664ef6b05d0425f68.tar.gz
gentoo-2-97175df717ee29d93055115664ef6b05d0425f68.tar.bz2
gentoo-2-97175df717ee29d93055115664ef6b05d0425f68.zip
media-libs/babl: vala eclass (bug #467394)
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x401A1600)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/babl/ChangeLog6
-rw-r--r--media-libs/babl/babl-0.1.10.ebuild19
-rw-r--r--media-libs/babl/babl-9999.ebuild17
3 files changed, 26 insertions, 16 deletions
diff --git a/media-libs/babl/ChangeLog b/media-libs/babl/ChangeLog
index ac7af0528c6f..6238cfa7e53f 100644
--- a/media-libs/babl/ChangeLog
+++ b/media-libs/babl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/babl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/babl/ChangeLog,v 1.47 2013/04/30 20:13:01 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/babl/ChangeLog,v 1.48 2013/04/30 20:37:44 sping Exp $
+
+ 30 Apr 2013; Sebastian Pipping <sping@gentoo.org> babl-0.1.10.ebuild,
+ babl-9999.ebuild:
+ Migrate to vala eclass (bug #467394)
30 Apr 2013; Sebastian Pipping <sping@gentoo.org> babl-0.1.8.ebuild:
Apply g-ir crash patch to 0.1.8, too (bug #413663)
diff --git a/media-libs/babl/babl-0.1.10.ebuild b/media-libs/babl/babl-0.1.10.ebuild
index 6604a457e72e..b50e5150fe3a 100644
--- a/media-libs/babl/babl-0.1.10.ebuild
+++ b/media-libs/babl/babl-0.1.10.ebuild
@@ -1,11 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/babl/babl-0.1.10.ebuild,v 1.7 2013/04/29 21:46:02 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/babl/babl-0.1.10.ebuild,v 1.8 2013/04/30 20:37:44 sping Exp $
-EAPI=3
-VALASLOT=0.14
+EAPI=4
-inherit autotools eutils
+VALA_MIN_API_VERSION=0.14
+VALA_USE_DEPEND=vapigen
+
+inherit vala autotools eutils
DESCRIPTION="A dynamic, any to any, pixel format conversion library"
HOMEPAGE="http://www.gegl.org/babl/"
@@ -19,7 +21,7 @@ IUSE="altivec +introspection sse mmx vala"
RDEPEND="introspection? ( >=dev-libs/gobject-introspection-0.10 )"
DEPEND="${RDEPEND}
>=sys-devel/libtool-2.2
- vala? ( dev-lang/vala:${VALASLOT}[vapigen] )
+ vala? ( $(vala_depend) )
virtual/pkgconfig"
src_prepare() {
@@ -31,6 +33,8 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-introspection.patch
epatch "${FILESDIR}"/${P}-g-ir-compiler-crash.patch
eautoreconf
+
+ use vala && vala_src_prepare
}
src_configure() {
@@ -38,7 +42,6 @@ src_configure() {
# so we don't need to fix it
# w3m is used for dist target thus no issue for us that it is automagically
# detected
- VAPIGEN="$(type -p vapigen-${VALASLOT})" \
econf \
--disable-static \
--disable-maintainer-mode \
@@ -50,7 +53,7 @@ src_configure() {
}
src_install() {
- emake install DESTDIR="${D}" || die "emake install failed"
+ default
find "${ED}" -name '*.la' -delete
- dodoc AUTHORS ChangeLog README NEWS || die "dodoc failed"
+ dodoc AUTHORS ChangeLog README NEWS
}
diff --git a/media-libs/babl/babl-9999.ebuild b/media-libs/babl/babl-9999.ebuild
index 7802c1f9dbe7..7baa1fa47428 100644
--- a/media-libs/babl/babl-9999.ebuild
+++ b/media-libs/babl/babl-9999.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/babl/babl-9999.ebuild,v 1.1 2012/05/17 18:50:59 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/babl/babl-9999.ebuild,v 1.2 2013/04/30 20:37:44 sping Exp $
EAPI=4
-VALASLOT=0.14
+
+VALA_MIN_API_VERSION=0.14
+VALA_USE_DEPEND=vapigen
EGIT_REPO_URI="git://git.gnome.org/babl"
-inherit autotools eutils git-2
+inherit vala autotools eutils git-2
DESCRIPTION="A dynamic, any to any, pixel format conversion library"
HOMEPAGE="http://www.gegl.org/babl/"
@@ -19,7 +21,7 @@ IUSE="altivec +introspection sse mmx vala"
RDEPEND="introspection? ( >=dev-libs/gobject-introspection-0.10 )"
DEPEND="${RDEPEND}
>=sys-devel/libtool-2.2
- vala? ( dev-lang/vala:${VALASLOT}[vapigen] )
+ vala? ( $(vala_depend) )
virtual/pkgconfig"
src_prepare() {
@@ -27,6 +29,8 @@ src_prepare() {
# http://mail.gnome.org/archives/commits-list/2012-April/msg02589.html
sed -i -e 's/values\.h/limits.h/' babl/babl-palette.c || die
eautoreconf
+
+ use vala && vala_src_prepare
}
src_configure() {
@@ -34,7 +38,6 @@ src_configure() {
# so we don't need to fix it
# w3m is used for dist target thus no issue for us that it is automagically
# detected
- VAPIGEN="$(type -p vapigen-${VALASLOT})" \
econf \
--disable-static \
--disable-maintainer-mode \
@@ -46,7 +49,7 @@ src_configure() {
}
src_install() {
- emake install DESTDIR="${D}"
+ default
find "${ED}" -name '*.la' -delete
dodoc AUTHORS MAINTAINERS NEWS TODO
}