summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-03-21 21:48:11 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-03-21 21:48:11 +0000
commita2f2187ac092575a8fc050aabe5b66bd005ddc9b (patch)
tree9f0eb5b767eff3ad3206190131c4b765428201e8 /media-libs
parentRevision bump to EAPI 5. (diff)
downloadgentoo-2-a2f2187ac092575a8fc050aabe5b66bd005ddc9b.tar.gz
gentoo-2-a2f2187ac092575a8fc050aabe5b66bd005ddc9b.tar.bz2
gentoo-2-a2f2187ac092575a8fc050aabe5b66bd005ddc9b.zip
version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libmikmod/ChangeLog7
-rw-r--r--media-libs/libmikmod/libmikmod-3.3.6.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/media-libs/libmikmod/ChangeLog b/media-libs/libmikmod/ChangeLog
index aaa1abc5de22..6c16a9088901 100644
--- a/media-libs/libmikmod/ChangeLog
+++ b/media-libs/libmikmod/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libmikmod
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmikmod/ChangeLog,v 1.115 2014/01/11 14:24:44 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmikmod/ChangeLog,v 1.116 2014/03/21 21:48:11 aballier Exp $
+
+*libmikmod-3.3.6 (21 Mar 2014)
+
+ 21 Mar 2014; Alexis Ballier <aballier@gentoo.org> +libmikmod-3.3.6.ebuild:
+ version bump
*libmikmod-3.3.5 (11 Jan 2014)
diff --git a/media-libs/libmikmod/libmikmod-3.3.6.ebuild b/media-libs/libmikmod/libmikmod-3.3.6.ebuild
new file mode 100644
index 000000000000..e3fe6a5df01f
--- /dev/null
+++ b/media-libs/libmikmod/libmikmod-3.3.6.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmikmod/libmikmod-3.3.6.ebuild,v 1.1 2014/03/21 21:48:11 aballier Exp $
+
+EAPI=5
+inherit eutils multilib-minimal
+
+DESCRIPTION="A library to play a wide range of module formats"
+HOMEPAGE="http://mikmod.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mikmod/${P}.tar.gz"
+
+LICENSE="LGPL-2+ LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+alsa altivec coreaudio debug nas openal oss pulseaudio sse2 static-libs +threads"
+
+REQUIRED_USE="|| ( alsa oss coreaudio )"
+
+RDEPEND="alsa? ( media-libs/alsa-lib:=[${MULTILIB_USEDEP}] )
+ nas? ( media-libs/nas:=[${MULTILIB_USEDEP}] )
+ openal? ( >=media-libs/openal-1.15.1-r1[${MULTILIB_USEDEP}] )
+ pulseaudio? ( >=media-sound/pulseaudio-4.0-r1[${MULTILIB_USEDEP}] )
+ !${CATEGORY}/${PN}:2
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-soundlibs-20130224-r3
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ oss? ( virtual/os-headers )"
+
+multilib_src_configure() {
+ local mysimd="--disable-simd"
+ if use ppc || use ppc64 || use ppc-macos; then
+ mysimd="$(use_enable altivec simd)"
+ fi
+ if use amd64 || use x86 || use x86-fbsd || use x86-freebsd || use amd64-linux || use x86-linux || use x86-macos; then
+ mysimd="$(use_enable sse2 simd)"
+ fi
+
+ # sdl, sdl2: missing multilib supported ebuilds, temporarily disabled
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable alsa) \
+ $(use_enable nas) \
+ $(use_enable pulseaudio) \
+ --disable-sdl \
+ --disable-sdl2 \
+ $(use_enable openal) \
+ $(use_enable oss) \
+ $(use_enable coreaudio osx) \
+ $(use_enable debug) \
+ $(use_enable threads) \
+ $(use_enable static-libs static) \
+ --disable-dl \
+ ${mysimd}
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ dosym ${PN}$(get_libname 3) /usr/$(get_libdir)/${PN}$(get_libname 2)
+}
+
+multilib_src_install_all() {
+ dodoc AUTHORS NEWS README TODO
+ dohtml docs/*.html
+ prune_libtool_files
+}