summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2007-11-22 12:12:15 +0000
committerChristian Birchinger <joker@gentoo.org>2007-11-22 12:12:15 +0000
commit8621723b948d35cf805d78f05ad79c5434d6a579 (patch)
tree74db5767a5f376ac7d11eab1b14f8fdd41867a6a /media-plugins/audacious-crossfade/audacious-crossfade-0.3.13.ebuild
parentRemove older version. (diff)
downloadgentoo-2-8621723b948d35cf805d78f05ad79c5434d6a579.tar.gz
gentoo-2-8621723b948d35cf805d78f05ad79c5434d6a579.tar.bz2
gentoo-2-8621723b948d35cf805d78f05ad79c5434d6a579.zip
Added new version which supports Audacious 1.4.2 or later
(Portage version: 2.1.3.9)
Diffstat (limited to 'media-plugins/audacious-crossfade/audacious-crossfade-0.3.13.ebuild')
-rw-r--r--media-plugins/audacious-crossfade/audacious-crossfade-0.3.13.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-plugins/audacious-crossfade/audacious-crossfade-0.3.13.ebuild b/media-plugins/audacious-crossfade/audacious-crossfade-0.3.13.ebuild
new file mode 100644
index 000000000000..8ff178f1976a
--- /dev/null
+++ b/media-plugins/audacious-crossfade/audacious-crossfade-0.3.13.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/audacious-crossfade/audacious-crossfade-0.3.13.ebuild,v 1.1 2007/11/22 12:12:15 joker Exp $
+
+IUSE="libsamplerate"
+U_PN="xmms-crossfade"
+
+DESCRIPTION="Audacious plugin for crossfading and continuous output. Also know as xmms-crossfade"
+HOMEPAGE="http://www.eisenlohr.org/xmms-crossfade/index.html"
+SRC_URI="http://www.eisenlohr.org/${U_PN}/${U_PN}-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=media-sound/audacious-1.4.2
+ libsamplerate? ( media-libs/libsamplerate )"
+
+S="${WORKDIR}/${U_PN}-${PV}"
+
+src_compile() {
+
+ econf \
+ --enable-player=audacious \
+ --libdir="`pkg-config audacious --variable=output_plugin_dir`" \
+ $(use_enable libsamplerate samplerate) \
+ || die
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README TODO
+}