summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-05 13:09:57 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-05 13:09:57 +0000
commitd8f6ab0d3f511a0c2ef03185e8d2938e846b6aca (patch)
tree0a1ee07f3985c9f32dce9dd72cabe7996f386205 /media-plugins/gmpc-libnotify
parentamd64 stable, bug #353652 (diff)
downloadgentoo-2-d8f6ab0d3f511a0c2ef03185e8d2938e846b6aca.tar.gz
gentoo-2-d8f6ab0d3f511a0c2ef03185e8d2938e846b6aca.tar.bz2
gentoo-2-d8f6ab0d3f511a0c2ef03185e8d2938e846b6aca.zip
Fix building with x11-libs/libnotify >= 0.7.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins/gmpc-libnotify')
-rw-r--r--media-plugins/gmpc-libnotify/ChangeLog9
-rw-r--r--media-plugins/gmpc-libnotify/files/gmpc-libnotify-0.20.0-libnotify-0.7.patch37
-rw-r--r--media-plugins/gmpc-libnotify/gmpc-libnotify-0.20.0.ebuild9
3 files changed, 51 insertions, 4 deletions
diff --git a/media-plugins/gmpc-libnotify/ChangeLog b/media-plugins/gmpc-libnotify/ChangeLog
index b6f9a2b163ac..31831282faaa 100644
--- a/media-plugins/gmpc-libnotify/ChangeLog
+++ b/media-plugins/gmpc-libnotify/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/gmpc-libnotify
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gmpc-libnotify/ChangeLog,v 1.13 2010/05/25 09:45:40 angelos Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gmpc-libnotify/ChangeLog,v 1.14 2011/02/05 13:09:57 ssuominen Exp $
+
+ 05 Feb 2011; Samuli Suominen <ssuominen@gentoo.org>
+ gmpc-libnotify-0.20.0.ebuild,
+ +files/gmpc-libnotify-0.20.0-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7.
*gmpc-libnotify-0.20.0 (25 May 2010)
diff --git a/media-plugins/gmpc-libnotify/files/gmpc-libnotify-0.20.0-libnotify-0.7.patch b/media-plugins/gmpc-libnotify/files/gmpc-libnotify-0.20.0-libnotify-0.7.patch
new file mode 100644
index 000000000000..601b6f27c646
--- /dev/null
+++ b/media-plugins/gmpc-libnotify/files/gmpc-libnotify-0.20.0-libnotify-0.7.patch
@@ -0,0 +1,37 @@
+--- src/plugin.c
++++ src/plugin.c
+@@ -28,6 +28,10 @@
+ #include <gmpc/misc.h>
+ #include <config.h>
+
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
++
+ #define LOG_DOMAIN "LibNotifyPlugin"
+
+ extern GtkStatusIcon *tray_icon2_gsi;
+@@ -149,15 +153,23 @@
+ if(not == NULL)
+ {
+ // notify_notification_close(not, NULL);
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ not = notify_notification_new(summary, buffer,NULL);
++#else
+ not = notify_notification_new(summary, buffer,NULL, NULL);
++#endif
+ }
+ else{
+ notify_notification_update(not, summary, buffer, NULL);
+ }
+ notify_notification_set_urgency(not, NOTIFY_URGENCY_LOW);
+
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ /* notify_notification_attach_to_status_icon was removed */
++#else
+ if(cfg_get_single_value_as_int_with_default(config, "libnotify-plugin", "attach-to-tray", TRUE))
+ notify_notification_attach_to_status_icon(not, tray_icon2_gsi);
++#endif
+
+ g_free(summary);
+ /* Add the song to the widget */
diff --git a/media-plugins/gmpc-libnotify/gmpc-libnotify-0.20.0.ebuild b/media-plugins/gmpc-libnotify/gmpc-libnotify-0.20.0.ebuild
index 3c4905446856..2863c7c6cb49 100644
--- a/media-plugins/gmpc-libnotify/gmpc-libnotify-0.20.0.ebuild
+++ b/media-plugins/gmpc-libnotify/gmpc-libnotify-0.20.0.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gmpc-libnotify/gmpc-libnotify-0.20.0.ebuild,v 1.1 2010/05/25 09:45:40 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gmpc-libnotify/gmpc-libnotify-0.20.0.ebuild,v 1.2 2011/02/05 13:09:57 ssuominen Exp $
EAPI=2
+inherit eutils
DESCRIPTION="This plugin sends an announcement to the notification daemon on song change"
HOMEPAGE="http://gmpc.wikia.com/wiki/GMPC_PLUGIN_LIBNOTIFY"
@@ -21,6 +22,10 @@ DEPEND="${RDEPEND}
nls? ( dev-util/intltool
sys-devel/gettext )"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+}
+
src_configure() {
econf \
$(use_enable nls) \