summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-09-22 05:22:05 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-09-22 05:22:05 +0000
commitde94b691ca61d499f540cbe5f4887198ab1beed5 (patch)
treecc3f811ed5fb40b7888527f1262ed7af714f25d8 /media-plugins/vdr-graphtft
parentadding new fio with permission from Robin (diff)
downloadgentoo-2-de94b691ca61d499f540cbe5f4887198ab1beed5.tar.gz
gentoo-2-de94b691ca61d499f540cbe5f4887198ab1beed5.tar.bz2
gentoo-2-de94b691ca61d499f540cbe5f4887198ab1beed5.zip
fix build with latest ffmpeg, bug #278947
(Portage version: 2.2_rc41/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins/vdr-graphtft')
-rw-r--r--media-plugins/vdr-graphtft/ChangeLog6
-rw-r--r--media-plugins/vdr-graphtft/files/vdr-graphtft-0.2.2-avutil50.patch31
-rw-r--r--media-plugins/vdr-graphtft/vdr-graphtft-0.2.2-r1.ebuild5
3 files changed, 39 insertions, 3 deletions
diff --git a/media-plugins/vdr-graphtft/ChangeLog b/media-plugins/vdr-graphtft/ChangeLog
index 15717f5157ce..3d8bdc1c8d94 100644
--- a/media-plugins/vdr-graphtft/ChangeLog
+++ b/media-plugins/vdr-graphtft/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-plugins/vdr-graphtft
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/ChangeLog,v 1.16 2009/07/24 18:15:15 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/ChangeLog,v 1.17 2009/09/22 05:22:04 aballier Exp $
+
+ 22 Sep 2009; Alexis Ballier <aballier@gentoo.org>
+ vdr-graphtft-0.2.2-r1.ebuild, +files/vdr-graphtft-0.2.2-avutil50.patch:
+ fix build with latest ffmpeg, bug #278947
24 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
vdr-graphtft-0.2.2-r1.ebuild, +files/vdr-graphtft-0.2.2-gcc44.patch,
diff --git a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.2.2-avutil50.patch b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.2.2-avutil50.patch
new file mode 100644
index 000000000000..dfec5ab3aee4
--- /dev/null
+++ b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.2.2-avutil50.patch
@@ -0,0 +1,31 @@
+Index: graphtft-0.2.2/imlibrenderer/dvbrenderer/mpeg2encoder.c
+===================================================================
+--- graphtft-0.2.2.orig/imlibrenderer/dvbrenderer/mpeg2encoder.c
++++ graphtft-0.2.2/imlibrenderer/dvbrenderer/mpeg2encoder.c
+@@ -126,11 +126,11 @@ mpeg_frame mpeg_draw(UINT8* buf)
+ int i;
+ AVPicture avpsrc;
+
+- avpicture_fill(&avpsrc, buf, PIX_FMT_RGBA32, width, height);
++ avpicture_fill(&avpsrc, buf, PIX_FMT_RGB32, width, height);
+
+ #ifndef HAVE_SWSCALE
+
+- img_convert(&pic, PIX_FMT_YUV420P, &avpsrc, PIX_FMT_RGBA32, width, height);
++ img_convert(&pic, PIX_FMT_YUV420P, &avpsrc, PIX_FMT_RGB32, width, height);
+
+ #else
+
+Index: graphtft-0.2.2/imlibrenderer/fbrenderer/fbrenderer.c
+===================================================================
+--- graphtft-0.2.2.orig/imlibrenderer/fbrenderer/fbrenderer.c
++++ graphtft-0.2.2/imlibrenderer/fbrenderer/fbrenderer.c
+@@ -192,7 +192,7 @@ int FbRenderer::init(int devnum)
+
+ switch (fb_vinfo.bits_per_pixel)
+ {
+- case 32: tell(4, "fbdevout.c: using 32 bit depth"); fb_type = PIX_FMT_RGBA32; break;
++ case 32: tell(4, "fbdevout.c: using 32 bit depth"); fb_type = PIX_FMT_RGB32; break;
+ case 24: tell(4, "fbdevout.c: using 24 bit depth"); fb_type = PIX_FMT_RGB24; break;
+ case 16: tell(4, "fbdevout.c: using 16 bit depth"); fb_type = PIX_FMT_RGB565; break;
+ default: tell(4, "fbdevout.c: color depth not supported -> %i bits per pixel",
diff --git a/media-plugins/vdr-graphtft/vdr-graphtft-0.2.2-r1.ebuild b/media-plugins/vdr-graphtft/vdr-graphtft-0.2.2-r1.ebuild
index 22138c8fd3c3..4fd1ab1381cb 100644
--- a/media-plugins/vdr-graphtft/vdr-graphtft-0.2.2-r1.ebuild
+++ b/media-plugins/vdr-graphtft/vdr-graphtft-0.2.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/vdr-graphtft-0.2.2-r1.ebuild,v 1.3 2009/07/24 18:15:15 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/vdr-graphtft-0.2.2-r1.ebuild,v 1.4 2009/09/22 05:22:04 aballier Exp $
EAPI="2"
@@ -30,7 +30,8 @@ RDEPEND="${DEPEND}"
PATCHES=( "${FILESDIR}/${P}_gentoo.diff"
"${FILESDIR}/${P}-gcc44.patch"
- "${FILESDIR}/${P}-glibc210.patch" )
+ "${FILESDIR}/${P}-glibc210.patch"
+ "${FILESDIR}/${P}-avutil50.patch" )
extpatch_v_check() {