summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2006-12-03 14:50:11 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2006-12-03 14:50:11 +0000
commitf7e6dff50ab557d4bfd269f1157767303c3d55fd (patch)
tree669174502cc8f37432f36fc5e1092e67c91c92a7 /media-plugins/vdr-taste
parentAdded patch to prevent a patch on frontend getting killed/connection lost. (diff)
downloadgentoo-2-f7e6dff50ab557d4bfd269f1157767303c3d55fd.tar.gz
gentoo-2-f7e6dff50ab557d4bfd269f1157767303c3d55fd.tar.bz2
gentoo-2-f7e6dff50ab557d4bfd269f1157767303c3d55fd.zip
Added patch to compile also with vdr-1.4.4_p1
(Portage version: 2.1.2_rc2-r4)
Diffstat (limited to 'media-plugins/vdr-taste')
-rw-r--r--media-plugins/vdr-taste/ChangeLog6
-rw-r--r--media-plugins/vdr-taste/files/vdr-taste-0.0.2d-uint64.diff12
-rw-r--r--media-plugins/vdr-taste/vdr-taste-0.0.2d.ebuild5
3 files changed, 20 insertions, 3 deletions
diff --git a/media-plugins/vdr-taste/ChangeLog b/media-plugins/vdr-taste/ChangeLog
index 9a51488b5361..339bc1412808 100644
--- a/media-plugins/vdr-taste/ChangeLog
+++ b/media-plugins/vdr-taste/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-plugins/vdr-taste
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-taste/ChangeLog,v 1.2 2006/08/15 09:59:25 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-taste/ChangeLog,v 1.3 2006/12/03 14:50:11 zzam Exp $
+
+ 03 Dec 2006; Matthias Schwarzott <zzam@gentoo.org>
+ +files/vdr-taste-0.0.2d-uint64.diff, vdr-taste-0.0.2d.ebuild:
+ Added patch to compile also with vdr-1.4.4_p1
15 Aug 2006; Matthias Schwarzott <zzam@gentoo.org> metadata.xml:
Assigned to Gentoo VDR Project.
diff --git a/media-plugins/vdr-taste/files/vdr-taste-0.0.2d-uint64.diff b/media-plugins/vdr-taste/files/vdr-taste-0.0.2d-uint64.diff
new file mode 100644
index 000000000000..8648f93d4dcf
--- /dev/null
+++ b/media-plugins/vdr-taste/files/vdr-taste-0.0.2d-uint64.diff
@@ -0,0 +1,12 @@
+diff -ru taste-0.0.2d-orig/control.h taste-0.0.2d/control.h
+--- taste-0.0.2d-orig/control.h 2006-12-03 15:48:00.521763680 +0100
++++ taste-0.0.2d/control.h 2006-12-03 15:48:15.469333968 +0100
+@@ -15,7 +15,7 @@
+ const cChannel *mChannel;
+ const cEvent *mPresent;
+ const cEvent *mFollowing;
+- uint64 mStart;
++ uint64_t mStart;
+ bool mSwitch;
+ cSkinDisplayChannel *mOsd;
+
diff --git a/media-plugins/vdr-taste/vdr-taste-0.0.2d.ebuild b/media-plugins/vdr-taste/vdr-taste-0.0.2d.ebuild
index 4d8d1d5a30cc..2188355028e5 100644
--- a/media-plugins/vdr-taste/vdr-taste-0.0.2d.ebuild
+++ b/media-plugins/vdr-taste/vdr-taste-0.0.2d.ebuild
@@ -1,6 +1,6 @@
# Copyright 2004-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-taste/vdr-taste-0.0.2d.ebuild,v 1.1 2006/03/05 11:25:00 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-taste/vdr-taste-0.0.2d.ebuild,v 1.2 2006/12/03 14:50:11 zzam Exp $
IUSE=""
inherit vdr-plugin
@@ -15,5 +15,6 @@ LICENSE="GPL-2"
DEPEND=">=media-video/vdr-1.3.7"
-PATCHES="${DISTDIR}/${VDRPLUGIN}-${PV}.patch"
+PATCHES="${DISTDIR}/${VDRPLUGIN}-${PV}.patch
+ ${FILESDIR}/${P}-uint64.diff"