summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2013-09-15 13:34:28 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2013-09-15 13:34:28 +0000
commitd6f5954a219ee0cf20d23ebed7dbcc9b6fbe6b65 (patch)
treef309316a8df567721f3b15524ea55ea151059e4f /media-plugins/vdr-zaphistory
parentBump again to latest mpv tagged release. Drop older. (diff)
downloadgentoo-2-d6f5954a219ee0cf20d23ebed7dbcc9b6fbe6b65.tar.gz
gentoo-2-d6f5954a219ee0cf20d23ebed7dbcc9b6fbe6b65.tar.bz2
gentoo-2-d6f5954a219ee0cf20d23ebed7dbcc9b6fbe6b65.zip
bump; fixed wrt bug #414179
(Portage version: 2.1.11.50/cvs/Linux i686, signed Manifest commit with key 34C2808A)
Diffstat (limited to 'media-plugins/vdr-zaphistory')
-rw-r--r--media-plugins/vdr-zaphistory/ChangeLog11
-rw-r--r--media-plugins/vdr-zaphistory/files/vdr-zaphistory-0.9.6-fix-crash-no-info.diff15
-rw-r--r--media-plugins/vdr-zaphistory/vdr-zaphistory-0.9.6.ebuild23
3 files changed, 47 insertions, 2 deletions
diff --git a/media-plugins/vdr-zaphistory/ChangeLog b/media-plugins/vdr-zaphistory/ChangeLog
index 252fd0a02c4f..2333612afb32 100644
--- a/media-plugins/vdr-zaphistory/ChangeLog
+++ b/media-plugins/vdr-zaphistory/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-plugins/vdr-zaphistory
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-zaphistory/ChangeLog,v 1.15 2008/04/28 08:50:52 zzam Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-zaphistory/ChangeLog,v 1.16 2013/09/15 13:34:28 hd_brummy Exp $
+
+*vdr-zaphistory-0.9.6 (15 Sep 2013)
+
+ 15 Sep 2013; Joerg Bornkessel <hd_brummy@gentoo.org>
+ +vdr-zaphistory-0.9.6.ebuild,
+ +files/vdr-zaphistory-0.9.6-fix-crash-no-info.diff:
+ bump; fixed wrt bug #414179
28 Apr 2008; Matthias Schwarzott <zzam@gentoo.org>
vdr-zaphistory-0.9.5.ebuild:
diff --git a/media-plugins/vdr-zaphistory/files/vdr-zaphistory-0.9.6-fix-crash-no-info.diff b/media-plugins/vdr-zaphistory/files/vdr-zaphistory-0.9.6-fix-crash-no-info.diff
new file mode 100644
index 000000000000..274012d731e4
--- /dev/null
+++ b/media-plugins/vdr-zaphistory/files/vdr-zaphistory-0.9.6-fix-crash-no-info.diff
@@ -0,0 +1,15 @@
+diff -Naur zaphistory-0.9.6.orig/zaphistoryosd.c zaphistory-0.9.6/zaphistoryosd.c
+--- zaphistory-0.9.6.orig/zaphistoryosd.c 2013-09-15 15:22:41.000000000 +0200
++++ zaphistory-0.9.6/zaphistoryosd.c 2013-09-15 15:24:42.000000000 +0200
+@@ -217,6 +217,11 @@
+
+ return AddSubMenu( new cMenuEvent(schedule->GetEventAround(time(NULL)) ) );
+
++ const cEvent *event = schedule->GetEventAround(time(NULL));
++ if (event)
++ return AddSubMenu( new cMenuEvent(event) );
++ else
++ return osUnknown;
+ }
+
+ eOSState cMenuZappedChannels::ProcessKey(eKeys Key)
diff --git a/media-plugins/vdr-zaphistory/vdr-zaphistory-0.9.6.ebuild b/media-plugins/vdr-zaphistory/vdr-zaphistory-0.9.6.ebuild
new file mode 100644
index 000000000000..7dec7f9f6b65
--- /dev/null
+++ b/media-plugins/vdr-zaphistory/vdr-zaphistory-0.9.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-zaphistory/vdr-zaphistory-0.9.6.ebuild,v 1.1 2013/09/15 13:34:28 hd_brummy Exp $
+
+EAPI="5"
+
+inherit vdr-plugin-2
+
+VERSION="1437" # every bump, new Version
+
+DESCRIPTION="VDR Plugin: Shows the least recently used channels"
+HOMEPAGE="http://projects.vdr-developer.org/projects/plg-zaphistory"
+SRC_URI="mirror://vdr-developerorg/${VERSION}/zaphistory-${PV}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=media-video/vdr-2.0.0"
+RDEPEND="${DEPEND}"
+
+PATCHES=("${FILESDIR}/${P}-fix-crash-no-info.diff")