summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2008-04-13 19:01:40 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2008-04-13 19:01:40 +0000
commit00149a883de6347ad6b41bbbb59983eb665e8c6c (patch)
tree5437e616213693105af8e51e2cbf0e509ad466ac /media-plugins
parentbug 217518 , removed (german) from HOMEPAGE (diff)
downloadgentoo-2-00149a883de6347ad6b41bbbb59983eb665e8c6c.tar.gz
gentoo-2-00149a883de6347ad6b41bbbb59983eb665e8c6c.tar.bz2
gentoo-2-00149a883de6347ad6b41bbbb59983eb665e8c6c.zip
version bump; bug 217176 fixed; bug 217518 fixed
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-graphtft/ChangeLog9
-rw-r--r--media-plugins/vdr-graphtft/files/vdr-graphtft-0.1.18_alpha-gentoo.diff111
-rw-r--r--media-plugins/vdr-graphtft/vdr-graphtft-0.1.16_alpha.ebuild8
-rw-r--r--media-plugins/vdr-graphtft/vdr-graphtft-0.1.18_alpha.ebuild104
4 files changed, 227 insertions, 5 deletions
diff --git a/media-plugins/vdr-graphtft/ChangeLog b/media-plugins/vdr-graphtft/ChangeLog
index 4665e7dc32f4..1624ef055625 100644
--- a/media-plugins/vdr-graphtft/ChangeLog
+++ b/media-plugins/vdr-graphtft/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-plugins/vdr-graphtft
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/ChangeLog,v 1.2 2008/03/29 13:46:11 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/ChangeLog,v 1.3 2008/04/13 19:01:39 hd_brummy Exp $
+
+*vdr-graphtft-0.1.18_alpha (13 Apr 2008)
+
+ 13 Apr 2008; Joerg Bornkessel <hd_brummy@gentoo.org>
+ +files/vdr-graphtft-0.1.18_alpha-gentoo.diff,
+ vdr-graphtft-0.1.16_alpha.ebuild, +vdr-graphtft-0.1.18_alpha.ebuild:
+ version bump; bug 217176 fixed; bug 217518 fixed
29 Mar 2008; Joerg Bornkessel <hd_brummy@gentoo.org>
+files/ffmpeg-0.4.9_p20080326-new_header.diff,
diff --git a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.1.18_alpha-gentoo.diff b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.1.18_alpha-gentoo.diff
new file mode 100644
index 000000000000..c3ed929ba3a6
--- /dev/null
+++ b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.1.18_alpha-gentoo.diff
@@ -0,0 +1,111 @@
+diff -Naur graphtft-0.1.16.alpha.orig/dfbrenderer/dfbrenderer.c graphtft-0.1.16.alpha/dfbrenderer/dfbrenderer.c
+--- graphtft-0.1.16.alpha.orig/dfbrenderer/dfbrenderer.c 2007-12-12 20:15:39.223026383 +0100
++++ graphtft-0.1.16.alpha/dfbrenderer/dfbrenderer.c 2007-12-12 20:17:01.430709769 +0100
+@@ -333,7 +333,7 @@
+ else
+ {
+ const char* tmp = themePath.c_str();
+- asprintf(&fpath, "%s/graphTFT/themes/%s/%s", confPath.c_str(), tmp, fname);
++ asprintf(&fpath, "%s/themes/%s/%s", confPath.c_str(), tmp, fname);
+ }
+
+ tell(4,"creating imageprovider for %s\n", fpath);
+@@ -383,7 +383,7 @@
+
+ if (!fontCache.Contains(FontFaceSize(fontName, fontSize)))
+ {
+- asprintf(&fpath, "%s/graphTFT/fonts/%s.ttf", confPath.c_str(), fontName);
++ asprintf(&fpath, "%s/fonts/%s.ttf", confPath.c_str(), fontName);
+
+ tell(4,"creating font for %s\n", fpath);
+
+@@ -444,7 +444,7 @@
+
+ if (!fontCache.Contains(FontFaceSize(font_name, size)))
+ {
+- asprintf(&fpath, "%s/graphTFT/fonts/%s.ttf", confPath.c_str(), font_name);
++ asprintf(&fpath, "%s/fonts/%s.ttf", confPath.c_str(), font_name);
+
+ tell(4,"creating font for %s\n", fpath);
+
+diff -Naur graphtft-0.1.16.alpha.orig/graphtft.c graphtft-0.1.16.alpha/graphtft.c
+--- graphtft-0.1.16.alpha.orig/graphtft.c 2007-12-12 20:15:39.246358112 +0100
++++ graphtft-0.1.16.alpha/graphtft.c 2007-12-12 20:19:52.292300174 +0100
+@@ -20,6 +20,8 @@
+ #include <graphtft.h>
+ #include <span.h>
+
++#define DATA_DIR "/usr/share/vdr/graphTFT"
++
+ //***************************************************************************
+ // cGraphTFTMenu
+ //***************************************************************************
+@@ -255,14 +257,7 @@
+
+ #endif
+
+- // try to get the config dir
+-
+- if (!ConfigDirectory())
+- return false;
+-
+- // init
+-
+- GraphTFTSetup.PluginConfPath = strdup(ConfigDirectory());
++ GraphTFTSetup.PluginConfPath = strdup(DATA_DIR);
+
+ #if APIVERSNUM < 10507
+ RegisterI18n(Phrases);
+@@ -278,7 +273,7 @@
+ if (loadThemes() != 0)
+ return false;
+
+- return display->Init(_dev, ConfigDirectory(), port);
++ return display->Init(_dev, DATA_DIR, port);
+ }
+
+ //***************************************************************************
+@@ -294,8 +289,8 @@
+
+ // look for the themes in the config directory
+
+- asprintf(&buffer, "find %s/graphTFT/themes -follow -type f -name '*.theme' | sort",
+- ConfigDirectory());
++ asprintf(&buffer, "find %s/themes -follow -type f -name '*.theme' | sort",
++ DATA_DIR);
+
+ p = popen(buffer, "r");
+
+diff -Naur graphtft-0.1.16.alpha.orig/imlibrenderer/imlibrenderer.c graphtft-0.1.16.alpha/imlibrenderer/imlibrenderer.c
+--- graphtft-0.1.16.alpha.orig/imlibrenderer/imlibrenderer.c 2007-12-12 20:15:39.369682970 +0100
++++ graphtft-0.1.16.alpha/imlibrenderer/imlibrenderer.c 2007-12-12 20:20:35.006031224 +0100
+@@ -53,7 +53,7 @@
+
+ // font
+
+- std::ostringstream path; path << confPath.c_str() << "/graphTFT/fonts/";
++ std::ostringstream path; path << confPath.c_str() << "/fonts/";
+ imlib_add_path_to_font_path(path.str().c_str());
+
+ // new image
+@@ -134,7 +134,7 @@
+ if (fname[0] == '/')
+ path << fname;
+ else
+- path << confPath << "/graphTFT/themes/" << themePath << "/" << fname;
++ path << confPath << "/themes/" << themePath << "/" << fname;
+
+ new_image = imlib_load_image(path.str().c_str());
+
+diff -Naur graphtft-0.1.18.alpha.orig/dspitems.c graphtft-0.1.18.alpha/dspitems.c
+--- graphtft-0.1.18.alpha.orig/dspitems.c 2008-04-13 20:04:45.855102424 +0200
++++ graphtft-0.1.18.alpha/dspitems.c 2008-04-13 20:05:41.912312127 +0200
+@@ -697,7 +697,7 @@
+ if (p[0] != '/')
+ {
+ p = string(GraphTFTSetup.PluginConfPath)
+- + "/graphTFT/themes/"
++ + "/themes/"
+ + string(theTheme->getDir())
+ + "/" + p;
+ }
diff --git a/media-plugins/vdr-graphtft/vdr-graphtft-0.1.16_alpha.ebuild b/media-plugins/vdr-graphtft/vdr-graphtft-0.1.16_alpha.ebuild
index 8166f8dfc6f2..9cc0338525cd 100644
--- a/media-plugins/vdr-graphtft/vdr-graphtft-0.1.16_alpha.ebuild
+++ b/media-plugins/vdr-graphtft/vdr-graphtft-0.1.16_alpha.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/vdr-graphtft-0.1.16_alpha.ebuild,v 1.2 2008/03/29 13:46:11 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/vdr-graphtft-0.1.16_alpha.ebuild,v 1.3 2008/04/13 19:01:39 hd_brummy Exp $
MY_PV="${PV/_alpha/.alpha}"
MY_P="${PN}-${MY_PV}"
-inherit vdr-plugin
+inherit vdr-plugin qt4
DESCRIPTION="VDR plugin: GraphTFT"
-HOMEPAGE="http://www.vdr-wiki.de/wiki/index.php/Graphtft-plugin (german)"
+HOMEPAGE="http://www.vdr-wiki.de/wiki/index.php/Graphtft-plugin"
SRC_URI="http://www.jwendel.de/vdr/${MY_P}.tar.bz2
http://www.jwendel.de/vdr/DeepBlue-horchi-0.0.6.tar.bz2"
@@ -24,7 +24,7 @@ DEPEND=">=media-video/vdr-1.4.7-r9
gnome-base/libgtop
>=media-video/ffmpeg-0.4.8
directfb? ( dev-libs/DirectFB )
- graphtft-fe? ( x11-libs/qt )"
+ graphtft-fe? ( $(qt4_min_version 4.0.0) )"
PATCHES="${FILESDIR}/${P}-gentoo.diff"
diff --git a/media-plugins/vdr-graphtft/vdr-graphtft-0.1.18_alpha.ebuild b/media-plugins/vdr-graphtft/vdr-graphtft-0.1.18_alpha.ebuild
new file mode 100644
index 000000000000..98a7e8417255
--- /dev/null
+++ b/media-plugins/vdr-graphtft/vdr-graphtft-0.1.18_alpha.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphtft/vdr-graphtft-0.1.18_alpha.ebuild,v 1.1 2008/04/13 19:01:39 hd_brummy Exp $
+
+MY_PV="${PV/_alpha/.alpha}"
+MY_P="${PN}-${MY_PV}"
+
+inherit vdr-plugin qt4
+
+DESCRIPTION="VDR plugin: GraphTFT"
+HOMEPAGE="http://www.vdr-wiki.de/wiki/index.php/Graphtft-plugin"
+SRC_URI="http://www.jwendel.de/vdr/${MY_P}.tar.bz2
+ http://www.jwendel.de/vdr/DeepBlue-horchi-0.0.6.tar.bz2"
+
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+IUSE="directfb graphtft-fe"
+
+DEPEND=">=media-video/vdr-1.4.7-r9
+ media-fonts/ttf-bitstream-vera
+ media-libs/imlib2
+ media-gfx/imagemagick
+ gnome-base/libgtop
+ >=media-video/ffmpeg-0.4.8
+ directfb? ( dev-libs/DirectFB )
+ graphtft-fe? ( $(qt4_min_version 4.0.0) )"
+
+PATCHES="${FILESDIR}/${P}-gentoo.diff"
+
+S="${WORKDIR}/graphtft-${MY_PV}"
+
+pkg_setup() {
+ vdr-plugin_pkg_setup
+
+ if ! built_with_use media-video/vdr graphtft; then
+ echo
+ eerror "Please recompile VDR with USE=\"graphtft\""
+ die "Unpached VDR found"
+ echo
+ fi
+}
+
+src_unpack() {
+ vdr-plugin_src_unpack
+
+ sed -i "${WORKDIR}"/DeepBlue/DeepBlue.theme -e "s:Enigma:Vera:"
+ sed -i "${S}"/themes/DeepBlue.theme -e "s:Enigma:Vera:"
+ sed -i Makefile -e "s:WITH_X_COMM = 1:#WITH_X_COMM = 1:"
+ sed -i common.h -e "s:void tell:int tell:"
+ sed -i common.c -e "s:void tell:int tell:"
+
+ if has_version ">=media-video/ffmpeg-0.4.9_p20070525" ; then
+ sed -i Makefile -e "s:#HAVE_SWSCALE:HAVE_SWSCALE:"
+ fi
+
+ if has_version ">=media-video/ffmpeg-0.4.9_p20080326" ; then
+ epatch "${FILESDIR}/ffmpeg-0.4.9_p20080326-new_header.diff"
+ fi
+
+ use directfb && sed -i Makefile \
+ -e "s:#HAVE_DFB = 1:HAVE_DFB = 1:"
+
+ use graphtft-fe && sed -i Makefile \
+ -e "s:#WITH_X_COMM:WITH_X_COMM:"
+}
+
+src_compile() {
+ vdr-plugin_src_compile
+
+ if use graphtft-fe; then
+ cd "${S}"/graphtft-fe
+ sed -i build.sh -e "s:qmake-qt4:qmake:"
+ ./clean.sh
+ ./build.sh || die "build.sh failed"
+ fi
+}
+
+src_install() {
+ vdr-plugin_src_install
+
+ insinto /usr/share/vdr/graphTFT/themes/DeepBlue/
+ doins -r "${WORKDIR}"/DeepBlue/*
+ doins "${S}"/themes/DeepBlue.theme
+
+ dosym /usr/share/fonts/ttf-bitstream-vera /usr/share/vdr/graphTFT/fonts
+
+ dodoc "${S}"/documents/*
+
+ if use graphtft-fe; then
+ cd "${S}"/graphtft-fe && dobin graphtft-fe
+ doinit graphtft-fe
+ fi
+}
+
+pkg_postinst() {
+ vdr-plugin_pkg_postinst
+
+ echo
+ elog "Graphtft-fe user:"
+ elog "Edit /etc/conf.d/vdr.graphtft"
+ elog "/etc/init.d/graphtft-fe start"
+ echo
+}