summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-09-06 12:12:44 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-09-06 12:12:44 +0000
commitf5b561f8929054cb35036fa7943e021c1d5cd038 (patch)
tree04a15a72ed1390bd8b834a613a1da8b92945d831 /media-plugins
parentStable ppc64, bug #385321 (diff)
downloadgentoo-2-f5b561f8929054cb35036fa7943e021c1d5cd038.tar.gz
gentoo-2-f5b561f8929054cb35036fa7943e021c1d5cd038.tar.bz2
gentoo-2-f5b561f8929054cb35036fa7943e021c1d5cd038.zip
Use append-cppflags instead of append-flags for passing -D flags on autotools based project. Call prunt_libtool_files with --all argument since we want them out from the plugins directory.
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/alsa-plugins/ChangeLog10
-rw-r--r--media-plugins/alsa-plugins/alsa-plugins-1.0.25-r2.ebuild94
2 files changed, 103 insertions, 1 deletions
diff --git a/media-plugins/alsa-plugins/ChangeLog b/media-plugins/alsa-plugins/ChangeLog
index e541c8b3241a..9d6ad3d0b209 100644
--- a/media-plugins/alsa-plugins/ChangeLog
+++ b/media-plugins/alsa-plugins/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-plugins/alsa-plugins
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/ChangeLog,v 1.152 2012/08/18 02:57:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/ChangeLog,v 1.153 2012/09/06 12:12:44 ssuominen Exp $
+
+*alsa-plugins-1.0.25-r2 (06 Sep 2012)
+
+ 06 Sep 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +alsa-plugins-1.0.25-r2.ebuild:
+ Use append-cppflags instead of append-flags for passing -D flags on autotools
+ based project. Call prunt_libtool_files with --all argument since we want
+ them out from the plugins directory.
18 Aug 2012; Mike Frysinger <vapier@gentoo.org>
+files/alsa-plugins-1.0.25-glibc-2.16.patch, alsa-plugins-1.0.25-r1.ebuild:
diff --git a/media-plugins/alsa-plugins/alsa-plugins-1.0.25-r2.ebuild b/media-plugins/alsa-plugins/alsa-plugins-1.0.25-r2.ebuild
new file mode 100644
index 000000000000..caede5c0040c
--- /dev/null
+++ b/media-plugins/alsa-plugins/alsa-plugins-1.0.25-r2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/alsa-plugins-1.0.25-r2.ebuild,v 1.1 2012/09/06 12:12:44 ssuominen Exp $
+
+EAPI=4
+
+MY_P=${P/_/}
+
+inherit autotools eutils base flag-o-matic
+
+DESCRIPTION="ALSA extra plugins"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/plugins/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux"
+IUSE="debug ffmpeg jack libsamplerate pulseaudio speex"
+
+RDEPEND=">=media-libs/alsa-lib-${PV}
+ ffmpeg? ( virtual/ffmpeg )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.98 )
+ libsamplerate? ( media-libs/libsamplerate )
+ pulseaudio? ( media-sound/pulseaudio )
+ speex? ( media-libs/speex )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.19-missing-avutil.patch
+ "${FILESDIR}"/${PN}-1.0.23-automagic.patch
+ "${FILESDIR}"/${PN}-1.0.25-avcodec54.patch
+ "${FILESDIR}"/${P}-glibc-2.16.patch #426254
+)
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ base_src_prepare
+
+ # For some reasons the polyp/pulse plugin does fail with alsaplayer with a
+ # failed assert. As the code works just fine with asserts disabled, for now
+ # disable them waiting for a better solution.
+ sed -i \
+ -e '/AM_CFLAGS/s:-Wall:-DNDEBUG -Wall:' \
+ pulse/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use debug || append-cppflags -DNDEBUG
+
+ local myspeex=no
+ use speex && myspeex=lib
+
+ econf \
+ $(use_enable ffmpeg avcodec) \
+ $(use_enable jack) \
+ $(use_enable libsamplerate samplerate) \
+ $(use_enable pulseaudio) \
+ --with-speex=${myspeex}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ cd doc
+ dodoc upmix.txt vdownmix.txt README-pcm-oss
+ use jack && dodoc README-jack
+ use libsamplerate && dodoc samplerate.txt
+ use ffmpeg && dodoc lavcrate.txt a52.txt
+
+ if use pulseaudio; then
+ dodoc README-pulse
+ # install ALSA configuration files
+ # making PA to be used by alsa clients
+ insinto /usr/share/alsa
+ doins "${FILESDIR}"/pulse-default.conf
+ insinto /usr/share/alsa/alsa.conf.d
+ doins "${FILESDIR}"/51-pulseaudio-probe.conf
+ fi
+
+ prune_libtool_files --all
+}
+
+pkg_postinst() {
+ if use pulseaudio; then
+ einfo "The PulseAudio device is now set as the default device if the"
+ einfo "PulseAudio server is found to be running. Any custom"
+ einfo "configuration in /etc/asound.conf or ~/.asoundrc for this"
+ einfo "purpose should now be unnecessary."
+ fi
+}