summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-07-23 02:55:17 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-07-23 02:55:17 +0000
commit1df1f81740ba8ad21accba767baf0663941d3d37 (patch)
tree8b2ed8fadd341366d564b61b29ceb8de8854fb57 /media-radio
parentVersion bump, and dropped archs I'm unsure if they work or not (diff)
downloadgentoo-2-1df1f81740ba8ad21accba767baf0663941d3d37.tar.gz
gentoo-2-1df1f81740ba8ad21accba767baf0663941d3d37.tar.bz2
gentoo-2-1df1f81740ba8ad21accba767baf0663941d3d37.zip
Version bump, bug 278691
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/tucnak2/ChangeLog7
-rw-r--r--media-radio/tucnak2/tucnak2-2.27.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/media-radio/tucnak2/ChangeLog b/media-radio/tucnak2/ChangeLog
index da2f28a58178..8f539b2b8042 100644
--- a/media-radio/tucnak2/ChangeLog
+++ b/media-radio/tucnak2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-radio/tucnak2
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/tucnak2/ChangeLog,v 1.8 2009/05/20 01:54:44 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/tucnak2/ChangeLog,v 1.9 2009/07/23 02:55:17 darkside Exp $
+
+*tucnak2-2.27 (23 Jul 2009)
+
+ 23 Jul 2009; Jeremy Olexa <darkside@gentoo.org> +tucnak2-2.27.ebuild:
+ Version bump, bug 278691
*tucnak2-2.26 (20 May 2009)
diff --git a/media-radio/tucnak2/tucnak2-2.27.ebuild b/media-radio/tucnak2/tucnak2-2.27.ebuild
new file mode 100644
index 000000000000..60efd5053a3c
--- /dev/null
+++ b/media-radio/tucnak2/tucnak2-2.27.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/tucnak2/tucnak2-2.27.ebuild,v 1.1 2009/07/23 02:55:17 darkside Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="Amateur Radio VHF Contest Logbook"
+HOMEPAGE="http://tucnak.nagano.cz"
+SRC_URI="http://tucnak.nagano.cz/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa ftdi gpm hamlib"
+
+RDEPEND=">=dev-libs/glib-2
+ media-libs/libsndfile
+ >=media-libs/libsdl-1.2
+ alsa? ( media-libs/alsa-lib )
+ ftdi? ( dev-embedded/libftdi )
+ gpm? ( sys-libs/gpm )
+ hamlib? ( media-libs/hamlib )
+ >=media-libs/libpng-1.2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-2.19-doc.diff" \
+ "${FILESDIR}/${PN}-2.25-appname.diff"
+ eautoreconf
+}
+
+src_compile() {
+ econf $(use_with alsa) $(use_with ftdi) \
+ $(use_with gpm) $(use_with hamlib) --with-sdl
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ doman debian/tucnak2.1 || die "doman failed"
+ dodoc AUTHORS ChangeLog TODO doc/NAVOD.sxw doc/NAVOD.pdf || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "In order to use sound with tucnak2 add yourself to the 'audio' group"
+ elog "and to key your rig via the parport add yourself to the 'lp' group"
+ elog ""
+ elog "tucnak2 can be used with the following additional packages:"
+ elog " media-radio/cwdaemon : Morse output via code cwdaemon"
+ elog " (No need to recompile)"
+}