summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2009-06-26 11:05:41 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2009-06-26 11:05:41 +0000
commitf788ad0ee1e69c9523282a3a5b826a0039f7d8aa (patch)
tree1ddff895d2a4bae91eb91b03b828e7d4cf4a1a47 /media-sound/amarok-utils
parentVersion bump (diff)
downloadgentoo-2-f788ad0ee1e69c9523282a3a5b826a0039f7d8aa.tar.gz
gentoo-2-f788ad0ee1e69c9523282a3a5b826a0039f7d8aa.tar.bz2
gentoo-2-f788ad0ee1e69c9523282a3a5b826a0039f7d8aa.zip
Version bump, 275467
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/amarok-utils')
-rw-r--r--media-sound/amarok-utils/ChangeLog8
-rw-r--r--media-sound/amarok-utils/amarok-utils-2.1.1.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/media-sound/amarok-utils/ChangeLog b/media-sound/amarok-utils/ChangeLog
index 4f05cd20d636..894a0518d403 100644
--- a/media-sound/amarok-utils/ChangeLog
+++ b/media-sound/amarok-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/amarok-utils
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok-utils/ChangeLog,v 1.3 2009/06/05 11:46:13 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok-utils/ChangeLog,v 1.4 2009/06/26 11:05:41 tampakrap Exp $
+
+*amarok-utils-2.1.1 (26 Jun 2009)
+
+ 26 Jun 2009; Theo Chatzimichos <tampakrap@gentoo.org>
+ +amarok-utils-2.1.1.ebuild:
+ Version bump, bug 275467
05 Jun 2009; Theo Chatzimichos <tampakrap@gentoo.org>
amarok-utils-2.1.ebuild:
diff --git a/media-sound/amarok-utils/amarok-utils-2.1.1.ebuild b/media-sound/amarok-utils/amarok-utils-2.1.1.ebuild
new file mode 100644
index 000000000000..54688f42c6d7
--- /dev/null
+++ b/media-sound/amarok-utils/amarok-utils-2.1.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok-utils/amarok-utils-2.1.1.ebuild,v 1.1 2009/06/26 11:05:41 tampakrap Exp $
+
+EAPI="2"
+
+KMNAME="extragear/multimedia"
+KMMODULE="amarok"
+KDE_REQUIRED="never"
+inherit kde4-base
+
+DESCRIPTION="Various utility programs for Amarok."
+HOMEPAGE="http://amarok.kde.org/"
+SRC_URI="mirror://kde/stable/${PN/-utils/}/${PV}/src/${P/-utils/}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug"
+
+DEPEND="
+ >=media-libs/taglib-1.5
+ >=media-libs/taglib-extras-0.1
+ >=x11-libs/qt-core-4.4:4
+ >=x11-libs/qt-dbus-4.4:4
+"
+RDEPEND="${DEPEND}
+ !<media-sound/amarok-2.0.90:2
+ !<media-sound/amarok-2.0.90:${SLOT}
+"
+
+S="${WORKDIR}/${P/-utils/}"
+
+src_prepare() {
+ # Disable po processing
+ sed -e "s:include(MacroOptionalAddSubdirectory)::" \
+ -i "${S}/CMakeLists.txt" \
+ || die "Removing include of MacroOptionalAddSubdirectory failed."
+ sed -e "s:macro_optional_add_subdirectory( po )::" \
+ -i "${S}/CMakeLists.txt" \
+ || die "Removing include of MacroOptionalAddSubdirectory failed."
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ -DWITH_PLAYER=OFF
+ -DWITH_UTILITIES=ON"
+
+ kde4-base_src_configure
+}