summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Tolboom <ryan@gentoo.org>2001-02-10 23:39:36 +0000
committerRyan Tolboom <ryan@gentoo.org>2001-02-10 23:39:36 +0000
commit6034c3f44e7d8ca03bf7524a5e890482ccbe7c96 (patch)
tree343a00af83fa4f19ad608438edb59abf04afb67f /media-sound/dcd
parent*** empty log message *** (diff)
downloadgentoo-2-6034c3f44e7d8ca03bf7524a5e890482ccbe7c96.tar.gz
gentoo-2-6034c3f44e7d8ca03bf7524a5e890482ccbe7c96.tar.bz2
gentoo-2-6034c3f44e7d8ca03bf7524a5e890482ccbe7c96.zip
Initial DCD ebuild script. Command line CD player.
Diffstat (limited to 'media-sound/dcd')
-rw-r--r--media-sound/dcd/dcd-0.90.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-sound/dcd/dcd-0.90.ebuild b/media-sound/dcd/dcd-0.90.ebuild
new file mode 100644
index 000000000000..e55ee311a1aa
--- /dev/null
+++ b/media-sound/dcd/dcd-0.90.ebuild
@@ -0,0 +1,34 @@
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ryan Tolboom <ryan@intphsys.com>
+
+S=${WORKDIR}/dcd-0.90
+SRC_URI="http://www.technopagan.org/dcd/dcd-0.90.tar.bz2"
+
+HOMEPAGE="http://www.technopagan.org/dcd"
+
+DESCRIPTION="A simple command-line based CD Player"
+
+DEPEND=">=sys-libs/glibc-2.1.3"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ cat Makefile | sed "s:PREFIX = .*$:PREFIX = \"${D}/usr\":" |\
+ sed "s:# CDROM = /dev/cdroms/cdrom0:CDROM = \"/dev/cdroms/cdrom0\":"\
+ > Makefile
+
+}
+
+src_compile() {
+
+ try make
+
+}
+
+src_install() {
+
+ try make PREFIX=${D}/usr install
+ dodoc README BUGS
+
+}