summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-06-08 16:18:20 +0000
committerSamuli Suominen <drac@gentoo.org>2007-06-08 16:18:20 +0000
commita0ed40179351424c6b8a518125da8b8b5d94877e (patch)
treeeb68af4ac34f24e26ea523f4240ca4440dd47a13 /media-sound/exaile
parentnew version, only bugfixes (diff)
downloadgentoo-2-a0ed40179351424c6b8a518125da8b8b5d94877e.tar.gz
gentoo-2-a0ed40179351424c6b8a518125da8b8b5d94877e.tar.bz2
gentoo-2-a0ed40179351424c6b8a518125da8b8b5d94877e.zip
Byte compile Exaile.
(Portage version: 2.1.2.9)
Diffstat (limited to 'media-sound/exaile')
-rw-r--r--media-sound/exaile/ChangeLog7
-rw-r--r--media-sound/exaile/exaile-0.2.9-r2.ebuild4
-rw-r--r--media-sound/exaile/exaile-0.2.9-r3.ebuild90
-rw-r--r--media-sound/exaile/files/digest-exaile-0.2.9-r33
4 files changed, 101 insertions, 3 deletions
diff --git a/media-sound/exaile/ChangeLog b/media-sound/exaile/ChangeLog
index 64d22c3af43b..f14951fb2a98 100644
--- a/media-sound/exaile/ChangeLog
+++ b/media-sound/exaile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/exaile
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/ChangeLog,v 1.17 2007/06/08 15:59:21 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/ChangeLog,v 1.18 2007/06/08 16:18:20 drac Exp $
+
+*exaile-0.2.9-r3 (08 Jun 2007)
+
+ 08 Jun 2007; Samuli Suominen <drac@gentoo.org> +exaile-0.2.9-r3.ebuild:
+ byte compile exaile.
08 Jun 2007; Samuli Suominen <drac@gentoo.org> exaile-0.2.9-r2.ebuild:
Update mime database.
diff --git a/media-sound/exaile/exaile-0.2.9-r2.ebuild b/media-sound/exaile/exaile-0.2.9-r2.ebuild
index 98d602b31a36..92c762a95689 100644
--- a/media-sound/exaile/exaile-0.2.9-r2.ebuild
+++ b/media-sound/exaile/exaile-0.2.9-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-0.2.9-r2.ebuild,v 1.3 2007/06/08 15:59:21 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-0.2.9-r2.ebuild,v 1.4 2007/06/08 16:18:20 drac Exp $
inherit eutils fdo-mime python toolchain-funcs
@@ -85,4 +85,4 @@ pkg_postinst() {
pkg_postrm() {
fdo-mime_desktop_database_update
fdo-mime_mime_database_update
-}
+}
diff --git a/media-sound/exaile/exaile-0.2.9-r3.ebuild b/media-sound/exaile/exaile-0.2.9-r3.ebuild
new file mode 100644
index 000000000000..d2edfb768bda
--- /dev/null
+++ b/media-sound/exaile/exaile-0.2.9-r3.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-0.2.9-r3.ebuild,v 1.1 2007/06/08 16:18:20 drac Exp $
+
+inherit eutils fdo-mime python toolchain-funcs
+
+GVER="0.10"
+
+MY_P=${PN}_${PV}
+
+DESCRIPTION="a media player aiming to be similar to AmaroK, but for GTK+"
+HOMEPAGE="http://www.exaile.org/"
+SRC_URI="http://www.exaile.org/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="aac alsa cdparanoia flac gnome ipod libnotify libsexy mad musepack ogg
+ oss serpentine streamripper vorbis"
+
+RDEPEND=">=dev-python/pygtk-2.8.6
+ >=dev-python/pysqlite-2
+ >=media-libs/mutagen-1.6
+ dev-python/elementtree
+ >=gnome-base/librsvg-2
+ dev-python/dbus-python
+ libnotify? ( dev-python/notify-python )
+ libsexy? ( dev-python/sexy-python )
+ gnome? ( >=dev-python/gnome-python-extras-2.14
+ >=media-plugins/gst-plugins-gconf-${GVER}
+ >=media-plugins/gst-plugins-gnomevfs-${GVER} )
+ serpentine? ( app-cdr/serpentine )
+ streamripper? ( media-sound/streamripper )
+ >=media-libs/gstreamer-${GVER}
+ >=media-libs/gst-plugins-good-${GVER}
+ >=dev-python/gst-python-${GVER}
+ musepack? ( >=media-plugins/gst-plugins-musepack-${GVER} )
+ vorbis? ( >=media-plugins/gst-plugins-vorbis-${GVER} )
+ flac? ( >=media-plugins/gst-plugins-flac-${GVER} )
+ aac? ( >=media-plugins/gst-plugins-faad-${GVER} )
+ alsa? ( >=media-plugins/gst-plugins-alsa-${GVER} )
+ oss? ( >=media-plugins/gst-plugins-oss-${GVER} )
+ mad? ( >=media-plugins/gst-plugins-mad-${GVER} )
+ ogg? ( >=media-plugins/gst-plugins-ogg-${GVER} )
+ cdparanoia? ( >=media-plugins/gst-plugins-cdparanoia-${GVER}
+ dev-python/cddb-py )
+ ipod? ( >=media-libs/libgpod-0.4
+ >=media-plugins/gst-plugins-faad-${GVER} )"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use ipod && ! built_with_use media-libs/libgpod python ; then
+ eerror "libgpod has to be built with python support"
+ die "libgpod python use-flag not set"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.2.x-strip.patch
+ epatch "${FILESDIR}"/${P}-amazon.patch
+ python_version
+ sed -i -e "s:hon2.4:hon${PYVER}:" mmkeys/Makefile
+}
+
+src_compile() {
+ emake -j1 CC="$(tc-getCC)" || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc testing TODO
+ exeinto /usr/share/${PN}
+ doexe scripts/*
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/media-sound/exaile/files/digest-exaile-0.2.9-r3 b/media-sound/exaile/files/digest-exaile-0.2.9-r3
new file mode 100644
index 000000000000..7fa98eb6bbe1
--- /dev/null
+++ b/media-sound/exaile/files/digest-exaile-0.2.9-r3
@@ -0,0 +1,3 @@
+MD5 d52241d30a66286d9483e30e1259d8d4 exaile_0.2.9.tar.gz 421296
+RMD160 333362939e80f2feb5bd81d51e134cb4d29f74f2 exaile_0.2.9.tar.gz 421296
+SHA256 b8377fd0559a1ca7b98b47348a436b9dc90658b1dde17115b429e907f045ca98 exaile_0.2.9.tar.gz 421296