summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn J. Ellis <jje@gentoo.org>2003-09-21 02:23:39 +0000
committerJohn J. Ellis <jje@gentoo.org>2003-09-21 02:23:39 +0000
commit6cb70f22b3d57ecdccf104b914ce981b2c8a277d (patch)
tree995fb45b8f2ceeb4262039e467f62995ce8ba4f4 /media-sound/fluidsynth
parentVersion bump and improvements. Close #27039. (diff)
downloadgentoo-2-6cb70f22b3d57ecdccf104b914ce981b2c8a277d.tar.gz
gentoo-2-6cb70f22b3d57ecdccf104b914ce981b2c8a277d.tar.bz2
gentoo-2-6cb70f22b3d57ecdccf104b914ce981b2c8a277d.zip
Version bump and improvements. Close #27039.
Diffstat (limited to 'media-sound/fluidsynth')
-rw-r--r--media-sound/fluidsynth/ChangeLog11
-rw-r--r--media-sound/fluidsynth/Manifest4
-rw-r--r--media-sound/fluidsynth/files/digest-fluidsynth-1.0.31
-rw-r--r--media-sound/fluidsynth/fluidsynth-1.0.3.ebuild51
4 files changed, 64 insertions, 3 deletions
diff --git a/media-sound/fluidsynth/ChangeLog b/media-sound/fluidsynth/ChangeLog
index 10b7a95f08b5..687af4849c5f 100644
--- a/media-sound/fluidsynth/ChangeLog
+++ b/media-sound/fluidsynth/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-sound/fluidsynth
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.1 2003/05/24 09:26:43 jje Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.2 2003/09/21 02:23:34 jje Exp $
+
+*fluidsynth-1.0.3 (21 Sep 2003)
+
+ 21 Sep 2003; jje <jje@gentoo.org> fluidsynth-1.0.3.ebuild:
+ Version bump. Now checks USE=sse, codified some comments from Jonathan Kraut
+ on not enabling -msse2 and having USE=sse.
+
+ Submitted by: Jonathan Kraut <krautj@earthlink.net>
+ Rossen Apostolov <rossen@protein.osaka-u.ac.jp>
*fluidsynth-1.0.1 (24 May 2003)
diff --git a/media-sound/fluidsynth/Manifest b/media-sound/fluidsynth/Manifest
index eab07e296c1d..664a106dc905 100644
--- a/media-sound/fluidsynth/Manifest
+++ b/media-sound/fluidsynth/Manifest
@@ -1,5 +1,5 @@
MD5 f4fe95939ff66d3ebd2975d889f71ba1 fluidsynth-1.0.1.ebuild 1392
-MD5 ce3e185dcf6cf833c99def777a8febc0 ChangeLog 393
-MD5 8fb3a3d5ab6e55e0cd171ef577e83ac8 fluidsynth-1.0.3.ebuild 1451
+MD5 6e0058af30013ebf1fd99d89aab6f5b7 ChangeLog 719
+MD5 704bf16f675107d9ef40d9a2ec46a786 fluidsynth-1.0.3.ebuild 1450
MD5 76597f227dd6266c408aab1d4f58da85 files/digest-fluidsynth-1.0.1 68
MD5 751ab7ab31fc6b9ccf266a683545b750 files/digest-fluidsynth-1.0.3 68
diff --git a/media-sound/fluidsynth/files/digest-fluidsynth-1.0.3 b/media-sound/fluidsynth/files/digest-fluidsynth-1.0.3
new file mode 100644
index 000000000000..291e1112ceeb
--- /dev/null
+++ b/media-sound/fluidsynth/files/digest-fluidsynth-1.0.3
@@ -0,0 +1 @@
+MD5 fbdccd05e538626888e27b58d3bdbc2b fluidsynth-1.0.3.tar.gz 867788
diff --git a/media-sound/fluidsynth/fluidsynth-1.0.3.ebuild b/media-sound/fluidsynth/fluidsynth-1.0.3.ebuild
new file mode 100644
index 000000000000..ac4ea3dc5212
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-1.0.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/fluidsynth-1.0.3.ebuild,v 1.1 2003/09/21 02:23:34 jje Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="IIWU Synth is a software real-time synthesizer based on the
+Soundfont 2 specifications."
+HOMEPAGE="http://www.fluidsynth.org/"
+SRC_URI="http://savannah.nongnu.org/download/fluid/stable.pkg/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="alsa ladcca jack sse"
+
+DEPEND="ladcca? ( media-libs/ladcca ) \
+ jack? ( virtual/jack ) \
+ media-libs/ladspa-sdk \
+ alsa? ( media-sound/alsa-driver \
+ media-libs/alsa-lib \
+ media-sound/alsa-utils )"
+
+src_compile() {
+ local myconf
+ myconf="--enable-ladspa"
+ use ladcca || myconf="--disable-ladcca ${myconf}"
+ use alsa || myconf="--disable-alsa ${myconf}"
+ use jack || myconf="--disable-jack-support ${myconf}"
+ if [ `use sse` ]; then
+ myconf="--enable-SSE ${myconf}"
+ # If your CFLAGS include optimizations for sse, ie:
+ # -march=pentium4 -mfpmath=sse -msse2
+ # AND your USE flags include sse, ie: USE=sse,
+ # the sounds with fluidsynth will be distorted.
+ if [ `is-flag "-march=pentium4"` ]; then
+ filter-flags "-msse2"
+ filter-flags "-mfpmath=sse"
+ fi
+ fi
+ econf ${myconf} || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS COPYING INSTALL NEWS README THANKS TODO
+}
+
+