summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-12 06:59:20 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-12 06:59:20 +0000
commitc50d2fbb5827795e4d42220439366aaeed4e4449 (patch)
tree872f868118dbbe0fd2c2b9da81d62a5c7241dd9b /media-sound/jokosher
parentVersion bump. (diff)
downloadgentoo-2-c50d2fbb5827795e4d42220439366aaeed4e4449.tar.gz
gentoo-2-c50d2fbb5827795e4d42220439366aaeed4e4449.tar.bz2
gentoo-2-c50d2fbb5827795e4d42220439366aaeed4e4449.zip
Version bump wrt #260967, thanks to Dennis Lichtenthäler.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/jokosher')
-rw-r--r--media-sound/jokosher/ChangeLog12
-rw-r--r--media-sound/jokosher/files/jokosher-0.11.1-update-database.patch31
-rw-r--r--media-sound/jokosher/jokosher-0.11.1.ebuild57
3 files changed, 97 insertions, 3 deletions
diff --git a/media-sound/jokosher/ChangeLog b/media-sound/jokosher/ChangeLog
index 8d2b81d81ee4..c8f48a181206 100644
--- a/media-sound/jokosher/ChangeLog
+++ b/media-sound/jokosher/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/jokosher
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/jokosher/ChangeLog,v 1.6 2008/11/24 16:10:11 ssuominen Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/jokosher/ChangeLog,v 1.7 2009/05/12 06:59:19 ssuominen Exp $
+
+*jokosher-0.11.1 (12 May 2009)
+
+ 12 May 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +jokosher-0.11.1.ebuild, +files/jokosher-0.11.1-update-database.patch:
+ Version bump wrt #260967, thanks to Dennis Lichtenthäler.
24 Nov 2008; <ssuominen@gentoo.org> metadata.xml:
Re-assign to sound herd.
@@ -16,7 +22,7 @@
*jokosher-0.9 (17 Sep 2007)
- 17 Sep 2007; Samuli Suominen <drac@gentoo.org>
+ 17 Sep 2007; Samuli Suominen <ssuominen@gentoo.org>
+files/jokosher-0.9-desktop-entry.patch,
+files/jokosher-0.9-update-database.patch, +jokosher-0.9.ebuild:
Initial commit for bug 141362, thanks to Denis Gubanov, Eric Anderson, James
diff --git a/media-sound/jokosher/files/jokosher-0.11.1-update-database.patch b/media-sound/jokosher/files/jokosher-0.11.1-update-database.patch
new file mode 100644
index 000000000000..287765b04fc5
--- /dev/null
+++ b/media-sound/jokosher/files/jokosher-0.11.1-update-database.patch
@@ -0,0 +1,31 @@
+diff -ur jokosher-0.11.1.orig/setup.py jokosher-0.11.1/setup.py
+--- jokosher-0.11.1.orig/setup.py 2009-03-17 05:19:23.000000000 +0200
++++ jokosher-0.11.1/setup.py 2009-05-12 09:43:39.000000000 +0300
+@@ -93,27 +93,6 @@
+ call(["scrollkeeper-preinstall", HELPURI[fileNum],
+ installedOmfFiles[fileNum], installedOmfFiles[fileNum]])
+
+- #Update the scrollkeeper catalog
+- if os.geteuid() == 0:
+- print "Updating the scrollkeeper index..."
+- call(["scrollkeeper-update", "-o", installroot + omfdir])
+-
+-# Update the mime types
+-if os.geteuid() == 0 and dist != None:
+- print "Updating the mime-types...."
+-
+- #update the mimetypes database
+- try:
+- call(["update-mime-database", "/usr/share/mime/"])
+- except:
+- pass
+-
+- #update the .desktop file database
+- try:
+- call(["update-desktop-database"])
+- except:
+- pass
+-
+ print "\nInstallation finished! You can now run Jokosher by typing 'jokosher' or through your applications menu icon."
+
+ ## To uninstall manually delete these files/folders:
diff --git a/media-sound/jokosher/jokosher-0.11.1.ebuild b/media-sound/jokosher/jokosher-0.11.1.ebuild
new file mode 100644
index 000000000000..5207b5731c85
--- /dev/null
+++ b/media-sound/jokosher/jokosher-0.11.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/jokosher/jokosher-0.11.1.ebuild,v 1.1 2009/05/12 06:59:19 ssuominen Exp $
+
+NEED_PYTHON=2.4
+inherit eutils gnome2 distutils
+
+DESCRIPTION="A simple yet powerful multi-track studio"
+HOMEPAGE="http://www.jokosher.org"
+SRC_URI="http://launchpad.net/jokosher/0.11/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome"
+
+# NOTE: setuptools are a runtime requirement as the app
+# loads its extensions via pkg_resources
+# Removed gnome-python and pyxml from deps because Ubuntu
+# doesn't dep on them. Let me know if there is trouble, ssuominen.
+RDEPEND="dev-python/dbus-python
+ >=dev-python/gst-python-0.10.8
+ dev-python/pycairo
+ >=dev-python/pygtk-2.10
+ gnome-base/librsvg
+ >=media-libs/gnonlin-0.10.9
+ >=media-libs/gst-plugins-good-0.10.6
+ >=media-libs/gst-plugins-bad-0.10.5
+ >=media-plugins/gst-plugins-alsa-0.10.14
+ >=media-plugins/gst-plugins-flac-0.10.6
+ gnome? ( >=media-plugins/gst-plugins-gnomevfs-0.10.14 )
+ >=media-plugins/gst-plugins-lame-0.10.6
+ >=media-plugins/gst-plugins-ogg-0.10.14
+ >=media-plugins/gst-plugins-vorbis-0.10.14
+ >=media-plugins/gst-plugins-ladspa-0.10.5
+ x11-themes/hicolor-icon-theme
+ dev-python/setuptools
+ dev-python/pyxdg"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper"
+
+PYTHON_MODNAME="Jokosher"
+
+src_unpack() {
+ gnome2_src_unpack
+ epatch "${FILESDIR}"/${P}-update-database.patch
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ gnome2_pkg_postrm
+}