summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2007-02-12 13:55:38 +0000
committerSimon Stelling <blubb@gentoo.org>2007-02-12 13:55:38 +0000
commit978af61f93ebd18b4738b5957ff784fb18e7b566 (patch)
tree78a3b34d13e19069445844da0774d4a5da8d6dff /media-sound/lastfmplayer
parentStable on sparc wrt security #166022 (diff)
downloadgentoo-2-978af61f93ebd18b4738b5957ff784fb18e7b566.tar.gz
gentoo-2-978af61f93ebd18b4738b5957ff784fb18e7b566.tar.bz2
gentoo-2-978af61f93ebd18b4738b5957ff784fb18e7b566.zip
up
(Portage version: 2.1.2-r9)
Diffstat (limited to 'media-sound/lastfmplayer')
-rw-r--r--media-sound/lastfmplayer/ChangeLog6
-rw-r--r--media-sound/lastfmplayer/files/lastfmplayer-1.1.3-pic.patch11
-rw-r--r--media-sound/lastfmplayer/lastfmplayer-1.1.3.ebuild5
3 files changed, 20 insertions, 2 deletions
diff --git a/media-sound/lastfmplayer/ChangeLog b/media-sound/lastfmplayer/ChangeLog
index 4f8f570b9e08..c3880c735daf 100644
--- a/media-sound/lastfmplayer/ChangeLog
+++ b/media-sound/lastfmplayer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/lastfmplayer
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/ChangeLog,v 1.11 2007/02/11 11:17:36 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/ChangeLog,v 1.12 2007/02/12 13:55:38 blubb Exp $
+
+ 12 Feb 2007; Simon Stelling <blubb@gentoo.org>
+ +files/lastfmplayer-1.1.3-pic.patch, lastfmplayer-1.1.3.ebuild:
+ fix fPIC issues; bug 166451
*lastfmplayer-1.1.3 (11 Feb 2007)
diff --git a/media-sound/lastfmplayer/files/lastfmplayer-1.1.3-pic.patch b/media-sound/lastfmplayer/files/lastfmplayer-1.1.3-pic.patch
new file mode 100644
index 000000000000..5ad22ae98023
--- /dev/null
+++ b/media-sound/lastfmplayer/files/lastfmplayer-1.1.3-pic.patch
@@ -0,0 +1,11 @@
+--- src/Makefile 2007-02-11 19:39
++++ src/Makefile 2007-02-11 19:40
+@@ -828,7 +828,7 @@
+ $(CXX) -c $(CXXFLAGS) $(INCPATH) -o build/main.o main.cpp
+
+ build/Loqqer.o: Loqqer.cpp Loqqer.h
+- $(CXX) -c $(CXXFLAGS) $(INCPATH) -o build/Loqqer.o Loqqer.cpp
++ $(CXX) -c $(CXXFLAGS) -fPIC $(INCPATH) -o build/Loqqer.o Loqqer.cpp
+
+ build/container.o: container.cpp container.h \
+ playerlistener.h \
diff --git a/media-sound/lastfmplayer/lastfmplayer-1.1.3.ebuild b/media-sound/lastfmplayer/lastfmplayer-1.1.3.ebuild
index ce66e163e8f9..d7f7f1823e7d 100644
--- a/media-sound/lastfmplayer/lastfmplayer-1.1.3.ebuild
+++ b/media-sound/lastfmplayer/lastfmplayer-1.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/lastfmplayer-1.1.3.ebuild,v 1.1 2007/02/11 11:17:36 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/lastfmplayer-1.1.3.ebuild,v 1.2 2007/02/12 13:55:38 blubb Exp $
inherit eutils versionator
@@ -21,6 +21,9 @@ DEPEND=">=x11-libs/qt-4.2
src_compile() {
./configure
+ emake -j1 qmake_all || die "emake qmake_all failed"
+ epatch ${FILESDIR}/${P}-pic.patch
+
emake -j1 || die "emake failed"
}