summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-11-09 20:05:16 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-11-09 20:05:16 +0000
commitc8821034b1d8592349c5443c7bc7c5d4298cbb7d (patch)
tree6f3e9fa6f56f61705b9a1c535e9f9155f77832c6 /media-sound/nted
parentDrop dev-python/papyon dependency per bug #434690 (diff)
downloadgentoo-2-c8821034b1d8592349c5443c7bc7c5d4298cbb7d.tar.gz
gentoo-2-c8821034b1d8592349c5443c7bc7c5d4298cbb7d.tar.bz2
gentoo-2-c8821034b1d8592349c5443c7bc7c5d4298cbb7d.zip
Add patch for fixing invalid lilypond export markup. Thanks to Christopher Harvey <chris@basementcode.com>. Bug #437540. Adding him as proxy maintainer
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'media-sound/nted')
-rw-r--r--media-sound/nted/ChangeLog9
-rw-r--r--media-sound/nted/files/nted-1.10.18-lilypond.patch58
-rw-r--r--media-sound/nted/metadata.xml10
-rw-r--r--media-sound/nted/nted-1.10.18-r1.ebuild49
4 files changed, 118 insertions, 8 deletions
diff --git a/media-sound/nted/ChangeLog b/media-sound/nted/ChangeLog
index dfa24a7e8bfd..7b3c8a828ad7 100644
--- a/media-sound/nted/ChangeLog
+++ b/media-sound/nted/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/nted
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/nted/ChangeLog,v 1.28 2012/07/12 19:08:53 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/nted/ChangeLog,v 1.29 2012/11/09 20:05:16 hwoarang Exp $
+
+*nted-1.10.18-r1 (09 Nov 2012)
+
+ 09 Nov 2012; Markos Chandras <hwoarang@gentoo.org>
+ +files/nted-1.10.18-lilypond.patch, +nted-1.10.18-r1.ebuild, metadata.xml:
+ Add patch for fixing invalid lilypond export markup. Thanks to Christopher
+ Harvey <chris@basementcode.com>. Bug #437540. Adding him as proxy maintainer
12 Jul 2012; Markos Chandras <hwoarang@gentoo.org>
+files/nted-1.10.18-gcc47.patch, nted-1.10.18.ebuild:
diff --git a/media-sound/nted/files/nted-1.10.18-lilypond.patch b/media-sound/nted/files/nted-1.10.18-lilypond.patch
new file mode 100644
index 000000000000..d1e77849e679
--- /dev/null
+++ b/media-sound/nted/files/nted-1.10.18-lilypond.patch
@@ -0,0 +1,58 @@
+From 54881f2bdfc3d18e1496b7739124311d8e7c394a Mon Sep 17 00:00:00 2001
+From: Christopher Harvey <chris@basementcode.com>
+Date: Sun, 7 Oct 2012 15:05:03 -0400
+Subject: [PATCH] Fix LilyPond clef exporting
+
+For example, sometimes NtEd would export "\clef \clef tenor" instead
+of just "\clef tenor"
+---
+ mainwindow.cpp | 4 +++-
+ resource.cpp | 14 +++++++-------
+ 2 files changed, 10 insertions(+), 8 deletions(-)
+
+diff --git a/mainwindow.cpp b/mainwindow.cpp
+index 7263565..3343526 100644
+--- a/mainwindow.cpp
++++ b/mainwindow.cpp
+@@ -3902,7 +3902,9 @@ void NedMainWindow::do_lily_export(FILE *fp, bool with_break, bool *selected_sta
+ if (m_staff_contexts[i].m_staff_short_name != NULL && strlen(m_staff_contexts[i].m_staff_short_name->getText()) > 0) {
+ fprintf(fp, " \\set Staff.shortInstrumentName = \"%s \"", m_staff_contexts[i].m_staff_short_name->getText());
+ }
+- fprintf(fp, NedResource::getLilyPondClefName(m_staff_contexts[i].m_clef_number));
++ if (m_staff_contexts[i].m_clef_number != NEUTRAL_CLEF3) {
++ fprintf(fp, "\\clef %s", NedResource::getLilyPondClefName(m_staff_contexts[i].m_clef_number));
++ }
+ fprintf(fp, NedResource::getLilyPondKeySigName(m_staff_contexts[i].m_key_signature_number));
+ fprintf(fp, " \\time %d/%d", m_numerator, m_denominator);
+ if (m_upbeat_inverse != 0) {
+diff --git a/resource.cpp b/resource.cpp
+index 11c52b4..cff080f 100644
+--- a/resource.cpp
++++ b/resource.cpp
+@@ -3870,16 +3870,16 @@ int NedResource::determineLastLine(int treble_line, int clef) {
+
+ const char *NedResource::getLilyPondClefName(int clef_number) {
+ switch (clef_number) {
+- case TREBLE_CLEF: return "\\clef treble";
+- case BASS_CLEF: return "\\clef bass";
+- case ALTO_CLEF: return "\\clef alto";
+- case SOPRAN_CLEF: return "\\clef soprano";
+- case TENOR_CLEF: return "\\clef tenor";
++ case TREBLE_CLEF: return "treble";
++ case BASS_CLEF: return "bass";
++ case ALTO_CLEF: return "alto";
++ case SOPRAN_CLEF: return "soprano";
++ case TENOR_CLEF: return "tenor";
+ case NEUTRAL_CLEF1:
+- case NEUTRAL_CLEF2: return "\\clef percussion";
++ case NEUTRAL_CLEF2: return "percussion";
+ case NEUTRAL_CLEF3: return "";
+ }
+- return "\\clef treble";
++ return "treble";
+ }
+ const char *NedResource::getLilyPondKeySigName(int keysig_number) {
+ switch (keysig_number) {
+--
+1.7.8.6
+
diff --git a/media-sound/nted/metadata.xml b/media-sound/nted/metadata.xml
index 79531f8f111a..af15c1cf940b 100644
--- a/media-sound/nted/metadata.xml
+++ b/media-sound/nted/metadata.xml
@@ -1,14 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sound</herd>
+<herd>proxy-maintainers</herd>
<maintainer>
-<email>hwoarang@gentoo.org</email>
-<name>Markos Chandras</name>
-</maintainer>
-<maintainer>
-<email>gentoo@cconstruct.de</email>
-<name>Matthias Vill</name>
+<email>chris@basementcode.com</email>
+<name>Christopher Harvey</name>
<description>Proxy maintainer</description>
</maintainer>
<longdescription lang="en">
diff --git a/media-sound/nted/nted-1.10.18-r1.ebuild b/media-sound/nted/nted-1.10.18-r1.ebuild
new file mode 100644
index 000000000000..7b972c0c3de5
--- /dev/null
+++ b/media-sound/nted/nted-1.10.18-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/nted/nted-1.10.18-r1.ebuild,v 1.1 2012/11/09 20:05:16 hwoarang Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="WYSIWYG score editor for GTK+"
+HOMEPAGE="http://vsr.informatik.tu-chemnitz.de/staff/jan/nted/nted.xhtml"
+SRC_URI="http://vsr.informatik.tu-chemnitz.de/staff/jan/${PN}/sources/${P}.tar.gz"
+
+LICENSE="GPL-2 FDL-1.2 NTED_FONT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug nls"
+
+RDEPEND=">=dev-libs/glib-2
+ media-libs/alsa-lib
+ >=media-libs/freetype-2
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-text/xmlto )
+ nls? ( sys-devel/gettext )"
+
+DOCS="ABOUT_THE_EXAMPLES.TXT AUTHORS FAQ README"
+
+src_prepare() {
+ # bug #424291
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+ # bug #437540
+ epatch "${FILESDIR}"/${P}-lilypond.patch
+}
+
+src_configure() {
+ # Trick ./configure to believe we have gnome-extra/yelp installed.
+ has_version gnome-extra/yelp || export ac_cv_path_YELP="$(type -P true)"
+
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_with doc)
+}